summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-08-09 20:19:03 +0200
committerUlrich Müller <ulm@gentoo.org>2018-08-09 20:19:49 +0200
commit3dc243c8b8690b0721cb44335850ec1c36afad19 (patch)
treea2d096c49ac5312e12705b3bb0839c0bdc4435a6 /app-emacs/mailcrypt
parentapp-emacs/gnuserv: Fix runtime failure with Emacs 27. (diff)
downloadgentoo-3dc243c8b8690b0721cb44335850ec1c36afad19.tar.gz
gentoo-3dc243c8b8690b0721cb44335850ec1c36afad19.tar.bz2
gentoo-3dc243c8b8690b0721cb44335850ec1c36afad19.zip
app-emacs/mailcrypt: Fix build failure with Emacs 27.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'app-emacs/mailcrypt')
-rw-r--r--app-emacs/mailcrypt/files/mailcrypt-3.5.9-backquotes.patch11
-rw-r--r--app-emacs/mailcrypt/mailcrypt-3.5.9-r1.ebuild44
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/mailcrypt/files/mailcrypt-3.5.9-backquotes.patch b/app-emacs/mailcrypt/files/mailcrypt-3.5.9-backquotes.patch
new file mode 100644
index 000000000000..7cacdbb9e482
--- /dev/null
+++ b/app-emacs/mailcrypt/files/mailcrypt-3.5.9-backquotes.patch
@@ -0,0 +1,11 @@
+--- mailcrypt-3.5.9-orig/mc-gpg.el
++++ mailcrypt-3.5.9/mc-gpg.el
+@@ -108,7 +108,7 @@
+ (defmacro with-current-buffer (buffer &rest body)
+ "Execute the forms in BODY with BUFFER as the current buffer.
+ The value returned is the value of the last form in BODY."
+- (` (save-excursion (set-buffer (, buffer)) (,@ body)))))
++ `(save-excursion (set-buffer (, buffer)) (,@ body))))
+ )
+
+ (defun mc-gpg-debug-print (string)
diff --git a/app-emacs/mailcrypt/mailcrypt-3.5.9-r1.ebuild b/app-emacs/mailcrypt/mailcrypt-3.5.9-r1.ebuild
new file mode 100644
index 000000000000..7de100b9da94
--- /dev/null
+++ b/app-emacs/mailcrypt/mailcrypt-3.5.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 elisp autotools
+
+DESCRIPTION="Provides a simple interface to public key cryptography with OpenPGP"
+HOMEPAGE="http://mailcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mailcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+RESTRICT="test"
+
+RDEPEND="app-crypt/gnupg"
+
+ELISP_PATCHES="${P}-backquotes.patch"
+ELISP_REMOVE="FSF-timer.el" # remove bundled timer.el
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ export EMACS
+ econf
+}
+
+src_install() {
+ emake \
+ lispdir="${D}${SITELISP}/${PN}" \
+ infodir="${D}/usr/share/info" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ANNOUNCE ChangeLog* INSTALL LCD-entry NEWS ONEWS README*
+
+ DOC_CONTENTS="See the INSTALL file in /usr/share/doc/${PF} for how
+ to customize mailcrypt."
+ readme.gentoo_create_doc
+}