summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-11 08:44:34 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-11 08:44:34 +0100
commit46b9dfba2a81410b87d0b4589e6114ff1d3f7fa8 (patch)
tree67f33cfb0b262dd5901d02f36b1776cc3b0f5e59 /app-emacs/ghc-mod
parentdev-ruby/gettext_i18n_rails: add 1.8.1 (diff)
downloadgentoo-46b9dfba2a81410b87d0b4589e6114ff1d3f7fa8.tar.gz
gentoo-46b9dfba2a81410b87d0b4589e6114ff1d3f7fa8.tar.bz2
gentoo-46b9dfba2a81410b87d0b4589e6114ff1d3f7fa8.zip
app-emacs: Remove unnecessary die statements after eclass functions.
Functions elisp-compile, elisp-install, and elisp-site-file-install from elisp-common.eclass all die by themselves. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/ghc-mod')
-rw-r--r--app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild2
-rw-r--r--app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild2
-rw-r--r--app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild b/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild
index 9803686ef359..a54c351b2c4e 100644
--- a/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild
+++ b/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild
@@ -60,7 +60,7 @@ src_compile() {
haskell-cabal_src_compile
if use emacs ; then
pushd elisp
- elisp-compile *.el || die
+ elisp-compile *.el
popd
fi
}
diff --git a/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild b/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild
index b67184547ee0..122d5f8ea2cd 100644
--- a/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild
+++ b/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild
@@ -60,7 +60,7 @@ src_compile() {
haskell-cabal_src_compile
if use emacs ; then
pushd elisp
- elisp-compile *.el || die
+ elisp-compile *.el
popd
fi
}
diff --git a/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild b/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild
index fb6256d2db11..f054faba6519 100644
--- a/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild
+++ b/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild
@@ -55,7 +55,7 @@ src_compile() {
haskell-cabal_src_compile
if use emacs ; then
pushd elisp
- elisp-compile *.el || die
+ elisp-compile *.el
popd
fi
}