summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-15 22:30:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-16 00:07:33 +0100
commitb657232dc48cfac3f07ef7fa2b3986c86a428ca0 (patch)
tree1b08daedc51360fb658766f87fef158627f1102d /app-editors
parentapp-editors/leafpad: Switch from gnome2-utils to xdg, EAPI-7 bump (diff)
downloadgentoo-b657232dc48cfac3f07ef7fa2b3986c86a428ca0.tar.gz
gentoo-b657232dc48cfac3f07ef7fa2b3986c86a428ca0.tar.bz2
gentoo-b657232dc48cfac3f07ef7fa2b3986c86a428ca0.zip
app-editors/tea: 47.0.0 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/tea/Manifest1
-rw-r--r--app-editors/tea/tea-47.0.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/tea/Manifest b/app-editors/tea/Manifest
index 3355b17492ba..16837ba57a82 100644
--- a/app-editors/tea/Manifest
+++ b/app-editors/tea/Manifest
@@ -1 +1,2 @@
DIST tea-44.1.1.tar.bz2 425326 BLAKE2B e674456c428bbecd5afb256280bccb61b6385492153955625c158dcfebba0ed31caebdcc06bc1f809517badddef3d97245a4bc873bcc0593957647becdebf62b SHA512 fc7bf6f76ac3a48767a39ff5bcada4c7dae40950bfd9aca4021b3581e1b702c73f2608b070306dd528932d5eaa73bf01632a4376bbb71deaf1189a0f790c05a9
+DIST tea-47.0.0.tar.bz2 437273 BLAKE2B 8ed36526dedc6df4af74ef0e400c2ee2e19bb533cf2a4fa51df83f21ad78abb0e8e90bce3469e2e8db5f780ba8a900aedf2737c736945431b836ba0a76574b26 SHA512 7136d59383bf43c6a024a31aa29860a3e89893ff091a42f44f9e7088fb318920ab886cd1fdabc8ff6e3c30f8eb3d46d707228d2d45fb085ed7c822a4ffd89d13
diff --git a/app-editors/tea/tea-47.0.0.ebuild b/app-editors/tea/tea-47.0.0.ebuild
new file mode 100644
index 000000000000..fb73c864181b
--- /dev/null
+++ b/app-editors/tea/tea-47.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="https://tea.ourproject.org/"
+SRC_URI="https://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aspell djvu hunspell pdf +qml"
+
+BDEPEND="
+ hunspell? ( virtual/pkgconfig )
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ djvu? ( app-text/djvu )
+ hunspell? ( app-text/hunspell:= )
+ pdf? ( app-text/poppler[qt5] )
+ qml? ( dev-qt/qtdeclarative:5 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
+
+src_configure() {
+ local myqmakeargs=(
+ PREFIX=/usr
+ $(usex aspell '' CONFIG+=noaspell)
+ $(usex djvu CONFIG+=usedjvu '')
+ $(usex hunspell '' CONFIG+=nohunspell)
+ $(usex pdf CONFIG+=usepoppler '')
+ $(usex qml '' CONFIG+=noqml)
+ )
+ eqmake5 tea-qmake.pro "${myqmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ docinto html
+ dodoc manuals/*.html
+
+ insinto /usr/share/qt5/translations
+ doins translations/${PN}_*.qm
+}