summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-22 18:13:52 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-22 18:16:15 +0200
commit4340eb85c2d4859037b858bb58e2f77d7f79d9f7 (patch)
tree2bcdf1feeb141f0f1fd04b190d89aef7d5c80a21 /app-editors
parentapp-editors/emacs-vcs: Upstream change of version number. (diff)
downloadgentoo-4340eb85c2d4859037b858bb58e2f77d7f79d9f7.tar.gz
gentoo-4340eb85c2d4859037b858bb58e2f77d7f79d9f7.tar.bz2
gentoo-4340eb85c2d4859037b858bb58e2f77d7f79d9f7.zip
app-editors/emacs: Install systemd unit file.
Closes: https://bugs.gentoo.org/694542 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-26.3-r1.ebuild (renamed from app-editors/emacs/emacs-26.3.ebuild)9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-26.3.ebuild b/app-editors/emacs/emacs-26.3-r1.ebuild
index 0e312adbbbb7..40ca9d580196 100644
--- a/app-editors/emacs/emacs-26.3.ebuild
+++ b/app-editors/emacs/emacs-26.3-r1.ebuild
@@ -281,6 +281,15 @@ src_install () {
# remove COPYING file (except for etc/COPYING used by describe-copying)
rm "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp/COPYING
+ if use systemd; then
+ insinto /usr/lib/systemd/user
+ sed -e "/^##/d" \
+ -e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
+ -e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
+ etc/emacs.service | newins - ${EMACS_SUFFIX}.service
+ assert
+ fi
+
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \