summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-11-13 15:05:40 +0100
committerSam James <sam@gentoo.org>2022-11-15 02:08:48 +0000
commit4d3d40a29078d1796ed26b83d5a823155a5ce015 (patch)
tree9da87b69f667c20916908bf58739192c80bb0d56 /app-editors/xvile
parentapp-misc/wcd: version bump to 6.0.4, fix clang16 build (diff)
downloadgentoo-4d3d40a29078d1796ed26b83d5a823155a5ce015.tar.gz
gentoo-4d3d40a29078d1796ed26b83d5a823155a5ce015.tar.bz2
gentoo-4d3d40a29078d1796ed26b83d5a823155a5ce015.zip
app-editors/xvile: fix build for clang16
Closes: https://bugs.gentoo.org/880941 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/28255 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/files/xvile-9.8w-fix-build-for-clang16.patch27
-rw-r--r--app-editors/xvile/xvile-9.8w-r1.ebuild (renamed from app-editors/xvile/xvile-9.8w.ebuild)2
2 files changed, 29 insertions, 0 deletions
diff --git a/app-editors/xvile/files/xvile-9.8w-fix-build-for-clang16.patch b/app-editors/xvile/files/xvile-9.8w-fix-build-for-clang16.patch
new file mode 100644
index 000000000000..df5b6d605054
--- /dev/null
+++ b/app-editors/xvile/files/xvile-9.8w-fix-build-for-clang16.patch
@@ -0,0 +1,27 @@
+Clang16 will not allow implicit function pointer types by default.
+
+Bug: https://bugs.gentoo.org/880941
+Upstream Bug report and patch: https://savannah.nongnu.org/bugs/index.php?63356
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+--- a/x11.c
++++ b/x11.c
+@@ -2259,7 +2259,7 @@ x_preparse_args(int *pargc, char ***pargv)
+ if (isEmpty(xvile_class))
+ xvile_class = MY_CLASS;
+
+- XtSetErrorHandler(initial_error_handler);
++ XtSetErrorHandler((__attribute__((noreturn)) XtErrorHandler)runtime_error_handler);
+ memset(cur_win, 0, sizeof(*cur_win));
+ cur_win->top_widget = XtVaAppInitialize(&cur_win->app_context,
+ xvile_class,
+@@ -2269,7 +2269,7 @@ x_preparse_args(int *pargc, char ***pargv)
+ Nval(XtNgeometry, NULL),
+ Nval(XtNinput, TRUE),
+ NULL);
+- XtSetErrorHandler(runtime_error_handler);
++ XtSetErrorHandler((__attribute__((noreturn)) XtErrorHandler)runtime_error_handler);
+ dpy = XtDisplay(cur_win->top_widget);
+
+ XtVaGetValues(cur_win->top_widget,
diff --git a/app-editors/xvile/xvile-9.8w.ebuild b/app-editors/xvile/xvile-9.8w-r1.ebuild
index 2d85fe5b7359..081a230fd55d 100644
--- a/app-editors/xvile/xvile-9.8w.ebuild
+++ b/app-editors/xvile/xvile-9.8w-r1.ebuild
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
sys-devel/flex"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}"-fix-build-for-clang16.patch )
+
S="${WORKDIR}"/${MY_P}
src_configure() {