summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-21 19:40:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-21 23:04:17 +0200
commit4ceb19e276bcdd7669911281457c0c025a7f6858 (patch)
tree66b4b457dc1e2183d2f6155da14e57986142dc12 /app-editors/texworks
parentapp-office/texmaker: add 5.1.4, EAPI-8 bump (diff)
downloadgentoo-4ceb19e276bcdd7669911281457c0c025a7f6858.tar.gz
gentoo-4ceb19e276bcdd7669911281457c0c025a7f6858.tar.bz2
gentoo-4ceb19e276bcdd7669911281457c0c025a7f6858.zip
app-editors/texworks: add 0.6.8, EAPI-8 bump, python3_12, drop virtualx
- add missing dev-qt/qttest:5 dependency - dev-qt/qtscript:5 was replaced by dev-qt/qtdeclarative:5 - fix upstream's "optional" (really not) Qt5Script in build system Bug: https://bugs.gentoo.org/915780 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/texworks')
-rw-r--r--app-editors/texworks/Manifest1
-rw-r--r--app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch25
-rw-r--r--app-editors/texworks/texworks-0.6.8.ebuild84
3 files changed, 110 insertions, 0 deletions
diff --git a/app-editors/texworks/Manifest b/app-editors/texworks/Manifest
index 59ca10e2c65d..eba2967aa0d0 100644
--- a/app-editors/texworks/Manifest
+++ b/app-editors/texworks/Manifest
@@ -1 +1,2 @@
DIST texworks-0.6.7.tar.gz 12394465 BLAKE2B 0a2e0531ef0f296cd2be176baed14eb0c21733aeaf3ca3c43e3ff02e48bf68be8953db67f955db0b5a56676b391e2f7700404e9ea52907092d58cbbccaa02adf SHA512 b1c22c1f9bfae2595e77f0c98297cc690f62aac38125bb576d57cc3a0666d779e75af23ccf430a3547215065596b4ea60758233947cda06df8e1a7fc95c46b65
+DIST texworks-0.6.8.tar.gz 12486607 BLAKE2B a7de78adc0746c57b721a400a704d3912574933604e01124a99f5a60ba377ba66ce8d57f5f0a87e336de715d981146db6b8ae61a78c744b385c698fcdad2f7fe SHA512 23164f9ab2f611a705b533f4c435891f1279d1e0e0de2d7f947864f8919a6513cb696881dc1dcf93345471599f113d264ced57cbd2dceae343b9dde46ee80482
diff --git a/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
new file mode 100644
index 000000000000..460c4f4f7e2d
--- /dev/null
+++ b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
@@ -0,0 +1,25 @@
+It doesn't work like that.
+
+--- a/CMakeLists.txt 2023-02-18 11:42:11.000000000 +0100
++++ b/CMakeLists.txt 2023-10-21 20:00:29.144638825 +0200
+@@ -281,9 +281,11 @@
+ set(QT_VERSION_PATCH "${Qt6_VERSION_PATCH}")
+ else ()
+ # Check for Qt5
+- find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml OPTIONAL_COMPONENTS Script ScriptTools)
++ find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml)
+ set(QT_LIBRARIES Qt5::Core Qt5::Widgets Qt5::Gui Qt5::UiTools Qt5::Concurrent Qt5::Xml Qt5::Qml)
+
++ find_package(Qt5Script)
++ find_package(Qt5ScriptTools)
+ if (Qt5Script_FOUND AND Qt5ScriptTools_FOUND)
+ list(APPEND QT_LIBRARIES Qt5::ScriptTools Qt5::Script)
+ set(WITH_QTSCRIPT ON)
+@@ -311,7 +313,6 @@
+ set(QT_VERSION_MAJOR "${Qt5_VERSION_MAJOR}")
+ set(QT_VERSION_MINOR "${Qt5_VERSION_MINOR}")
+ set(QT_VERSION_PATCH "${Qt5_VERSION_PATCH}")
+- set(WITH_QTSCRIPT ON)
+ endif ()
+
+ # Expose the major version number of Qt to the preprocessor. This is necessary
diff --git a/app-editors/texworks/texworks-0.6.8.ebuild b/app-editors/texworks/texworks-0.6.8.ebuild
new file mode 100644
index 000000000000..532ab36b69d9
--- /dev/null
+++ b/app-editors/texworks/texworks-0.6.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} )
+PYTHON_COMPAT=( python3_{9..12} )
+CMAKE_REMOVE_MODULES_LIST=( FindLua )
+inherit lua-single python-single-r1 cmake xdg
+
+DESCRIPTION="Simple interface for working with TeX documents"
+HOMEPAGE="https://tug.org/texworks/"
+SRC_URI="https://github.com/TeXworks/texworks/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-release-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="lua python test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ app-text/hunspell:=
+ app-text/poppler[qt5]
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.5-cmake_lua_version.patch
+ "${FILESDIR}"/${P}-optional-qtscript.patch
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Wno-dev
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Script=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5ScriptTools=ON
+ -DPREFER_BUNDLED_SYNCTEX=ON
+ -DWITH_LUA=$(usex lua)
+ -DWITH_PYTHON=$(usex python)
+ -DWITH_TESTS=$(usex test)
+ -DTeXworks_PLUGIN_DIR="/usr/$(get_libdir)/texworks"
+ -DTeXworks_DOCS_DIR="/share/doc/${PF}"
+ -DQTPDF_VIEWER=ON
+ -DBUILD_SHARED_PLUGINS=ON
+ )
+
+ use lua && mycmakeargs+=( -DLUA_VERSION="$(lua_get_version)" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ cmake_src_test
+}