summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-06-29 09:38:13 +0200
committerSam James <sam@gentoo.org>2022-06-29 09:09:09 +0000
commit6f0a95daae18c8bb7c99acd1a3430651e2d6ca75 (patch)
tree099a615a10f1997488cdbb9a69ae7947a18b9004 /app-editors/nano
parentmail-mta/exim-4.96-r1: revbump for pcre2 dep change (diff)
downloadgentoo-6f0a95daae18c8bb7c99acd1a3430651e2d6ca75.tar.gz
gentoo-6f0a95daae18c8bb7c99acd1a3430651e2d6ca75.tar.bz2
gentoo-6f0a95daae18c8bb7c99acd1a3430651e2d6ca75.zip
app-editors/nano: Warn in pkg_postrm about updating EDITOR
Closes: https://bugs.gentoo.org/819342 Signed-off-by: Ulrich Müller <ulm@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/26133 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/nano-6.3.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-editors/nano/nano-6.3.ebuild b/app-editors/nano/nano-6.3.ebuild
index 9bd57c68b191..ff0fcf25cd44 100644
--- a/app-editors/nano/nano-6.3.ebuild
+++ b/app-editors/nano/nano-6.3.ebuild
@@ -91,3 +91,12 @@ src_install() {
use split-usr && dosym ../../bin/nano /usr/bin/nano
}
+
+pkg_postrm() {
+ local e
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}