summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/mousepad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest2
-rw-r--r--app-editors/mousepad/files/mousepad-0.3.0-validate.patch17
-rw-r--r--app-editors/mousepad/metadata.xml11
-rw-r--r--app-editors/mousepad/mousepad-0.3.0.ebuild36
-rw-r--r--app-editors/mousepad/mousepad-0.4.0.ebuild47
5 files changed, 113 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
new file mode 100644
index 000000000000..d069a48c3f9c
--- /dev/null
+++ b/app-editors/mousepad/Manifest
@@ -0,0 +1,2 @@
+DIST mousepad-0.3.0.tar.bz2 481125 SHA256 10f27506994d0d0b8f9e02555404a144babedab97517abe3b6be8b2d21ff046d SHA512 4e8f7cd8f05265c7f3964f0f5196721136c501351aa8c7bae1e3a6056fcd61f40364f2bb226817d458afa3707334dd600efbae2f8d050d65841ef03085717e42 WHIRLPOOL ed3582231bca8d3ea1f5a4adaf6279cd48d3628ba1154db80c6fb037b0efacbaf7535dad9bb4631982cfa5ee73514a628c340cb017514b0ab29d028b3c974b1c
+DIST mousepad-0.4.0.tar.bz2 578483 SHA256 60114431eac8db6bb6ce18bd38f1630cccb684375b97a445a1b6fd619848d132 SHA512 5196abd04268d1ace118dc485b72bfcfb7f9175eeaf52bc97c08c1646371d26401403a3bb199d882380bcb998547c65af9bd054f0365afd846c0ad74d3c3b1fe WHIRLPOOL dd087f38d75836d28cdae3a851d2ede0246a66db104710bab919928d32b63e470c95d77ff09c34c92e90322f14d5f85f83dc913acc529b8dd95ad8bc2712b9c1
diff --git a/app-editors/mousepad/files/mousepad-0.3.0-validate.patch b/app-editors/mousepad/files/mousepad-0.3.0-validate.patch
new file mode 100644
index 000000000000..dbbd31fb786d
--- /dev/null
+++ b/app-editors/mousepad/files/mousepad-0.3.0-validate.patch
@@ -0,0 +1,17 @@
+--- mousepad.desktop.in.in
++++ mousepad.desktop.in.in
+@@ -1,6 +1,4 @@
+-
+ [Desktop Entry]
+-Encoding=UTF-8
+ _Name=Mousepad
+ _Comment=Simple Text Editor
+ _GenericName=Text Editor
+@@ -9,5 +7,5 @@
+ Terminal=false
+ StartupNotify=true
+ Type=Application
+-Categories=Application;Utility;TextEditor;GTK;
+-MimeType=text/plain
++Categories=Utility;TextEditor;GTK;
++MimeType=text/plain;
diff --git a/app-editors/mousepad/metadata.xml b/app-editors/mousepad/metadata.xml
new file mode 100644
index 000000000000..6b976badcbc7
--- /dev/null
+++ b/app-editors/mousepad/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name='gtk3'>Use GTK+3 instead of GTK+2</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-editors/mousepad/mousepad-0.3.0.ebuild b/app-editors/mousepad/mousepad-0.3.0.ebuild
new file mode 100644
index 000000000000..34d66f0ed058
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="GTK+ 2.x based editor for the Xfce Desktop Environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/start"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug dbus"
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/gtksourceview:2.0
+ dbus? ( >=dev-libs/dbus-glib-0.100 )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-validate.patch )
+
+ XFCONF=(
+ $(xfconf_use_debug)
+ $(use_enable dbus)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
diff --git a/app-editors/mousepad/mousepad-0.4.0.ebuild b/app-editors/mousepad/mousepad-0.4.0.ebuild
new file mode 100644
index 000000000000..d5941cb8a15c
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome2-utils xfconf
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/start"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug dbus gtk3"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ dbus? ( >=dev-libs/dbus-glib-0.100:0= )
+ !gtk3? ( >=x11-libs/gtk+-2.24:2=
+ x11-libs/gtksourceview:2.0= )
+ gtk3? ( x11-libs/gtk+:3=
+ x11-libs/gtksourceview:3.0= )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ $(use_enable dbus)
+ $(use_enable gtk3)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+pkg_preinst() {
+ xfconf_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ gnome2_schemas_update
+}