summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-12-11 12:40:25 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-12-11 12:40:46 -0600
commit252cc3a9cabddf1d50185796b4e60e4de5ba2476 (patch)
tree779926addce0f06b7fbdf90d31fd69e42e6302e5 /app-crypt/certbot
parentdev-lang/python: arm64 stable (bug #701116) (diff)
downloadgentoo-252cc3a9cabddf1d50185796b4e60e4de5ba2476.tar.gz
gentoo-252cc3a9cabddf1d50185796b4e60e4de5ba2476.tar.bz2
gentoo-252cc3a9cabddf1d50185796b4e60e4de5ba2476.zip
app-crypt/certbot: fix dep on acme
Fixes: https://bugs.gentoo.org/702542 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/certbot-1.0.0-r1.ebuild52
-rw-r--r--app-crypt/certbot/certbot-1.0.0.ebuild2
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild2
3 files changed, 54 insertions, 2 deletions
diff --git a/app-crypt/certbot/certbot-1.0.0-r1.ebuild b/app-crypt/certbot/certbot-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..37c17aa225d3
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.0.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/certbot
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # acme is not installed, removing it here is fine, the dir just confuses tests
+ rm -R acme
+ pytest -vv ${PN} || die
+}
diff --git a/app-crypt/certbot/certbot-1.0.0.ebuild b/app-crypt/certbot/certbot-1.0.0.ebuild
index f7e5d6d043a7..37c17aa225d3 100644
--- a/app-crypt/certbot/certbot-1.0.0.ebuild
+++ b/app-crypt/certbot/certbot-1.0.0.ebuild
@@ -27,7 +27,7 @@ RESTRICT="!test? ( test )"
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
${CDEPEND}
- >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 39028621e8f0..e59b628d2009 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -25,7 +25,7 @@ RESTRICT="!test? ( test )"
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
${CDEPEND}
- >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]