summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-03 12:01:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-03 12:01:29 -0500
commitd833ca93b8b0aec085cf14b40bd7cb681dabfb82 (patch)
treeea160a7e9f36df60b17c562ffd859301eaa960bd /app-crypt/acme
parentapp-crypt/certbot-nginx: 0.34.0 bump (diff)
downloadgentoo-d833ca93b8b0aec085cf14b40bd7cb681dabfb82.tar.gz
gentoo-d833ca93b8b0aec085cf14b40bd7cb681dabfb82.tar.bz2
gentoo-d833ca93b8b0aec085cf14b40bd7cb681dabfb82.zip
app-crypt/acme: 0.33.1 stable amd64/x86
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/acme-0.33.1-r1.ebuild2
-rw-r--r--app-crypt/acme/acme-0.33.1.ebuild48
2 files changed, 1 insertions, 49 deletions
diff --git a/app-crypt/acme/acme-0.33.1-r1.ebuild b/app-crypt/acme/acme-0.33.1-r1.ebuild
index bfa507fa149c..58b7f12c6356 100644
--- a/app-crypt/acme/acme-0.33.1-r1.ebuild
+++ b/app-crypt/acme/acme-0.33.1-r1.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999* ]]; then
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
S=${WORKDIR}/certbot-${PV}/acme
fi
diff --git a/app-crypt/acme/acme-0.33.1.ebuild b/app-crypt/acme/acme-0.33.1.ebuild
deleted file mode 100644
index 9df5e0dbdae0..000000000000
--- a/app-crypt/acme/acme-0.33.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
- S=${WORKDIR}/certbot-${PV}/acme
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
- >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
-"
-
-python_test() {
- nosetests -w ${PN} || die
-}