summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-11-10 10:53:58 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-11-10 10:55:34 -0600
commitb8c955bc6faf8b2cca59a76ce3329eacd7bdb5a0 (patch)
tree2660fda1c24b15b42ce87c2b4a2adb9e6f934ca5 /app-containers
parentapp-admin/ocsinventory-agent: add github upstream metadata (diff)
downloadgentoo-b8c955bc6faf8b2cca59a76ce3329eacd7bdb5a0.tar.gz
gentoo-b8c955bc6faf8b2cca59a76ce3329eacd7bdb5a0.tar.bz2
gentoo-b8c955bc6faf8b2cca59a76ce3329eacd7bdb5a0.zip
app-containers/cosign: add 2.2.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/cosign/Manifest2
-rw-r--r--app-containers/cosign/cosign-2.2.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/cosign/Manifest b/app-containers/cosign/Manifest
index aead42dcf1a8..501b5cc33ac9 100644
--- a/app-containers/cosign/Manifest
+++ b/app-containers/cosign/Manifest
@@ -4,3 +4,5 @@ DIST cosign-2.0.1-deps.tar.xz 409822612 BLAKE2B dba99cb2e5b9c3668b1d0c80ae7acc77
DIST cosign-2.0.1.tar.gz 6656038 BLAKE2B eb552f0160473cd98d4c876c126f1bbacb53deeddaa9b475f12c3baa5b076fdc06ac3e9783f785059a96baf3643d010617efb695fb6a10f28f5d40023fa6602d SHA512 2d8ce3c495818091e8077503fd2266bd0f3d8ee8a76f2a9b27ab1ab1cf1e2a01fee3ce6138f54d634015010d80e8193f79a8029dd3eb7a09c4b457be16ee4e50
DIST cosign-2.2.0-deps.tar.xz 474893012 BLAKE2B 75b8a9ccdb117c9eb147a5efd2a167164e5ff5d4dc18483777f0afc1a8c0fc378323003ca58bac92cea4c09a3c4b73d692a81bb45b13bce31553f0e0af2e76e9 SHA512 8b3288ad01ca0d5e789d782f7ba479314396a8848785e4b8fc62b60e1f96b442937d7f2d955370b82b825da62ba1d316169e1ccdff9ce1204663402d680910cb
DIST cosign-2.2.0.tar.gz 850421 BLAKE2B 182bb28cf2b17a04e20d61d4d039e9106fb54a773a9669ad27ff1f3f081a5739dbba7b949688d71a882a4cefceda057ce2636af50e99795194e9656c05928e08 SHA512 379c8544744afb36c143113d6cd3af63cdc28249a34e4c81ab4fe547e97868ae28e0796d9fe77108b7fa2ba30e6379be612650a4f37dc34c08de3fb88fbc5e1d
+DIST cosign-2.2.1-deps.tar.xz 487130076 BLAKE2B a0adbfc4d6230f4ba1013dfc28638752e1732eff92b72993aa386073d255a2629c9abb36bca24cacdcd7edff11b4f34cd54356cb3af82b2c3a781a19c12c168e SHA512 27d09d16abbf1ee3d4d1e186dca9cd0836a6da8e36eeb6cce861c85c2a1ec594a4b37dfbd3ada0970fe469aebcf188a0bbe9f8903871bca0e3b81fb718acda09
+DIST cosign-2.2.1.tar.gz 853562 BLAKE2B 40894d00d6071206221010337cb517ee9559518764a0d991df3363cb4dc381a0af4cd31e60c0c1fc6cffce6086af08c908ccf503893356f224f95b1d4085b195 SHA512 84f2308bbb1968eaf6d0d95e2dcb8efa2c42cd2599298b37d576e5e87f0cf6c1153c330b034908c0c7557953e0a7d964eaa4a8768f7dc35900f5f427d8fe7713
diff --git a/app-containers/cosign/cosign-2.2.1.ebuild b/app-containers/cosign/cosign-2.2.1.ebuild
new file mode 100644
index 000000000000..8324e0f4ed2e
--- /dev/null
+++ b/app-containers/cosign/cosign-2.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_HASH=12cbf9ea177d22bbf5cf028bcb4712b5f174ebc6
+SOURCE_DATE_EPOCH=1699360786
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean \
+ SOURCE_DATE_EPOCH=${SOURCE_DATE_EPOCH}
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+dodoc CHANGELOG.md
+}