summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormipseb <germtoo@outlook.com>2023-11-08 04:02:37 -0500
committerJoonas Niilola <juippis@gentoo.org>2024-01-11 16:05:28 +0200
commit86b0530d2aed9f875a70ebdb9f5e9f8348faee1c (patch)
treea12aac75c931abb1102232bd1486062587ee5013 /app-cdr/nrg2iso
parentnet-libs/rabbitmq-c: add proxy maintainer metadata (diff)
downloadgentoo-86b0530d2aed9f875a70ebdb9f5e9f8348faee1c.tar.gz
gentoo-86b0530d2aed9f875a70ebdb9f5e9f8348faee1c.tar.bz2
gentoo-86b0530d2aed9f875a70ebdb9f5e9f8348faee1c.zip
app-cdr/nrg2iso: bump to version 0.4.1
Signed-off-by: Germ Mipseb <germtoo@outlook.com> Closes: https://github.com/gentoo/gentoo/pull/33723 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-cdr/nrg2iso')
-rw-r--r--app-cdr/nrg2iso/Manifest1
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.4.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-cdr/nrg2iso/Manifest b/app-cdr/nrg2iso/Manifest
index 99cff6ce91c4..7df8c4076349 100644
--- a/app-cdr/nrg2iso/Manifest
+++ b/app-cdr/nrg2iso/Manifest
@@ -1,3 +1,4 @@
+DIST nrg2iso-0.4.1.tar.gz 14949 BLAKE2B e6468d966f0b3ff7913ee58a646abd8a389569e4694b169ba67dfe6d11ac4a17fd9ea2d883d1c53f19c978afa0e376343d635f85cc3e01ed2c47b4cdaf3d4eb1 SHA512 f84711cfbbfd74bdd81854b64b85054df5aa39b8667509d23a8483e665a814d66c7f83426d60849c17fc8b5bb6c2019f549ef6945bb3b000f647bb98dfea03e5
DIST nrg2iso-0.4.tar.gz 8553 BLAKE2B 2bd7907dc027c1bf602447c32f24f82d1627a90922aa32ebabecc15a3b3bb8d021f0dc3e13661351626a36365c76e325cded37046d7ac0f84ce6239c034a87e1 SHA512 fa9e081984345770fad713cdfc5711c8c9ace3981d1cc8130b4c2b83eca517c7765eaab758a34dd5e59846f24c6e3f76f3fc89e984305c4358859b0b28e1ec68
DIST nrg2iso-test.iso 55452 BLAKE2B c4bd651bde0bc66b781332cc186828fbe3fbff2c77150f5ac5cea5f42824b0016fd8b007991d94801a64edc43ce84e050a2db654380e3a0497b33d3abb11cdf5 SHA512 905c0b30482a3b411e786a4cc225dab7513a33c32bfd312717f4666543323456d2b6b6ddbeee75ed194e04cf28d472c87ffbdbf783c63abd06fae7e433601fba
DIST nrg2iso-test.nrg 362652 BLAKE2B c122ae3b0c310e5c823ccbf33906135aa74f1001b02dc31f7fc0fa77b87b5627d31ea8746a64f0e8a2450e0ec20dc25f5fd72e202113237a95bc219f321c79df SHA512 c29f7e7d3f692a03fdbc5d0c1a112ead73efb45b102302f7f1685f9f2ccfe1eed9b690a3c3f1c7d7d79da9197fdb40dd06ca7bab4187e5dfca81d47268b550b7
diff --git a/app-cdr/nrg2iso/nrg2iso-0.4.1.ebuild b/app-cdr/nrg2iso/nrg2iso-0.4.1.ebuild
new file mode 100644
index 000000000000..047667ce42e0
--- /dev/null
+++ b/app-cdr/nrg2iso/nrg2iso-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert CD images from nrg (Nero) to iso"
+HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
+SRC_URI="
+ http://gregory.kokanosky.free.fr/v4/linux/${P}.tar.gz
+ test? (
+ https://yegortimoshenko.s3.amazonaws.com/${PN}-test.iso
+ https://yegortimoshenko.s3.amazonaws.com/${PN}-test.nrg
+ )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake nrg2iso
+}
+
+src_test() {
+ einfo "checking that nrg -> iso matches the expected output"
+ ./nrg2iso "${DISTDIR}"/nrg2iso-test.nrg "${T}"/nrg2iso-test.iso || die "conversion failed"
+ diff "${DISTDIR}"/nrg2iso-test.iso "${T}"/nrg2iso-test.iso || die "unexpected iso"
+}
+
+src_install() {
+ dobin nrg2iso
+ einstalldocs
+}