summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-12-19 09:32:07 +0800
committerYixun Lan <dlan@gentoo.org>2022-12-19 09:40:26 +0800
commit80f2994f505712c04894c64b2297410a9de4cf96 (patch)
tree7ac2e1ee9ead26a0ac6657b46c784b64f4515ddd /app-backup/snapper
parentmedia-gfx/sane-backends: restore clang, musl patches & udev rules (diff)
downloadgentoo-80f2994f505712c04894c64b2297410a9de4cf96.tar.gz
gentoo-80f2994f505712c04894c64b2297410a9de4cf96.tar.bz2
gentoo-80f2994f505712c04894c64b2297410a9de4cf96.zip
app-backup/snapper: Version bump 0.10.4
Closes: https://bugs.gentoo.org/886545 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-backup/snapper')
-rw-r--r--app-backup/snapper/Manifest1
-rw-r--r--app-backup/snapper/snapper-0.10.4.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index dd0f9edda0e9..dcb08718952f 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,2 +1,3 @@
DIST snapper-0.10.2.tar.gz 407857 BLAKE2B f59ee95612a66397f9cb1bec4a3a20fec41f12324d1a778d5bbdac2bd3359b6719d16fba5c50b3753e416681e83780180fe8965757b810165bebef8c4bed6634 SHA512 bdda67908b054beee7285bb3ac97ce28276449d7719369135a7ffa74bce40000ebc89f4f059abe44f8cc7c3a09c46af446e812229290ddd10b2af053fefbc568
DIST snapper-0.10.3.tar.gz 409277 BLAKE2B bc4963081a24572015ff888b5cb85f3afa071e487a89e89f1a72d5b96391be69ad982c79ddfd71f020203d0c50ca07d67cbeb535cd6e57bc3d6ee269ef5c788e SHA512 74cb04d045304021564a0452769fdcde1764595a52e30947396c37fe4c36b3fba08d10505734bc0bd631986e933ee2bfaf67c871cba93a96e498fbfe5e2c6985
+DIST snapper-0.10.4.tar.gz 409357 BLAKE2B c2b33d917647118848dfd02315435d9dab21bcaade22b9da5a2d4d628c00731ecd9bbc7cedba223f618f336535ccba0ca92b065d572aab328337858dba76275f SHA512 f42bcfa541e1fff23f5057c9b38d93f31a28980ce1cd37e07bcf622ff9151bd98c42975610d59da0c33a9bee7d83290edbdd05e013839e4ca23f02e9a9f8c793
diff --git a/app-backup/snapper/snapper-0.10.4.ebuild b/app-backup/snapper/snapper-0.10.4.ebuild
new file mode 100644
index 000000000000..7dfccdfc6e12
--- /dev/null
+++ b/app-backup/snapper/snapper-0.10.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc lvm pam test systemd xattr"
+RESTRICT="test"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/json-c:=
+ dev-libs/libxml2
+ dev-libs/icu:=
+ sys-apps/acl
+ sys-apps/dbus
+ sys-apps/util-linux
+ >=sys-fs/btrfs-progs-3.17.1
+ sys-libs/zlib
+ virtual/libintl
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/cron-confd.patch
+ "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+ -i data/Makefile.* \
+ || die "Failed to fix systemd services and timers installation path"
+ eautoreconf
+}
+
+src_configure() {
+ # ext4 code does not work anymore
+ # snapper does not build without btrfs
+ local myeconfargs=(
+ --disable-silent-rules
+ --with-conf="/etc/conf.d"
+ --enable-zypp
+ --enable-rollback
+ --enable-btrfs-quota
+ --disable-ext4
+ --enable-btrfs
+ $(use_enable doc)
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Existing configuration file required to function
+ keepdir /etc/snapper/configs
+ newconfd data/sysconfig.snapper snapper
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html and"
+ elog "https://wiki.gentoo.org/wiki/Snapper"
+}