summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-01-18 19:26:44 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-01-18 19:26:44 -0600
commita300eceb9c0fde0d3decfe6dc7d46a72ed56bc6e (patch)
tree657e34b27dd29a00218f09ae983d5140489a0f80 /app-admin
parentapp-admin/puppet: add 8.4.0 (diff)
downloadgentoo-a300eceb9c0fde0d3decfe6dc7d46a72ed56bc6e.tar.gz
gentoo-a300eceb9c0fde0d3decfe6dc7d46a72ed56bc6e.tar.bz2
gentoo-a300eceb9c0fde0d3decfe6dc7d46a72ed56bc6e.zip
app-admin/puppet-agent: add 8.4.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-8.4.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index a5924dd7ee51..f3b0eb74cecd 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_7.24.0-1focal_amd64.deb 31418478 BLAKE2B 201c0a5adbeca2b6f572d
DIST puppet-agent_7.24.0-1focal_arm64.deb 31160744 BLAKE2B 22dfc3f0855c2e88c7202f2a9d98efd4ad9ef3a191ab9b5b8c37a6869306a47d1225d568fec9f0fc52cdf236f8258b5ca206a360049cc39e1825f1f8afc5d4af SHA512 db1b7cb25a04d6aeedd7f3bb125fe0fcac420c2881f9f3aba729143e253908376cd118073753de018d8fd1a6d7f38139766b4ec4bfb23f840ca7ee32143a8a48
DIST puppet-agent_8.3.1-1focal_amd64.deb 35930206 BLAKE2B 8a636bfd9a76a364f03022a587bbe9bd8a596515d515cc41c1eb4d96f930366191df54217444cb4a7a471e201f5ac9673e101b1a3697a55abfc7e2b19ac9a45c SHA512 b455e4dd539159e568aa68acbb993e3c94a3d2724e8bdc9056a28c79737d54981c891bfb0d0e7084dd6c16bb13580eb535aacfe6dff34f9bf3ea6da32cfbe08b
DIST puppet-agent_8.3.1-1focal_arm64.deb 35420834 BLAKE2B b95702ba60df28ca511c7ea1efeacf7b537d666987e76f83048552667d0ee1ae41041166d07f41a6d1f0e1e6eceea9af427c8e4feef0efa1108b33edf2b64001 SHA512 89d0183dd8762ec9e96ca218d179a5c6278c6b106e4679370dac5b96beb5bb6ec5c18f52a6d076a7ae71f9bbcb9466351b65f096b5c961cb6d8f03a2c7fe171e
+DIST puppet-agent_8.4.0-1focal_amd64.deb 35930626 BLAKE2B ad299aaceba51bd2831c6aa15a1794c12e03026866e7b1fd59c49d078d7c32bc8af2f0eba9f699f21e0bde98147b3a7edb88db3ada2ec8cb9601c2ed64210240 SHA512 18148a6cbd237afc66bbce1bc5d9eec63426efd5d7a2625e4f8a7d962a97c25da7e5ef208972323ea10e35c174beaacacc131d7dd1043a9013f1d8c8ae8a8c70
+DIST puppet-agent_8.4.0-1focal_arm64.deb 35421066 BLAKE2B 348f4cb16b83e0703fe8ec1fc6a5ebd992384c02f51b8d38d597d629b19f070f21e0f944ba1c6188bd9d93d0689e66ef10a4c717847ffca2534b4c6a3fa0eb4d SHA512 5ba2d6d41e6d98e0e7830fc6140500173e1e18efd9c228c84ec124c5154df847657f4c43f994d05830774fc6431b49d57081ded579ed1215927623c7b83155a7
diff --git a/app-admin/puppet-agent/puppet-agent-8.4.0.ebuild b/app-admin/puppet-agent/puppet-agent-8.4.0.ebuild
new file mode 100644
index 000000000000..f5524d744e1b
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-8.4.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}