summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-22 08:10:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-22 08:10:52 +0200
commit41eefc315982abe602089e0af7725b189f10302f (patch)
tree3f52bf13f1dcd3527d0eccb59a3ed35e4a84028b /app-admin
parentdev-python/boto3: add 1.26.14 (diff)
downloadgentoo-41eefc315982abe602089e0af7725b189f10302f.tar.gz
gentoo-41eefc315982abe602089e0af7725b189f10302f.tar.bz2
gentoo-41eefc315982abe602089e0af7725b189f10302f.zip
app-admin/awscli: add 1.27.14
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.14.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index cab949a632c3..34edd82ea840 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,4 +2,5 @@ DIST aws-cli-1.26.5.gh.tar.gz 2294226 BLAKE2B 5c52d77679dcb999626751a7aa9abe3d81
DIST aws-cli-1.27.11.gh.tar.gz 2303984 BLAKE2B f773a631bd2f172697a013e11765307edfac0957f7bff7d05e74c326239491c03629859b5d7b4ec85a831e28acd47cbbf4a2393c8ae512fbf393142cfb7ca13d SHA512 ad9eee70eb95d2c9c71978425e96b80a42569efca6e20c5caeb6af7b27aa893b3bfe68fed8e13b18e20626c4cd9599e8efe93dacde5bcc5c347b815376819ea5
DIST aws-cli-1.27.12.gh.tar.gz 2306806 BLAKE2B b94c5ae753754ff66897263883942043fa659cef95b5eb6c4e8edee8249b0cf1010d4490a4a46b477052ad14398f5d034285ff2e21428369b1ab4b425bb75cca SHA512 104cf99cc5bee3261b04a0c11681dfe8a18ffce6d1a4b8502983f6c754cce5b7d7e9b7f1dfd314ff06ccc4d8aa81f47cc335cbdfe81b6e19e7a08bad7cf14b02
DIST aws-cli-1.27.13.gh.tar.gz 2308435 BLAKE2B 7b9ec88744417d9b3416f85d26100ab7e07a5373ada8aab004ff0411ff1aededfe21376b4843708a7b861bcf0d47fd5182e8423fcb1a041d1f16380532514a3c SHA512 0888cede49de91790dbd8eedf0b9ec96da10c05d06f939ab0cac983ca24c5f4e2dd8d2f3c11e5543c15c04c86f2bfb0fc49f9d29fe42149a2e3c1e2e04266089
+DIST aws-cli-1.27.14.gh.tar.gz 2309344 BLAKE2B dc29dbc89ca963f7dee116b815652c846a643b8415807a32460e86eb9a863470f985bcfcb7f228ce78682b351d14e29234dabc426556f4c7f8863ceec9c55347 SHA512 a97e104c8a45983f52a802d1b1cd55a89f95b1bd3ec5760905404e3f94946c2efe24de70a411d1e943a9ba07671f8114dbb05c216d3d52d1876c05f5e73093cd
DIST aws-cli-1.27.8.gh.tar.gz 2301766 BLAKE2B 1873d92b8d2f6d3f29a65b4177927a1a14034da71dbc95ff6abf3f49df6cf3ee192412eeea15be14c8cf9fca0a5603f2c76b80b280f4feb95e661055abcd8b60 SHA512 e53828cac1b3e10e2ddd45312d71cdb748216dbc37c3e9833e7a1320b236c3bef6a13204a38b946d9182430f169fca1ddc77d3d06c1c2c6e05978dc61f675168
diff --git a/app-admin/awscli/awscli-1.27.14.ebuild b/app-admin/awscli/awscli-1.27.14.ebuild
new file mode 100644
index 000000000000..9bcb01ac11e2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.14.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}