summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/usermin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/usermin')
-rw-r--r--app-admin/usermin/Manifest1
-rw-r--r--app-admin/usermin/files/init.d.usermin38
-rw-r--r--app-admin/usermin/files/usermin-1.080-safestop.patch12
-rw-r--r--app-admin/usermin/files/usermin-1.150-setup-nocheck.patch22
-rw-r--r--app-admin/usermin/files/usermin-1.540-r1.init38
-rw-r--r--app-admin/usermin/files/usermin.pam-include.111
-rw-r--r--app-admin/usermin/metadata.xml13
-rw-r--r--app-admin/usermin/usermin-1.600.ebuild89
8 files changed, 224 insertions, 0 deletions
diff --git a/app-admin/usermin/Manifest b/app-admin/usermin/Manifest
new file mode 100644
index 000000000000..35fe334aed22
--- /dev/null
+++ b/app-admin/usermin/Manifest
@@ -0,0 +1 @@
+DIST usermin-1.600.tar.gz 9295065 SHA256 4952689a2a7c77b111aeb0fdfac66d4c5edaa06735091b92aacab72e9ecd27ef SHA512 9c0670360179a6e79ac17ea8f87810f05e640b42cf946beeac8d4398b2b9ce441e10a178da242cb77f2163afd8eb508ccb6c89f54b540907eba8d97dac592895 WHIRLPOOL 7c92ab2bbb1378ca6288fae46a0c8590b4ea6bfbd8b9abc5697efb4d8d1b2ac85ece6d506e64e8e25b7661707fe8802521440a8ebcdb3b874670ab04645beaab
diff --git a/app-admin/usermin/files/init.d.usermin b/app-admin/usermin/files/init.d.usermin
new file mode 100644
index 000000000000..e62b4aacd9bd
--- /dev/null
+++ b/app-admin/usermin/files/init.d.usermin
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net logger
+}
+
+
+checkconfig() {
+ if [ -f /etc/usermin/config ]; then
+ return 0;
+ else
+ eerror "Error starting usermin. Have you run '/usr/libexec/usermin/setup.sh'?"
+ return 1;
+ fi
+}
+
+start() { # copied from /etc/usermin/start
+ checkconfig || return 1
+ ebegin "Starting Usermin"
+
+ LANG=
+ export LANG
+
+ unset PERLIO
+ export PERLIO
+ start-stop-daemon --start --quiet \
+ --exec /usr/libexec/usermin/miniserv.pl -- /etc/usermin/miniserv.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Usermin"
+ start-stop-daemon --stop --pidfile /var/run/usermin.pid --quiet
+ eend $?
+}
diff --git a/app-admin/usermin/files/usermin-1.080-safestop.patch b/app-admin/usermin/files/usermin-1.080-safestop.patch
new file mode 100644
index 000000000000..2cfd7e25e7fb
--- /dev/null
+++ b/app-admin/usermin/files/usermin-1.080-safestop.patch
@@ -0,0 +1,12 @@
+diff -Naur usermin-1.080.orig/setup.sh usermin-1.080/setup.sh
+--- usermin-1.080.orig/setup.sh 2004-06-03 16:18:07.000000000 -0700
++++ usermin-1.080/setup.sh 2004-07-26 01:27:23.959104711 -0700
+@@ -487,7 +487,7 @@
+ echo "#!/bin/sh" >>$config_dir/stop
+ echo "echo Stopping Usermin server in $wadir" >>$config_dir/stop
+ echo "pidfile=\`grep \"^pidfile=\" $config_dir/miniserv.conf | sed -e 's/pidfile=//g'\`" >>$config_dir/stop
+-echo "kill \`cat \$pidfile\`" >>$config_dir/stop
++echo "test -z \"\$pidfile\" || kill \`cat \$pidfile\`" >>$config_dir/stop
+ chmod 755 $config_dir/start $config_dir/stop
+ echo "..done"
+ echo ""
diff --git a/app-admin/usermin/files/usermin-1.150-setup-nocheck.patch b/app-admin/usermin/files/usermin-1.150-setup-nocheck.patch
new file mode 100644
index 000000000000..6b4a06fb9cf2
--- /dev/null
+++ b/app-admin/usermin/files/usermin-1.150-setup-nocheck.patch
@@ -0,0 +1,22 @@
+diff -Naurp usermin-1.150.orig/setup.sh usermin-1.150/setup.sh
+--- usermin-1.150.orig/setup.sh 2005-09-03 16:19:50.000000000 -0700
++++ usermin-1.150/setup.sh 2005-09-03 16:21:01.000000000 -0700
+@@ -342,12 +342,12 @@ else
+ echo ""
+ exit 12
+ fi
+- $perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
+- if [ $? != "0" ]; then
+- echo "ERROR: TCP port $port is already in use by another program"
+- echo ""
+- exit 13
+- fi
++ #$perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
++ #if [ $? != "0" ]; then
++ # echo "ERROR: TCP port $port is already in use by another program"
++ # echo ""
++ # exit 13
++ #fi
+
+ # Ask the user if SSL should be used
+ if [ "$ssl" = "" ]; then
diff --git a/app-admin/usermin/files/usermin-1.540-r1.init b/app-admin/usermin/files/usermin-1.540-r1.init
new file mode 100644
index 000000000000..90389764e698
--- /dev/null
+++ b/app-admin/usermin/files/usermin-1.540-r1.init
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net logger
+}
+
+
+checkconfig() {
+ if [ -f /etc/usermin/config ]; then
+ return 0;
+ else
+ eerror "Error starting usermin. Have you run '/usr/libexec/usermin/setup.sh'?"
+ return 1;
+ fi
+}
+
+start() { # copied from /etc/usermin/start
+ checkconfig || return 1
+ ebegin "Starting Usermin"
+
+ LANG=
+ export LANG
+
+ unset PERLIO
+ export PERLIO
+ start-stop-daemon --start --quiet --user usermin \
+ --exec /usr/libexec/usermin/miniserv.pl -- /etc/usermin/miniserv.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Usermin"
+ start-stop-daemon --stop --pidfile /var/run/usermin.pid --quiet
+ eend $?
+}
diff --git a/app-admin/usermin/files/usermin.pam-include.1 b/app-admin/usermin/files/usermin.pam-include.1
new file mode 100644
index 000000000000..50d360ce431c
--- /dev/null
+++ b/app-admin/usermin/files/usermin.pam-include.1
@@ -0,0 +1,11 @@
+#%PAM-1.0
+
+auth required pam_securetty.so
+auth required pam_nologin.so
+auth include system-auth
+
+account include system-auth
+
+password include system-auth
+
+session include system-auth
diff --git a/app-admin/usermin/metadata.xml b/app-admin/usermin/metadata.xml
new file mode 100644
index 000000000000..3317d0c52e61
--- /dev/null
+++ b/app-admin/usermin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A web-based user administration interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">webadmin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/usermin/usermin-1.600.ebuild b/app-admin/usermin/usermin-1.600.ebuild
new file mode 100644
index 000000000000..b9d9142b4c9b
--- /dev/null
+++ b/app-admin/usermin/usermin-1.600.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils pam user
+
+DESCRIPTION="A web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 ldap pam ssl syslog zlib"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+ || ( virtual/perl-Digest-MD5 dev-perl/MD5 )
+ dev-perl/Digest-SHA1
+ dev-perl/Net-HTTP
+ sys-process/lsof
+ virtual/perl-Time-HiRes
+ virtual/perl-Time-Local
+ ipv6? ( dev-perl/Socket6 )
+ ldap? ( dev-perl/perl-ldap )
+ pam? ( dev-perl/Authen-PAM )
+ ssl? ( dev-perl/Net-SSLeay )
+ syslog? ( virtual/perl-Sys-Syslog )
+ zlib? ( virtual/perl-Compress-Raw-Zlib )"
+
+pkg_setup() {
+ enewuser ${PN} -1 /bin/bash
+}
+
+src_prepare() {
+ # Point to the correct mysql location
+ sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+ # Change /usr/local/bin/perl references
+ find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+ epatch "${FILESDIR}"/${PN}-1.080-safestop.patch
+ epatch "${FILESDIR}"/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+ dodir /usr/libexec/${PN}
+ cp -pR * "${D}"/usr/libexec/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.540-r1.init ${PN}
+ newpamd "${FILESDIR}"/${PN}.pam-include.1 ${PN}
+
+ dodir /etc/${PN}
+ dodir /var/log/${PN}
+
+ # Fix ownership
+ chown -R ${PN} "${ED}"
+
+ config_dir=${D}/etc/${PN}
+ var_dir=${D}/var/log/${PN}
+ perl=/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ "${D}"/usr/libexec/${PN}/setup.sh > "${T}"/${PN}-setup.out 2>&1 || die "Failed to create initial ${PN} configuration."
+
+ # Cleanup from the config script
+ rm -rf "${D}"/var/log/${PN}
+ keepdir /var/log/${PN}
+}
+
+pkg_postinst() {
+ elog "To make ${PN} start at boot time, run: 'rc-update add ${PN} default'."
+ elog "Point your web browser to https://localhost:20000 to use ${PN}."
+}