summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-01-04 15:13:14 +0800
committerIan Delaney <idella4@gentoo.org>2016-01-04 15:15:04 +0800
commit019bcd0e1fa9001399fe53a872fbd4aa8a9e7bd2 (patch)
treecdb8bc609f2cc63538fdcf39a2248d719079b5ad /app-admin/qtpass
parentprofiles: mask games-puzzle/krystaldrop for removal (diff)
downloadgentoo-019bcd0e1fa9001399fe53a872fbd4aa8a9e7bd2.tar.gz
gentoo-019bcd0e1fa9001399fe53a872fbd4aa8a9e7bd2.tar.bz2
gentoo-019bcd0e1fa9001399fe53a872fbd4aa8a9e7bd2.zip
app-admin/qtpass: New ebuild, a GUI for app-admin/pass in qt
ebuild submitted by the OP Anne Jan Brouwer which was edited by Merlijn Wajer who agreed to proxy maintain, however in the end, ebuild also submitted by spiderx who also agreed to proxy maintain. With consent by Merlijn Wajer, the proxy maintainership has been assigned to spiderx; ebuild submitted in Comment 8 of the gentoo bug and usedfor this addition to the tree with minor touchups to bring style and syntax in the ebuild and metadata to required needs. Cross tested fully by user wraeth and myself. Fixes and closes the gentoo bug Gentoo bug: #564190 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/qtpass')
-rw-r--r--app-admin/qtpass/Manifest1
-rw-r--r--app-admin/qtpass/metadata.xml18
-rw-r--r--app-admin/qtpass/qtpass-1.0.5.ebuild62
3 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/qtpass/Manifest b/app-admin/qtpass/Manifest
new file mode 100644
index 000000000000..f720394d4234
--- /dev/null
+++ b/app-admin/qtpass/Manifest
@@ -0,0 +1 @@
+DIST qtpass-1.0.5.tar.gz 636461 SHA256 0c07bd1eb9e5336c0225f891e5b9a9df103f218619cf7ec6311edf654e8db281 SHA512 e1b63f1058dc9c194f06376d52acbbb8594d429f4d7fe4ba27baed2cafe10b1c36137b3e33626c1bf33c7f3e1444e6fbe48fc66a83e0f7cd82f5b47f0193d178 WHIRLPOOL acb914d89bcd667343f648e38bb9eb316ebbf0b01f75686d3a7694e82eedd3e3f52ffc99f530bbe3ccbb6089ced727796924fcf48a94c071a3e20b27141b28df
diff --git a/app-admin/qtpass/metadata.xml b/app-admin/qtpass/metadata.xml
new file mode 100644
index 000000000000..6c4ad75441b5
--- /dev/null
+++ b/app-admin/qtpass/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <longdescription>
+QtPass is a multi-platform GUI for pass, the standard unix password manager.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/IJHack/qtpass/releases</changelog>
+ <doc>https://github.com/IJHack/qtpass/wiki</doc>
+ <bugs-to>https://github.com/IJHack/qtpass/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/qtpass/qtpass-1.0.5.ebuild b/app-admin/qtpass/qtpass-1.0.5.ebuild
new file mode 100644
index 000000000000..ed2aa21369c0
--- /dev/null
+++ b/app-admin/qtpass/qtpass-1.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org/"
+SRC_URI="https://github.com/IJHack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+qt5"
+DOCS=( FAQ.md README.md CONTRIBUTING.md )
+
+RDEPEND="qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[xcb]
+ dev-qt/qtwidgets:5
+ dev-qt/qtnetwork:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ app-admin/pass"
+DEPEND="${RDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )"
+
+src_prepare() {
+ # Modify install path
+ sed -i "s/target.path = \$\$PREFIX/target.path = \$\$PREFIX\/bin/" \
+ ${PN}.pro \
+ || die "sed failed to modify install path for ${PN}.pro"
+
+ # Backport segfault fix https://github.com/IJHack/qtpass/issues/122
+ # (ToDo: remove this in 1.0.6)
+ sed -e "/QtPass = NULL;/{n;d};/startupPhase = true;/a autoclearTimer = NULL;" \
+ -i mainwindow.cpp || die "sed failed mainwindow.cpp"
+
+ epatch_user
+}
+
+src_configure() {
+ if use qt5 ; then
+ eqmake5 PREFIX="${D}"/usr
+ else
+ eqmake4 PREFIX="${D}"/usr
+ fi
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/applications
+ doins "${PN}.desktop"
+
+ newicon artwork/icon.svg "${PN}-icon.svg"
+}