summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-09-13 21:45:52 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-09-13 21:47:10 -0700
commitfe061f0de748ba1187514497b8a0e4cf14d1cf7a (patch)
treebc6e31626513167145244eaf4357513f2db9ffde /app-admin/git-credential-gopass
parentapp-admin/gopass-jsonapi: add 1.15.8 (diff)
downloadgentoo-fe061f0de748ba1187514497b8a0e4cf14d1cf7a.tar.gz
gentoo-fe061f0de748ba1187514497b8a0e4cf14d1cf7a.tar.bz2
gentoo-fe061f0de748ba1187514497b8a0e4cf14d1cf7a.zip
app-admin/git-credential-gopass: add 1.15.8
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-admin/git-credential-gopass')
-rw-r--r--app-admin/git-credential-gopass/Manifest2
-rw-r--r--app-admin/git-credential-gopass/git-credential-gopass-1.15.8.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/git-credential-gopass/Manifest b/app-admin/git-credential-gopass/Manifest
index 36018363ec35..bcc79c9531c8 100644
--- a/app-admin/git-credential-gopass/Manifest
+++ b/app-admin/git-credential-gopass/Manifest
@@ -2,3 +2,5 @@ DIST git-credential-gopass-1.15.4-deps.tar.xz 33138508 BLAKE2B 7cbb930e55f1ed53f
DIST git-credential-gopass-1.15.4.tar.gz 20592 BLAKE2B 2fef319cb7c1d90c89512f305fffbbe88ce5efa25bde798adfebdbf1a29847b1c62d51ca4ece4262c6746e5abb0f31e01804e827de8fdd364fa6bfbe2a9fd414 SHA512 4e456c35fb5fb4d91fada4c2ccafa5a48c9261746653dd363638b1fccfeea647f465d0956146a18bb0d50ffb8bd2c7502497efcac54095db7d37441074aeb6cb
DIST git-credential-gopass-1.15.5-deps.tar.xz 182896696 BLAKE2B 59cd74ff4be1dfd83d221327d041506c41799f67d8559f5a12341a70f2c63e36d03f8f99628ac973a02cbb42ba920366642f124a6315a8ff0d388d384c912b85 SHA512 64f34fecad85562cdf4db48030703b991bb2f6448e1fbd17ab0063f193c328f78e9630b7e64e9f1e4417f011b6a087e2e9fb19fe4adbac3ff36c3a315da933a6
DIST git-credential-gopass-1.15.5.tar.gz 23210 BLAKE2B 18f58e3e72778b9e3493288e2ab546413e09ed49b3d2764ed72d0cc444d4c03afd7fc4a4ecc1f378320296c6c7a488e0ec0e42ee688ad1b51c999c5a030e8339 SHA512 de67f21b27dc4f8e5437b465a748dabf3563393b09aefff08016fe367ffd847b3ad196d034589a05e1723763abf56395ab08372a05b86005cca11a3cc4cfb91f
+DIST git-credential-gopass-1.15.8-deps.tar.xz 286523452 BLAKE2B 651e9366fee3c68c06f2a94ce713c3f843f6ee35f0343e187519342950c5efc9e08cc68090d219a8e50a0ac61690c8f8d1c37ac0b844f580bfb27cc2f86d0eff SHA512 bf2a798d758057009f5e21574c84c944043f472350e847016682a79159d2abeabfcb8d684504c3f4abd31312f505104b1a5f20591547e741b8ed5520dacd6920
+DIST git-credential-gopass-1.15.8.tar.gz 24178 BLAKE2B c9d0e30384187125cb2c6a51ba34cb41a2878c4aa8aa04ef1f07906079f470d1980712b9f897d48ede9ea070d201d68a29795c0fffd63c592ab354be379e2c92 SHA512 8ad93729531a7a7962b4b0223d40e8984ba6524aeca3284bbd1a3e5ecdb0ec79788edae0cecde106d462fe41b8a355aca59a99749d50d042847509e9c56e68e8
diff --git a/app-admin/git-credential-gopass/git-credential-gopass-1.15.8.ebuild b/app-admin/git-credential-gopass/git-credential-gopass-1.15.8.ebuild
new file mode 100644
index 000000000000..466cf4057557
--- /dev/null
+++ b/app-admin/git-credential-gopass/git-credential-gopass-1.15.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Gopass git-credentials helper"
+HOMEPAGE="https://github.com/gopasspw/git-credential-gopass"
+SRC_URI="https://github.com/gopasspw/git-credential-gopass/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/go-1.16"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"