summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-03-10 09:28:42 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-03-10 12:28:09 +0100
commit563cb1affb5efaaadcf536c675362acbb6652b74 (patch)
treed21c637c0e02ef38498e93ae3941882ca6529f7b /app-admin/entr/entr-4.4.ebuild
parentdev-python/protobuf-python: ia64 stable wrt bug #712016 (diff)
downloadgentoo-563cb1affb5efaaadcf536c675362acbb6652b74.tar.gz
gentoo-563cb1affb5efaaadcf536c675362acbb6652b74.tar.bz2
gentoo-563cb1affb5efaaadcf536c675362acbb6652b74.zip
app-admin/entr: version bump.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/entr/entr-4.4.ebuild')
-rw-r--r--app-admin/entr/entr-4.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/entr/entr-4.4.ebuild b/app-admin/entr/entr-4.4.ebuild
new file mode 100644
index 000000000000..b86dea0ffd94
--- /dev/null
+++ b/app-admin/entr/entr-4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}