summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 10:27:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 10:31:31 +0100
commit024ac2b25b6e6d41ddb47330886b404d8ca79dff (patch)
tree18307ab44580a4b1a10e6305f897c353321e3e42 /acct-user/git/git-0-r1.ebuild
parenteclass: [QA] Revert multiple meaningless doc changes (diff)
downloadgentoo-024ac2b25b6e6d41ddb47330886b404d8ca79dff.tar.gz
gentoo-024ac2b25b6e6d41ddb47330886b404d8ca79dff.tar.bz2
gentoo-024ac2b25b6e6d41ddb47330886b404d8ca79dff.zip
acct-*: Revbumps for sysusers.d in eclass
Closes: https://bugs.gentoo.org/762089 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'acct-user/git/git-0-r1.ebuild')
-rw-r--r--acct-user/git/git-0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/acct-user/git/git-0-r1.ebuild b/acct-user/git/git-0-r1.ebuild
new file mode 100644
index 000000000000..0e86336ce40b
--- /dev/null
+++ b/acct-user/git/git-0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="Git repository hosting user"
+
+IUSE="gitea gitolite"
+REQUIRED_USE="^^ ( gitea gitolite )"
+
+ACCT_USER_ID=196
+ACCT_USER_HOME_OWNER=git:git
+ACCT_USER_HOME_PERMS=750
+ACCT_USER_SHELL=/bin/sh
+ACCT_USER_GROUPS=( git )
+
+acct-user_add_deps
+
+pkg_setup() {
+ if use gitea; then
+ ACCT_USER_HOME=/var/lib/gitea
+ elif use gitolite; then
+ ACCT_USER_HOME=/var/lib/gitolite
+ else
+ die "Incorrect USE flag combination"
+ fi
+}