summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-19 14:14:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-19 15:14:30 +0200
commit94329e0e679f95561b1c340b7a86cc5660b06cf9 (patch)
treeebea7667976b0a5b235f546de0eb1149ee4f81e7
parentdev-python/djangorestframework: Remove old (diff)
downloadgentoo-94329e0e679f95561b1c340b7a86cc5660b06cf9.tar.gz
gentoo-94329e0e679f95561b1c340b7a86cc5660b06cf9.tar.bz2
gentoo-94329e0e679f95561b1c340b7a86cc5660b06cf9.zip
dev-python/djangorestframework: Bump to 3.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.15.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index a557634d482e..473e112edc36 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1 +1,2 @@
DIST django-rest-framework-3.15.1.gh.tar.gz 9291840 BLAKE2B daf672a1fb01494f08dd54af7369bd464d4fc1e22ff3c90c0fe787408d4f327710c5e6394e33546a4df2da752dbd774980f092108f2f4e395795af3aead18f89 SHA512 e44c3d861973928194035364fb6b5ddffbcacab959072b2c549971dd6675b5a5f1be13b55856154dbffaefb48dcbd4a63fd9ffbce5456507b52fd5e4648706b9
+DIST django-rest-framework-3.15.2.gh.tar.gz 9290406 BLAKE2B 588aebbdd89f749bacd4244707f6b4b0e2a6aef0759973e5451ebcc4acb4d2e1c2d9773ab576e33442f5123ce860cae087622a26d1d208edc70df04057c4d401 SHA512 a24322fb09398ee1608900ae623d8ba44c3cb066fc7921e38f847a93513d3ca549d933da6cfc045a556edfe50dae3431b6782d0241a9f53ac3dbc0caf48fa520
diff --git a/dev-python/djangorestframework/djangorestframework-3.15.2.ebuild b/dev-python/djangorestframework/djangorestframework-3.15.2.ebuild
new file mode 100644
index 000000000000..692fde8de29e
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.15.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
+
+ # upstream is removing pytz, apparently it's not tested anymore
+ # https://github.com/encode/django-rest-framework/discussions/9342
+ tests/test_fields.py::TestPytzNaiveDayLightSavingTimeTimeZoneDateTimeField::test_invalid_inputs
+)