summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 17:35:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 20:37:56 +0100
commit8f6a51a40a4fd30a0583e75a156d33f1818a54bd (patch)
tree50ac2f17e16b2876b13ca8729307be181a188894
parentdev-python/sympy: Bump to 1.7 (diff)
downloadgentoo-8f6a51a40a4fd30a0583e75a156d33f1818a54bd.tar.gz
gentoo-8f6a51a40a4fd30a0583e75a156d33f1818a54bd.tar.bz2
gentoo-8f6a51a40a4fd30a0583e75a156d33f1818a54bd.zip
sys-devel/clang: CTE tests require compiler-rt now
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang/clang-11.0.1.9999.ebuild3
-rw-r--r--sys-devel/clang/clang-11.0.1_rc1.ebuild3
-rw-r--r--sys-devel/clang/clang-12.0.0.9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/sys-devel/clang/clang-11.0.1.9999.ebuild b/sys-devel/clang/clang-11.0.1.9999.ebuild
index 1e9b8aabd110..4a3a05b4df86 100644
--- a/sys-devel/clang/clang-11.0.1.9999.ebuild
+++ b/sys-devel/clang/clang-11.0.1.9999.ebuild
@@ -40,7 +40,8 @@ for x in "${ALL_LLVM_TARGETS[@]}"; do
done
unset x
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/compiler-rt )"
BDEPEND="
>=dev-util/cmake-3.16
doc? ( dev-python/sphinx )
diff --git a/sys-devel/clang/clang-11.0.1_rc1.ebuild b/sys-devel/clang/clang-11.0.1_rc1.ebuild
index 1e9b8aabd110..4a3a05b4df86 100644
--- a/sys-devel/clang/clang-11.0.1_rc1.ebuild
+++ b/sys-devel/clang/clang-11.0.1_rc1.ebuild
@@ -40,7 +40,8 @@ for x in "${ALL_LLVM_TARGETS[@]}"; do
done
unset x
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/compiler-rt )"
BDEPEND="
>=dev-util/cmake-3.16
doc? ( dev-python/sphinx )
diff --git a/sys-devel/clang/clang-12.0.0.9999.ebuild b/sys-devel/clang/clang-12.0.0.9999.ebuild
index d1d26af0fa7c..e5da1c5cedb4 100644
--- a/sys-devel/clang/clang-12.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-12.0.0.9999.ebuild
@@ -40,7 +40,8 @@ for x in "${ALL_LLVM_TARGETS[@]}"; do
done
unset x
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/compiler-rt )"
BDEPEND="
>=dev-util/cmake-3.16
doc? ( dev-python/sphinx )