summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-19 14:10:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-19 15:14:28 +0200
commit6c9360b440939ef19c0689e7644328a76800fd5a (patch)
tree117abff742781c0ab21ad6f2227298e8dfb3e495
parentmail-client/thunderbird: add 115.12.1 (diff)
downloadgentoo-6c9360b440939ef19c0689e7644328a76800fd5a.tar.gz
gentoo-6c9360b440939ef19c0689e7644328a76800fd5a.tar.bz2
gentoo-6c9360b440939ef19c0689e7644328a76800fd5a.zip
dev-python/Nuitka: Bump to 2.3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.3.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 38a715c28665..7fd03f2daca8 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-2.3.3.tar.gz 3668441 BLAKE2B 0e661948185490a4e47e71eca8c2cecb116bdea1f3ef2d0a477bae33bcfe5612d262e5fb8c3c9b0e192c8c41c3eee019dbb96a429eb072f05b0b5aeaae46a0f7 SHA512 1ea8f644f84d28bf4720f0fdc49204e93607a233c7e921eb006d1c09d6893d299d67d623ced0cd0b57bbe5056d108155f43e1de3d481c5c18f392dca321e9c4b
DIST Nuitka-2.3.4.tar.gz 3702705 BLAKE2B b67718cf4258a22e6f1d66abeaa293fb134a1726d03b40e7e00f5948765786afb92a317b718c4832be59f3821e5ce744755e06baf171180ca3c98a7cfd9cff0e SHA512 8794da550c31d488763c9c40304232b050a9647481f387b1d4ac1e3adadd794332004ec1152e650fb37725b2c0ecd00faedb5b0f1c4958fc294a61c28602e01a
+DIST Nuitka-2.3.7.tar.gz 3701490 BLAKE2B e898d23d3bee8d390a81798d3c351e2c208e7e8831a9dbaaa3de848fbad11f71aa5698f1dbe8f8a7b6a78baa9ce74f95c9be5c1c59054873d4091f5e5167b942 SHA512 5fc22f5f530a63a90fe3387d9c337008331a6099f2810ad9513d99fc7ef2c91c7780bd3fded111c9ca0cde63519fecc91a08f15eb0dbddefe0605e631520e682
diff --git a/dev-python/Nuitka/Nuitka-2.3.7.ebuild b/dev-python/Nuitka/Nuitka-2.3.7.ebuild
new file mode 100644
index 000000000000..274aff9ae3b5
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.3.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}