summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-11-26 13:44:11 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-11-26 13:44:11 +0000
commitf1ea79703d9830a2c2fb9fb6dcb16461b17adfb1 (patch)
tree551ca06ced56f2eea301e1831ec8cbdd0e3b8cf9
parent2018-11-26 13:24:32 UTC (diff)
parentdev-libs/libutf8proc: fix Prefix regression introduced in -r1. (diff)
downloadgentoo-f1ea79703d9830a2c2fb9fb6dcb16461b17adfb1.tar.gz
gentoo-f1ea79703d9830a2c2fb9fb6dcb16461b17adfb1.tar.bz2
gentoo-f1ea79703d9830a2c2fb9fb6dcb16461b17adfb1.zip
Merge updates from master
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild4
-rw-r--r--dev-util/netsurf-buildsystem/files/gentoo-helpers.sh2
-rw-r--r--net-im/prosody/Manifest1
-rw-r--r--net-im/prosody/prosody-0.11.0.ebuild85
4 files changed, 89 insertions, 3 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
index bfc2a2dc1b40..eeecdc8fec71 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
@@ -20,7 +20,7 @@ DEPEND="dev-util/netsurf-buildsystem"
S="${WORKDIR}/${MY_P}"
_emake() {
- source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+ source "${EPREFIX}"/usr/share/netsurf-buildsystem/gentoo-helpers.sh
netsurf_define_makeconf
emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
}
@@ -30,5 +30,5 @@ src_compile() {
}
src_install() {
- _emake DESTDIR="${ED}" install
+ _emake DESTDIR="${D}" install
}
diff --git a/dev-util/netsurf-buildsystem/files/gentoo-helpers.sh b/dev-util/netsurf-buildsystem/files/gentoo-helpers.sh
index e033a53f7672..ee81b3ccf88c 100644
--- a/dev-util/netsurf-buildsystem/files/gentoo-helpers.sh
+++ b/dev-util/netsurf-buildsystem/files/gentoo-helpers.sh
@@ -2,7 +2,7 @@
netsurf_define_makeconf() {
NETSURF_MAKECONF=(
- NSSHARED=/usr/share/netsurf-buildsystem
+ NSSHARED="${EROOT}"/usr/share/netsurf-buildsystem
LIBDIR="$(get_libdir)"
PREFIX="${EROOT}/usr"
Q=
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index af0978c715db..21822501c77e 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -1,2 +1,3 @@
DIST prosody-0.10.2.tar.gz 331874 BLAKE2B 0e0af95a9168810263e6f60b825393d1088f69dba1faabf6c0c9dda3ef6b039a92f7edb9643cb9a60a3131a64038de5c3598f7076837b58ad196ac03fa98bfc4 SHA512 9fc05e34b45b0c16835ba94a73532fb3b4ee335f27d56bb9260e1b3e22614f89f44eb5d04b4e90d016db0b5bee6f5c7e7d099e1defb027e6823ee7667c1fe28f
+DIST prosody-0.11.0.tar.gz 418710 BLAKE2B 2a9af1edbd77d3ef8f629ed5855a6638929bd0476d5245c0ef3ec6e2d840fda3a8b733bcfe35b7603057caa23576e0ec344d244d0c1678e28aa41badb75b6170 SHA512 292f555a25108716cd3ceb8ab39210bcb7f2fd113bd844092a51f68127e59b64ec76045740fd93edca8be2c1711a5fbab0f51a285f3ab78d36423a897ea667bf
DIST prosody-0.9.14.tar.gz 268253 BLAKE2B 0ae62ca3c8eb89feb34f1f67aa3d14aa1e6bf02cf10ff90a43fd7de8bd257d70508e36b10b3f159040c1fa5dcfb6ad8018e3411a5d6042992f71f643a13c11d4 SHA512 30116ebc20c719d88bae7f2f44c129604ec4477004581c3556ff548c75ee026a83dc519701a61a8c3f547776ba74c571e38c3e1e5240da9148dad35a5d1f67e3
diff --git a/net-im/prosody/prosody-0.11.0.ebuild b/net-im/prosody/prosody-0.11.0.ebuild
new file mode 100644
index 000000000000..7ccfe253a716
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib systemd
+
+MY_PV=$(ver_rs 3 '')
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua"
+HOMEPAGE="http://prosody.im/"
+SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit libressl"
+
+DEPEND="net-im/jabber-base
+ dev-lua/LuaBitOp
+ !jit? ( >=dev-lang/lua-5.1:0 )
+ jit? ( dev-lang/luajit:2 )
+ >=net-dns/libidn-1.1
+ !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= )"
+RDEPEND="${DEPEND}
+ >=dev-lua/luaexpat-1.3.0
+ dev-lua/luafilesystem
+ ipv6? ( >=dev-lua/luasocket-3 )
+ !ipv6? ( dev-lua/luasocket )
+ libevent? ( >=dev-lua/luaevent-0.4.3 )
+ mysql? ( dev-lua/luadbi[mysql] )
+ postgres? ( dev-lua/luadbi[postgres] )
+ sqlite? ( dev-lua/luadbi[sqlite] )
+ ssl? ( dev-lua/luasec )
+ zlib? ( dev-lua/lua-zlib )"
+
+S=${WORKDIR}/${MY_P}
+
+JABBER_ETC="/etc/jabber"
+JABBER_SPOOL="/var/spool/jabber"
+
+src_prepare() {
+ default
+ rm makefile && mv GNUmakefile Makefile || die
+ sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
+ -e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
+ -e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!"\
+ -e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!"\
+ Makefile || die
+}
+
+src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
+ append-cflags -D_GNU_SOURCE
+ luajit=""
+ if use jit; then
+ luajit="--runwith=luajit"
+ fi
+ ./configure \
+ --ostype=linux $luajit \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/lib64" \
+ --sysconfdir="${JABBER_ETC}" \
+ --datadir="${JABBER_SPOOL}" \
+ --with-lua-include=/usr/include \
+ --with-lua-lib=/usr/$(get_libdir)/lua \
+ --cflags="${CFLAGS} -Wall -fPIC" \
+ --ldflags="${LDFLAGS} -shared" \
+ --c-compiler="$(tc-getCC)" \
+ --linker="$(tc-getCC)" || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ systemd_dounit "${FILESDIR}/${PN}".service
+ systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
+ newinitd "${FILESDIR}/${PN}".initd-r2 ${PN}
+ keepdir /var/spool/jabber
+}
+
+pkg_postinst() {
+ elog "If you are using the MySQL backend, you need to update its schema:"
+ elog "https://prosody.im/doc/release/0.11.0#upgrade_notes"
+}