summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 09:18:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 10:07:15 +0200
commite3bb3ec64bc52cab8f1c9c6bca1c3169ede3180c (patch)
treefb5562a4c0365c7d6e844eff9f46d167587ae8b4
parentdev-python/sphinxcontrib-spelling: Bump to 7.4.0 (diff)
downloadgentoo-e3bb3ec64bc52cab8f1c9c6bca1c3169ede3180c.tar.gz
gentoo-e3bb3ec64bc52cab8f1c9c6bca1c3169ede3180c.tar.bz2
gentoo-e3bb3ec64bc52cab8f1c9c6bca1c3169ede3180c.zip
dev-python/rope: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.1.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 20aefabd8789..3ba59e8ff5f2 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-1.0.0.tar.gz 263335 BLAKE2B 5a2ecb494c7ab7833a75e54887e863fc5b35c2564d9ebcabb055084f1aff189bbedd2de13b1f8e0c56736886687c25111a42e47ff5ea84c217bb81927495e1a1 SHA512 f4a011750dfe51f092f29d1a911e4ce6c0425a31839f6ebade834d57472beeee9bae49cbd1f46ebcb2f3fe5c6aaf16edd583fd3a701b51b0f80d221c5aa23aed
+DIST rope-1.1.1.tar.gz 274610 BLAKE2B 52354453305ee58db70f86392f7ec27179e1e4a9ec677fb8875bb9ca24663e6dae26e1bac4a1ad62143fe3a419a7a1e1fd0b7d2f03ef556143d2b060b23300af SHA512 aaf664a63ef00e3c844d6999338fe6a3384ddecfe95ef9b7eb213e5c37c9f78f7d2ea59aa7e612487bac5eaaaf7fc8ba499c0d43c740f99a7b3be64c9d7f6e07
diff --git a/dev-python/rope/rope-1.1.1.ebuild b/dev-python/rope/rope-1.1.1.ebuild
new file mode 100644
index 000000000000..90418fa34ff6
--- /dev/null
+++ b/dev-python/rope/rope-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest