summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-05-31 18:33:46 +0200
committerHans de Graaff <graaff@gentoo.org>2023-05-31 18:37:50 +0200
commitdaf4b0640a76920887b35bdb7cd4cddc553fda90 (patch)
tree37a1cb83a17920e5f6315b72def7ad1788681987
parentnet-irc/irker: remove unused patch (diff)
downloadgentoo-daf4b0640a76920887b35bdb7cd4cddc553fda90.tar.gz
gentoo-daf4b0640a76920887b35bdb7cd4cddc553fda90.tar.bz2
gentoo-daf4b0640a76920887b35bdb7cd4cddc553fda90.zip
dev-ruby/capistrano: add 3.17.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/capistrano/Manifest1
-rw-r--r--dev-ruby/capistrano/capistrano-3.17.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/Manifest b/dev-ruby/capistrano/Manifest
index a05bbab31a6f..34f3b94970f2 100644
--- a/dev-ruby/capistrano/Manifest
+++ b/dev-ruby/capistrano/Manifest
@@ -1,2 +1,3 @@
DIST capistrano-2.15.5.gem 132096 BLAKE2B bbaa6bd482cf9bbe7aa01540aa5dab3f32401ffa1476d9057bb8ad420194f1ab2c32d8e744d7c982ebece5c4b5369133dc8378b7adf54c78732f9cb249db2a9e SHA512 10168080c7481ec6fc6f918ac90a3b1ce8f2b36f77411375e33cc915b02d5196ab061ac47e767edd724c82cffd1c2ad0a23ba1f0519cf1f2aae5b429167b19ff
DIST capistrano-3.17.2.gem 69632 BLAKE2B e2d1c16d7b4118593e5e8741dff0fdebd69af61db9c2796faeeadfdaabf04577775b2092917c60eba6d213680dba6d241b4b4ac1295e74da11c607fb54392ae3 SHA512 2c8943eda6dab2c4016c5eb86773040a4a0640e58405115f56c9c8c02dfd06bf2c7a98a0a0bee5d5c77dde16b262ab7131210bbba8ae1b5a8f5172cae76492a3
+DIST capistrano-3.17.3.gem 70144 BLAKE2B d8bd93bb41a41196394b0959fa0bdf17609c9c53771bbfbf87cbc02b169177ad7cc18613a18d362a7fc775c91a382071d2384262d5cb49b1534678aac575dc55 SHA512 b7b85ebf7309d93aed83f68dc897e5a6cb4c8a929f4427c8a29db2ef6f857ee110256ba80c2fe0ae15f8008597c47be5ec60c192f3268d0df66f761b90d0758f
diff --git a/dev-ruby/capistrano/capistrano-3.17.3.ebuild b/dev-ruby/capistrano/capistrano-3.17.3.ebuild
new file mode 100644
index 000000000000..060941c9ee4a
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.17.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="https://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+
+ # Avoid specs that require a TTY
+ sed -i -e '/asking for a variable/,/^ end/ s:^:#:' spec/integration/dsl_spec.rb || die
+ rm -f spec/lib/capistrano/configuration/question_spec.rb spec/lib/capistrano/doctor/output_helpers_spec.rb || die
+}