summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-22 10:52:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-22 10:55:48 +0100
commitd351e8aacb84894ac12da01abeb1cc672661228c (patch)
tree275d34f8011c392d3b39e58703fa676bf5cdea73
parentdev-python/nbformat: Remove old (diff)
downloadgentoo-d351e8aacb84894ac12da01abeb1cc672661228c.tar.gz
gentoo-d351e8aacb84894ac12da01abeb1cc672661228c.tar.bz2
gentoo-d351e8aacb84894ac12da01abeb1cc672661228c.zip
dev-python/xdoctest: Bump to 0.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 1cab8e346565..d822b7408af5 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-0.15.0.tar.gz 629125 BLAKE2B f5144365c4d1d58c107ac0603a1d99cd5bc622d3772fc7f2c907193ea863d9ff99bd183cc7fac12e2f85b7647ba25d5ae6878c06d3df9a5cdda9a1f143b43110 SHA512 114add93a75807d787c674b0649f92ff011987705f640912f876c4a4c3103cef90b0fae1959d5a85ef399b80695e9cbfcae6e809950ff5651fa211f54326682d
+DIST xdoctest-0.15.2.tar.gz 883332 BLAKE2B e90364d6096357ff1b5006b289a56a1afd0f3d0e952202d17a1b99c16f867e23ce0214a4f646154d9f6aada9f94ddda47a9c1f669a833bffaa63d99c10837766 SHA512 ca3bfc241e2d137988ee6dda2e9229f74add662fc2fe295c4c006a3d63ac6284f3f623451006acc4a8273729ccc589e1c5bab9d7fc65135582d7fc9fcffea464
diff --git a/dev-python/xdoctest/xdoctest-0.15.2.ebuild b/dev-python/xdoctest/xdoctest-0.15.2.ebuild
new file mode 100644
index 000000000000..74735ab8e849
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-0.15.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ || (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ <dev-python/nbformat-5.1[${PYTHON_USEDEP}]
+ )
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+python_test() {
+ local -x PYTHONPATH=.
+ pytest -vv || die "Test fail with ${EPYTHON}"
+}