summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-22 09:52:02 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-22 10:02:59 +0200
commitbf2c4a7522c3b48cc9a757e030c9a41688b488dc (patch)
treea7bbd1421cf5398f0c679fbc30cac9cdcbcd6b78
parentdev-haskell/cmark-gfm: treeclean (diff)
downloadgentoo-bf2c4a7522c3b48cc9a757e030c9a41688b488dc.tar.gz
gentoo-bf2c4a7522c3b48cc9a757e030c9a41688b488dc.tar.bz2
gentoo-bf2c4a7522c3b48cc9a757e030c9a41688b488dc.zip
dev-haskell/cmark: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-haskell/cmark/Manifest1
-rw-r--r--dev-haskell/cmark/cmark-0.6.ebuild34
-rw-r--r--dev-haskell/cmark/metadata.xml90
-rw-r--r--profiles/package.mask1
4 files changed, 0 insertions, 126 deletions
diff --git a/dev-haskell/cmark/Manifest b/dev-haskell/cmark/Manifest
deleted file mode 100644
index 98138b5dd5e4..000000000000
--- a/dev-haskell/cmark/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cmark-0.6.tar.gz 169132 BLAKE2B d6c72aa17216f89e90a269d2fcd6639f25ac2e9aa02a0799108a85247b5ccb5211ee02dc078cdbccfbd6295705799d5b49e2af70d50cd6a791fbf4ddcea70a01 SHA512 35d2851bb1d3305000527cfce81253c9492a3e3205e73418fe42fcc9f8e5f8e396a7ecf81ad4a003a2dd4a571c4f7d051bc6812c07a5c79dc30eac1d45fca4f5
diff --git a/dev-haskell/cmark/cmark-0.6.ebuild b/dev-haskell/cmark/cmark-0.6.ebuild
deleted file mode 100644
index ebd870a5758e..000000000000
--- a/dev-haskell/cmark/cmark-0.6.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.9999
-#hackport: flags: pkgconfig:system-cmark
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
-HOMEPAGE="https://github.com/jgm/cmark-hs"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="system-cmark"
-
-RDEPEND=">=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- system-cmark? ( app-text/cmark )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.14
- test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7 )
- system-cmark? ( virtual/pkgconfig )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag system-cmark pkgconfig)
-}
diff --git a/dev-haskell/cmark/metadata.xml b/dev-haskell/cmark/metadata.xml
deleted file mode 100644
index 0331282b8416..000000000000
--- a/dev-haskell/cmark/metadata.xml
+++ /dev/null
@@ -1,90 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <use>
- <flag name="system-cmark">use <pkg>app-text/cmark</pkg> instead of bundled copy</flag>
- </use>
- <longdescription>
- This package provides Haskell bindings for
- &lt;https://github.com/jgm/cmark libcmark&gt;, the reference
- parser for &lt;http://commonmark.org CommonMark&gt;, a fully
- specified variant of Markdown. It includes sources for
- libcmark (0.19.0) and does not require prior installation of the
- C library.
-
- cmark provides the following advantages over existing
- Markdown libraries for Haskell:
-
- - Speed: Conversion speed is on par with the
- &lt;https://hackage.haskell.org/package/sundown sundown&gt;
- library. We were unable to measure precisely
- against
- &lt;https://hackage.haskell.org/package/sundown sundown&gt;,
- which raised a malloc error when compiled into our
- benchmark suite. Relative to other implementations:
- cmark was 82 times faster than
- &lt;https://hackage.haskell.org/package/cheapskate cheapskate&gt;,
- 59 times faster than
- &lt;https://hackage.haskell.org/package/markdown markdown&gt;,
- 105 times faster than
- &lt;https://hackage.haskell.org/package/pandoc pandoc&gt;,
- and 2.8 times faster than
- &lt;https://hackage.haskell.org/package/discount discount&gt;.
-
- - Memory footprint: Memory footprint is on par with
- &lt;https://hackage.haskell.org/package/sundown sundown&gt;.
- On one sample, the library uses a fourth the memory that
- &lt;https://hackage.haskell.org/package/markdown markdown&gt;
- uses, and less than a tenth the memory that
- &lt;https://hackage.haskell.org/package/pandoc pandoc&gt;
- uses.
-
- - Robustness: cmark can handle whatever is thrown
- at it, without the exponential blowups in parsing
- time one can sometimes get with other libraries.
- (The input @bench\/full-sample.md@, for example,
- causes both
- &lt;https://hackage.haskell.org/package/pandoc pandoc&gt;
- and
- &lt;https://hackage.haskell.org/package/markdown markdown&gt;
- to grind to a halt.)
-
- - Accuracy: cmark passes the CommonMark spec\'s
- suite of over 500 conformance tests.
-
- - Standardization: Since there is a spec and a
- comprehensive suite of tests, we can have a high
- degree of confidence that any two CommonMark
- implementations will behave the same. Thus, for
- example, one could use this library for server-side
- rendering and
- &lt;https://github.com/jgm/commonmark.js commonmark.js&gt;
- for client-side previewing.
-
- - Ease of installation: cmark is portable and has
- minimal dependencies.
-
- cmark does not provide Haskell versions of the whole
- &lt;https://github.com/jgm/cmark libcmark&gt; API, which is
- built around mutable @cmark_node@ objects. Instead, it
- provides functions for converting CommonMark to HTML
- (and other formats), and a function for converting
- CommonMark to a @Node@ tree that can be processed
- further using Haskell.
-
- A note on security: This library does not attempt
- to sanitize HTML output. We recommend using
- &lt;https://hackage.haskell.org/package/xss-sanitize xss-sanitize&gt;
- to filter the output.
-
- A note on stability: There is a good chance the API
- will change significantly after this early release.
- </longdescription>
- <upstream>
- <remote-id type="github">jgm/commonmark-hs</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 606c2fce10c0..a63dc48777a8 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -372,7 +372,6 @@ dev-haskell/cipher-camellia
dev-haskell/cipher-des
dev-haskell/cipher-rc4
dev-haskell/classy-prelude
-dev-haskell/cmark
# Hans de Graaff <graaff@gentoo.org> (2022-07-16)
# No longer supported upstream. Use a newer ruby version instead.