summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-09 03:08:03 +0100
committerSam James <sam@gentoo.org>2021-08-09 03:08:03 +0100
commita355cce76d15a88a307c07ee7939a2b8148f6d22 (patch)
treef1828ee25fe553a597f953d671fca08828af5a39
parentnet-misc/curl: Stabilize 7.78.0 sparc, #803308 (diff)
downloadgentoo-a355cce76d15a88a307c07ee7939a2b8148f6d22.tar.gz
gentoo-a355cce76d15a88a307c07ee7939a2b8148f6d22.tar.bz2
gentoo-a355cce76d15a88a307c07ee7939a2b8148f6d22.zip
net-analyzer/nmap: add 7.92
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/nmap/Manifest2
-rw-r--r--net-analyzer/nmap/nmap-7.92.ebuild131
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild7
3 files changed, 137 insertions, 3 deletions
diff --git a/net-analyzer/nmap/Manifest b/net-analyzer/nmap/Manifest
index d261befb90a4..335efc4b01d6 100644
--- a/net-analyzer/nmap/Manifest
+++ b/net-analyzer/nmap/Manifest
@@ -1,3 +1,5 @@
DIST nmap-7.80.tar.bz2 10550327 BLAKE2B 513a5589f4dd72660d290cc03b8130da2c41e4620c5a82e125e4345259b8d0f6efa8bceef47d3c0d2b5b588888b716070e05105a09b0185622aed9268715ae2c SHA512 d4384d3ebf4f3abf3588eed5433f733874ecdceb9342a718dc36db19634b0cc819d73399974eb0a9a9c9dd9e5c88473e07644ec91db28b0c072552b54430be6b
DIST nmap-7.91.tar.bz2 10503500 BLAKE2B a758e0a20f8243b33b000c23e025b87bdb712390b82982a1aca219c9b98cd55c6ababb810328c7d0cdb5c884ef9bd5b187b9e4929454278342d7ee5ef441cded SHA512 9d59f031b5f748311e9f9a0b9d05ad4a7a70fc6ac17598d7c4c81a4825c95d53817d74435d839e67b9379a052f2d37889fd634f9c75301a851f465d60fb9974d
DIST nmap-7.91.tar.bz2.asc 195 BLAKE2B 16c4bad309c4652128a67f00c6b89f6552f432166733cac45756c20df0f48bdd0b8b9edbcce3df8f25d0a8e422be2494d9d5639fa74fc3f1e2c13489c52387c1 SHA512 376b74fc15896a1008709dac45b5af5d35ca00a1753994aba3ee6cffe2c2f0d67619fab45d57e83b454cfb376defe965f2bf881ef4cb8d5f8f2215979ad8ee96
+DIST nmap-7.92.tar.bz2 10498200 BLAKE2B 0f3022e797ffca7d1d3497990c86bb60ac9a80bb93cb4ec7fcfa4f51782cb8d79d4f0aca0fa6119bfd604cfe7b89af3d4223ce13ad3e6c948c021909aebd956b SHA512 7828367f9dc76ff4d1e8c821260e565fb0c3cb6aba0473d24759133a3006cdf2cb087574f0dd7d2ba47a63754ba4f72e0b78cdae1333a58f05c41d428b56ad59
+DIST nmap-7.92.tar.bz2.asc 195 BLAKE2B a8052138e58cd8009341a5f3fb3a31f55af9383b9dbb6c7ce858d80541e000b17953c053e9a3a6d86a5551244cf13f181e6e3943095b86335cbb5dae96e20bdd SHA512 300a22ab097bbff67de354de6b22a8e3287f95dd6318fcabd546ba52158e9589b19ede175587c6e31518c47bc118c7dd05db43755def075d810b16945b65e05a
diff --git a/net-analyzer/nmap/nmap-7.92.ebuild b/net-analyzer/nmap/nmap-7.92.ebuild
new file mode 100644
index 000000000000..d0ab6cc2b59c
--- /dev/null
+++ b/net-analyzer/nmap/nmap-7.92.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-3 )
+LUA_REQ_USE="deprecated"
+inherit autotools lua-single toolchain-funcs
+
+DESCRIPTION="Network exploration tool and security / port scanner"
+HOMEPAGE="https://nmap.org/"
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/nmap/nmap"
+
+ # Just in case for now as future seems undecided.
+ LICENSE="NPSL"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/nmap.asc
+ inherit verify-sig
+
+ SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
+ SRC_URI+=" verify-sig? ( https://nmap.org/dist/sigs/${P}.tar.bz2.asc )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+ LICENSE="|| ( NPSL GPL-2 )"
+fi
+
+SLOT="0"
+IUSE="ipv6 libssh2 ncat nping +nse ssl +system-lua"
+REQUIRED_USE="system-lua? ( nse ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/liblinear:=
+ dev-libs/libpcre
+ net-libs/libpcap
+ libssh2? (
+ net-libs/libssh2[zlib]
+ sys-libs/zlib
+ )
+ nse? ( sys-libs/zlib )
+ ssl? ( dev-libs/openssl:0= )
+ system-lua? ( ${LUA_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+="verify-sig? ( app-crypt/openpgp-keys-nmap )"
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.10_beta1-string.patch
+ "${FILESDIR}"/${PN}-5.21-python.patch
+ "${FILESDIR}"/${PN}-6.46-uninstaller.patch
+ "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
+ "${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
+ "${FILESDIR}"/${PN}-7.25-libpcre.patch
+ "${FILESDIR}"/${PN}-7.31-libnl.patch
+ "${FILESDIR}"/${PN}-7.80-ac-config-subdirs.patch
+ "${FILESDIR}"/${PN}-7.91-no-FORTIFY_SOURCE.patch
+)
+
+pkg_setup() {
+ use system-lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ rm -r liblinear/ libpcap/ libpcre/ libssh2/ libz/ || die
+
+ cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
+
+ default
+
+ sed -i \
+ -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
+ Makefile.in || die
+
+ cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
+
+ eautoreconf
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # we need the original for a Darwin-specific fix, bug #604432
+ mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
+ fi
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf \
+ $(use_enable ipv6) \
+ $(use_with libssh2) \
+ $(use_with ncat) \
+ $(use_with nping) \
+ $(use_with ssl openssl) \
+ $(usex libssh2 --with-zlib) \
+ $(usex nse --with-liblua=$(usex system-lua yes included '' '') --without-liblua) \
+ $(usex nse --with-zlib) \
+ --cache-file="${S}"/config.cache \
+ --with-libdnet=included \
+ --with-pcre="${ESYSROOT}"/usr \
+ --without-ndiff \
+ --without-zenmap
+}
+
+src_compile() {
+ local directory
+ for directory in . libnetutil nsock/src \
+ $(usex ncat ncat '') \
+ $(usex nping nping '')
+ do
+ emake -C "${directory}" makefile.dep
+ done
+
+ emake \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ LC_ALL=C emake -j1 \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+
+ dodoc CHANGELOG HACKING docs/README docs/*.txt
+}
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 0b17737335e2..58f0f67de1fa 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -17,14 +17,15 @@ if [[ ${PV} == *9999* ]] ; then
# Just in case for now as future seems undecided.
LICENSE="NPSL"
else
- VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/nmap.asc
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/nmap.asc
inherit verify-sig
SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
SRC_URI+=" verify-sig? ( https://nmap.org/dist/sigs/${P}.tar.bz2.asc )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
LICENSE="|| ( NPSL GPL-2 )"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
SLOT="0"
@@ -101,7 +102,7 @@ src_configure() {
$(usex nse --with-zlib) \
--cache-file="${S}"/config.cache \
--with-libdnet=included \
- --with-pcre=/usr \
+ --with-pcre="${ESYSROOT}"/usr \
--without-ndiff \
--without-zenmap
}