summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-07-10 21:21:12 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-07-10 21:21:12 +0000
commita2e40743fe58ce39448749e37a5c83937fa4900b (patch)
treebe70988ab4021e45d91e36d36250959d90e808f2
parent2021-07-10 20:52:11 UTC (diff)
parentdev-util/qbs: drop 1.16.0 (diff)
downloadgentoo-a2e40743fe58ce39448749e37a5c83937fa4900b.tar.gz
gentoo-a2e40743fe58ce39448749e37a5c83937fa4900b.tar.bz2
gentoo-a2e40743fe58ce39448749e37a5c83937fa4900b.zip
Merge updates from master
-rw-r--r--dev-util/qbs/Manifest2
-rw-r--r--dev-util/qbs/metadata.xml12
-rw-r--r--dev-util/qbs/qbs-1.19.1.ebuild (renamed from dev-util/qbs/qbs-1.16.0.ebuild)48
3 files changed, 35 insertions, 27 deletions
diff --git a/dev-util/qbs/Manifest b/dev-util/qbs/Manifest
index 142b017fb2d7..bfcc02f2c5b5 100644
--- a/dev-util/qbs/Manifest
+++ b/dev-util/qbs/Manifest
@@ -1,2 +1,2 @@
-DIST qbs-src-1.16.0.tar.gz 4571788 BLAKE2B 4fb06314d0d0a532574e0d245ea85b6d596850ffe4b81b621406d1bc99e0529fc491bf5c7db514d90026c0bf4916f9fa102457aab2bbaaddbbe2e90c03aa04a4 SHA512 65c5398ffad54e10e251bed79a5b58abd722c0f95a031c536fc8647d915dd696923401c767a7a8ac029f4f571b6bbf96ef4b7493bb30768f675477bd68fcc21c
DIST qbs-src-1.18.0.tar.gz 4921432 BLAKE2B 4c081434596c58d433e52ca9e335e3b4d62b75e401290895719b7fbe4f3c20cf8b34ab0753ae79a34b4e29c8859751a6276da8d6dbd5f3c711581af16ab61415 SHA512 bdef30200c7e74749c363b1d68232fd90d1dfc998722bee0e058ffcaff8e003599e0404b49f86cbeae098d59ccb5663316db5094d77b50a217fcf4ab5ae64d83
+DIST qbs-src-1.19.1.tar.gz 4961984 BLAKE2B 2b9333ac8bba12f311ad47b1315d0a61ddf3b3a804888369f3fd868fbebca4ad13bd857451cb3fe3515fd9f9e69b42b84484289e79d3e7911c69720d7d08ab29 SHA512 b53dae9631c9d4ec1f799395948a67ce4b62ae88908cce3b00f42fb0213d80d32127c3429b95d5c32c9f7c1b861fc5a52ac6952046a6d91d035539d7412a5c4d
diff --git a/dev-util/qbs/metadata.xml b/dev-util/qbs/metadata.xml
index 4311f5d8ba92..06efa80b24ba 100644
--- a/dev-util/qbs/metadata.xml
+++ b/dev-util/qbs/metadata.xml
@@ -14,10 +14,14 @@
projects across multiple platforms. Qbs can be used for any software
project, regardless of programming language, toolkit, or libraries used.
- Qbs is an all-in-one tool that generates a build graph from a
- high-level project description (like qmake or cmake) and additionally
- undertakes the task of executing the commands in the low-level build
- graph (like make).
+ Qbs projects are specified in a QML dialect. QML is a concise, easy to
+ learn, and intuitive language that is used successfully in the Qt project.
+ Its core is declarative, but it can be extended with JavaScript snippets
+ for extra flexibility.
+
+ Qbs is an all-in-one tool that generates a build graph from a high-level
+ project description (like qmake or CMake) and additionally undertakes the
+ task of executing the commands in the low-level build graph (like make).
</longdescription>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-util/qbs/qbs-1.16.0.ebuild b/dev-util/qbs/qbs-1.19.1.ebuild
index 2ecd2be09ac4..3339bb574287 100644
--- a/dev-util/qbs/qbs-1.16.0.ebuild
+++ b/dev-util/qbs/qbs-1.19.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit qmake-utils toolchain-funcs
@@ -9,37 +9,40 @@ MY_P=${PN}-src-${PV}
DESCRIPTION="Modern build tool for software projects"
HOMEPAGE="https://doc.qt.io/qbs/"
-SRC_URI="http://download.qt.io/official_releases/${PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://download.qt.io/official_releases/${PN}/${PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="|| ( LGPL-2.1 LGPL-3 )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples test"
+IUSE="doc examples gui test"
RESTRICT="!test? ( test )"
-# see bug 581874 for the qttest dep in RDEPEND
RDEPEND="
dev-qt/qtcore:5=
- dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtscript:5
- dev-qt/qtwidgets:5
dev-qt/qtxml:5
- test? ( dev-qt/qttest:5 )
+ gui? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
"
DEPEND="${RDEPEND}
- doc? (
- dev-qt/qdoc:5
- dev-qt/qthelp:5
- )
test? (
dev-qt/linguist-tools:5
dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
+ dev-qt/qttest:5
+ )
+"
+BDEPEND="
+ dev-qt/qtcore:5
+ doc? (
+ dev-qt/qdoc:5
+ dev-qt/qthelp:5
)
"
-
-S=${WORKDIR}/${MY_P}
src_prepare() {
default
@@ -48,18 +51,19 @@ src_prepare() {
sed -i -e '/INSTALLS +=/ s:examples::' static.pro || die
fi
- echo "SUBDIRS = $(usex test auto '')" >> tests/tests.pro
+ if ! use gui; then
+ sed -i -e '/SUBDIRS += config-ui/ d' src/app/app.pro || die
+ fi
+
+ echo "SUBDIRS = $(usev test auto)" >> tests/tests.pro
# skip several tests that fail and/or have additional deps
sed -i \
- -e 's/findArchiver("7z")/""/' `# requires p7zip, fails` \
-e 's/findArchiver(binaryName,.*/"";/' `# requires zip and jar` \
-e 's/p\.value("nodejs\./true||&/' `# requires nodejs, bug 527652` \
-e 's/\(p\.value\|m_qbsStderr\.contains\)("typescript\./true||&/' `# requires nodejs and typescript` \
tests/auto/blackbox/tst_blackbox.cpp || die
-
- # requires jdk, fails, bug 585398
- sed -i -e '/blackbox-java\.pro/ d' tests/auto/auto.pro || die
+ sed -i -re '/blackbox-(android|apple|java)\.pro/ d' tests/auto/auto.pro || die
}
src_configure() {
@@ -68,7 +72,7 @@ src_configure() {
-recursive
CONFIG+=qbs_disable_rpath
CONFIG+=qbs_enable_project_file_updates
- $(usex test 'CONFIG+=qbs_enable_unit_tests' '')
+ $(usev test 'CONFIG+=qbs_enable_unit_tests')
QBS_INSTALL_PREFIX="${EPREFIX}/usr"
QBS_LIBRARY_DIRNAME="$(get_libdir)"
)
@@ -102,9 +106,9 @@ src_test() {
}
src_install() {
- emake INSTALL_ROOT="${D}" install
+ emake -j1 INSTALL_ROOT="${D}" install
- dodoc -r changelogs README.md
+ dodoc -r changelogs CONTRIBUTING.md README.md
# install documentation
if use doc; then