summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-11-26 10:55:25 -0500
committerMike Gilbert <floppym@gentoo.org>2018-11-26 10:56:17 -0500
commit9d3277a5199c609627f126311021435b87f5f640 (patch)
treede40a8fc28f608bfd773f7f88fa8213d0ffa0e77
parentdev-ruby/ed25519: add ~arm bug# 671660 (diff)
downloadgentoo-9d3277a5199c609627f126311021435b87f5f640.tar.gz
gentoo-9d3277a5199c609627f126311021435b87f5f640.tar.bz2
gentoo-9d3277a5199c609627f126311021435b87f5f640.zip
Revert "dev-python/cryptography: add missing pycparser dep"
This reverts commit 76e7a21981368a77cbcdb198a91d63baebc1760e. cryptography does not depend on pycparser directly. Bug: https://bugs.gentoo.org/671948 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-python/cryptography/cryptography-2.2.2-r1.ebuild3
-rw-r--r--dev-python/cryptography/cryptography-2.3.1.ebuild1
-rw-r--r--dev-python/cryptography/cryptography-2.3.ebuild3
3 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/cryptography/cryptography-2.2.2-r1.ebuild b/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
index e4d73ba997e1..449719f769ca 100644
--- a/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
+++ b/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,7 +42,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- dev-python/pycparser[${PYTHON_USEDEP}]
test? (
~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-2.3.1.ebuild b/dev-python/cryptography/cryptography-2.3.1.ebuild
index 9c239e0ef880..1a58e5692ef8 100644
--- a/dev-python/cryptography/cryptography-2.3.1.ebuild
+++ b/dev-python/cryptography/cryptography-2.3.1.ebuild
@@ -41,7 +41,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- dev-python/pycparser[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
diff --git a/dev-python/cryptography/cryptography-2.3.ebuild b/dev-python/cryptography/cryptography-2.3.ebuild
index f858938c524b..ec123a175ee9 100644
--- a/dev-python/cryptography/cryptography-2.3.ebuild
+++ b/dev-python/cryptography/cryptography-2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,7 +41,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- dev-python/pycparser[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (