summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-01-23 10:40:25 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-01-23 10:40:25 +0000
commit9a5ec16a8114889a659cdfc5ccd6807e9d16c291 (patch)
tree0faac2aa6de1ae16b7337632e485da3a8ba4cd9f
parent2021-01-23 09:32:43 UTC (diff)
parentx11-wm/icewm: Removed old (diff)
downloadgentoo-9a5ec16a8114889a659cdfc5ccd6807e9d16c291.tar.gz
gentoo-9a5ec16a8114889a659cdfc5ccd6807e9d16c291.tar.bz2
gentoo-9a5ec16a8114889a659cdfc5ccd6807e9d16c291.zip
Merge updates from master
-rw-r--r--dev-python/Faker/Faker-5.6.5.ebuild (renamed from dev-python/Faker/Faker-5.5.1.ebuild)6
-rw-r--r--dev-python/Faker/Manifest2
-rw-r--r--dev-python/Faker/files/Faker-5.6.5-ukposttest.patch (renamed from dev-python/Faker/files/Faker-5.5.1-ukposttest.patch)12
-rw-r--r--dev-python/tld/tld-0.12.5.ebuild4
-rw-r--r--eclass/toolchain-funcs.eclass21
-rw-r--r--x11-wm/icewm/Manifest2
-rw-r--r--x11-wm/icewm/icewm-2.1.0.ebuild (renamed from x11-wm/icewm/icewm-2.0.0.ebuild)2
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild118
-rw-r--r--x11-wm/windowmaker/windowmaker-9999.ebuild66
9 files changed, 186 insertions, 47 deletions
diff --git a/dev-python/Faker/Faker-5.5.1.ebuild b/dev-python/Faker/Faker-5.6.5.ebuild
index efc26fd7d0f0..4a51d5a89546 100644
--- a/dev-python/Faker/Faker-5.5.1.ebuild
+++ b/dev-python/Faker/Faker-5.6.5.ebuild
@@ -15,14 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]"
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
DEPEND=""
BDEPEND="test? (
dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
dev-python/validators[${PYTHON_USEDEP}]
)"
# Specific test dependency for one country post code tests
-PATCHES=( "${FILESDIR}"/${PN}-5.5.1-ukposttest.patch )
+PATCHES=( "${FILESDIR}"/${PN}-5.6.5-ukposttest.patch )
distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index a1955ece9999..90cad02d069d 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1 @@
-DIST Faker-5.5.1.tar.gz 1045964 BLAKE2B d0e06b0994fec1b1fbbfbc8cabb12f9a3666894304c673a8e7cc27bb52a7bf66bef8d110665b459a1c43e2b5f0d93e59f793f00279b123ff25c36ba4b4ed2cac SHA512 58d240801d72bbb884d1788931621e4ae9fa4e3ea749af90d9703fe99af23c38c86902970574838135398305877e8d196d18dc14eeb71cfe9c9c6390fbf511cb
+DIST Faker-5.6.5.tar.gz 1058615 BLAKE2B 2a730b79ca11a80b33f5249541e2de68e5c53832fcd06891ce2e074dbca8aa21c657147e55725d37954cb997a2b1854b5c853449e7d58a71358b69fd2a36584f SHA512 1806eded3534602eb5c463ad030564edfe7c663952e62e943b809dd5d7c4e485b26c612e45f481b6125f6462d48215df065f2d3f30df67ab19699b6386a65b7b
diff --git a/dev-python/Faker/files/Faker-5.5.1-ukposttest.patch b/dev-python/Faker/files/Faker-5.6.5-ukposttest.patch
index 5ff925613ac3..3cd84c171cf4 100644
--- a/dev-python/Faker/files/Faker-5.5.1-ukposttest.patch
+++ b/dev-python/Faker/files/Faker-5.6.5-ukposttest.patch
@@ -1,6 +1,6 @@
-diff -Naur Faker-5.5.1.orig/tests/providers/test_address.py Faker-5.5.1/tests/providers/test_address.py
---- Faker-5.5.1.orig/tests/providers/test_address.py 2021-01-07 17:08:37.000000000 +0100
-+++ Faker-5.5.1/tests/providers/test_address.py 2021-01-12 22:07:13.748206737 +0100
+diff -Naur Faker-5.6.5.orig/tests/providers/test_address.py Faker-5.6.5/tests/providers/test_address.py
+--- Faker-5.6.5.orig/tests/providers/test_address.py 2021-01-20 16:16:43.000000000 +0100
++++ Faker-5.6.5/tests/providers/test_address.py 2021-01-23 10:12:35.826357768 +0100
@@ -4,8 +4,6 @@
import pytest
@@ -10,7 +10,7 @@ diff -Naur Faker-5.5.1.orig/tests/providers/test_address.py Faker-5.5.1/tests/pr
from faker.providers.address.cs_CZ import Provider as CsCzAddressProvider
from faker.providers.address.da_DK import Provider as DaDkAddressProvider
from faker.providers.address.de_AT import Provider as DeAtAddressProvider
-@@ -375,20 +373,6 @@
+@@ -377,20 +375,6 @@
assert re.fullmatch(r'(?:Apt\.|Suite) \d{3}', secondary_address)
@@ -28,6 +28,6 @@ diff -Naur Faker-5.5.1.orig/tests/providers/test_address.py Faker-5.5.1/tests/pr
- assert county in EnGbAddressProvider.counties
-
-
- class TestEnUS:
- """Test en_US address provider methods"""
+ class TestEnIe:
+ """Test en_IE address provider methods"""
diff --git a/dev-python/tld/tld-0.12.5.ebuild b/dev-python/tld/tld-0.12.5.ebuild
index ba3c451c647b..3c09f0f0acae 100644
--- a/dev-python/tld/tld-0.12.5.ebuild
+++ b/dev-python/tld/tld-0.12.5.ebuild
@@ -18,10 +18,10 @@ RESTRICT="!test? ( test )"
BDEPEND="test? (
dev-python/Faker[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
)"
# Calls system binary directly
PATCHES=( "${FILESDIR}"/${PN}-0.12.5-names_cli_test.patch )
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 4a4bb27fc084..267cf5cfce34 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -1,4 +1,4 @@
-# Copyright 2002-2019 Gentoo Authors
+# Copyright 2002-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: toolchain-funcs.eclass
@@ -505,12 +505,21 @@ tc-ld-is-lld() {
# If the gold linker is currently selected, configure the compilation
# settings so that we use the older bfd linker instead.
tc-ld-disable-gold() {
- if ! tc-ld-is-gold "$@" ; then
- # They aren't using gold, so nothing to do!
+ tc-ld-is-gold "$@" && tc-ld-force-bfd "$@"
+}
+
+# @FUNCTION: tc-ld-force-bfd
+# @USAGE: [toolchain prefix]
+# @DESCRIPTION:
+# If the gold or lld linker is currently selected, configure the compilation
+# settings so that we use the bfd linker instead.
+tc-ld-force-bfd() {
+ if ! tc-ld-is-gold "$@" && ! tc-ld-is-lld "$@" ; then
+ # They aren't using gold or lld, so nothing to do!
return
fi
- ewarn "Forcing usage of the BFD linker instead of GOLD"
+ ewarn "Forcing usage of the BFD linker"
# Set up LD to point directly to bfd if it's available.
# We need to extract the first word in case there are flags appended
@@ -520,7 +529,7 @@ tc-ld-disable-gold() {
local path_ld=$(which "${bfd_ld}" 2>/dev/null)
[[ -e ${path_ld} ]] && export LD=${bfd_ld}
- # Set up LDFLAGS to select gold based on the gcc / clang version.
+ # Set up LDFLAGS to select bfd based on the gcc / clang version.
local fallback="true"
if tc-is-gcc; then
local major=$(gcc-major-version "$@")
@@ -548,7 +557,7 @@ tc-ld-disable-gold() {
ln -sf "${path_ld}" "${d}"/ld
export LDFLAGS="${LDFLAGS} -B${d}"
else
- die "unable to locate a BFD linker to bypass gold"
+ die "unable to locate a BFD linker"
fi
fi
}
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index 7d96efce6032..f5e6764fa3ec 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,3 @@
DIST icewm-1.9.2.tar.lz 1694602 BLAKE2B cf30a695ba48093b386aa2f3af5120e78a9fcc57da9038bcd546ade0986e1bc359a3da91d2eeeb8d3a105173f5d755223675a84b38cfc8c907269efd2561c706 SHA512 7b4f8c47c636a0113af576bc1bcd9fde111ae70eb0bcf21fb1d906ca43bea4d8b0337a728e5da35bcfeabd56c66fd0d14581d7377f063dd750fdf01362b24be2
-DIST icewm-2.0.0.tar.lz 1694653 BLAKE2B 36feb02d653256b4d6755618da89400c3925279757da32695d6b8c2206d69228bcf392852eaba8b9096d06b60b5f021a0b6b474140a7754c4865d575d8a868dc SHA512 58b9a62d15add73c9c535e8602711636058b67b5e89b6189656a2d0668d2e647b9a59c45b5602f634ffd89abe7fb8a03be094524f3ff6d2b136bb8e21bc79fa3
DIST icewm-2.0.1.tar.lz 1694439 BLAKE2B 1476f33fa7350a98b7eca8c5c265455d0a78b28bcbd35ab78969b528ae02d3c960fb73cf2b24ea999ee5e08c9f0641d3502c7d5ed8b285777162c334d645b6db SHA512 ac4126b38d592aed60d2269f58c5a1612b61e871565e3c3e51bc2b430e4da6a4708f78e86c16091fa4dfb9eefd4109ae89102ab708e3bce9a44f1e5fe1970c59
+DIST icewm-2.1.0.tar.lz 1696214 BLAKE2B ba91eac4ea425fc9979d1c64fbc2a4c59f1d8004138f31b1e184484cfcaaca7c1a550cd160ff3683a4f663e54efdd5f8ded001317765485259a1f19b8de794a3 SHA512 a57ebbf76640b5296c90c105bdc9b9b2cc55546d324fa18b2e7bfc6bee4442b56176bda4a584d6a73b2297203e1966d7646354bb6e0baaf64fdf0acdb357ee58
diff --git a/x11-wm/icewm/icewm-2.0.0.ebuild b/x11-wm/icewm/icewm-2.1.0.ebuild
index e00f833b8352..ec1d0545c005 100644
--- a/x11-wm/icewm/icewm-2.0.0.ebuild
+++ b/x11-wm/icewm/icewm-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
diff --git a/x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild b/x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild
new file mode 100644
index 000000000000..169193220615
--- /dev/null
+++ b/x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop eutils
+
+DESCRIPTION="The fast and light GNUstep window manager"
+HOMEPAGE="https://www.windowmaker.org/"
+SRC_URI="https://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
+ https://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gif imagemagick jpeg modelock nls png tiff webp xinerama +xpm xrandr"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="media-libs/fontconfig
+ >=x11-libs/libXft-2.1.0
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXv
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ imagemagick? ( >=media-gfx/imagemagick-7:0= )
+ jpeg? ( virtual/jpeg:0= )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0 )
+ webp? ( media-libs/libwebp )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
+
+S=${WORKDIR}/${P/windowm/WindowM}
+
+DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL-WMAKER FAQ
+ NEWS README README.definable-cursor README.i18n TODO )
+PATCHES=( "${FILESDIR}"/${PN}-0.95.8-configure_default_search_paths.patch )
+
+src_prepare() {
+ # Fix some paths
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s|/usr/local/GNUstep/Applications/WPrefs.app|${EPREFIX}/usr/bin/|g;" "$file" || die
+ sed -i -e "s|/usr/local/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
+ sed -i -e "s|/opt/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
+ fi
+ done
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local -a myeconfargs=(
+ # image format types
+ $(use_enable gif)
+ $(use_enable imagemagick magick)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable tiff)
+ $(use_enable webp)
+ $(use_enable xpm)
+
+ # optional X capabilities
+ $(use_enable modelock)
+ $(use_enable xinerama)
+ $(use_enable xrandr randr)
+ )
+
+ # NLS depends on whether LINGUAS is empty
+ if use nls; then
+ myeconfargs+=( LINGUAS="${LINGUAS:-$(cd po; x=(*.po); echo ${x[*]%.po})}" )
+ else
+ myeconfargs+=( LINGUAS= )
+ fi
+
+ econf \
+ --localedir="${EPREFIX}"/usr/share/locale \
+ --sysconfdir="${EPREFIX}"/etc/X11 \
+ --disable-static \
+ --enable-usermenu \
+ --with-{incs,libs}-from= \
+ --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
+ --with-x \
+ "${myeconfargs[@]}"
+
+ pushd ../WindowMaker-extra-0.1 &>/dev/null || die
+ econf
+}
+
+src_compile() {
+ emake
+
+ # WindowMaker Extra Package (themes and icons)
+ emake -C ../WindowMaker-extra-0.1
+}
+
+src_install() {
+ default
+
+ # WindowMaker Extra
+ emake -C ../WindowMaker-extra-0.1 DESTDIR="${D}" install
+ newdoc ../WindowMaker-extra-0.1/README README.extra
+
+ # create wmaker session shell script
+ echo "#!/usr/bin/env bash" > wmaker
+ echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/wmaker.desktop
+ make_desktop_entry /usr/bin/wmaker
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/x11-wm/windowmaker/windowmaker-9999.ebuild b/x11-wm/windowmaker/windowmaker-9999.ebuild
index 9fabfa3d5f0b..5cc89fa45b5b 100644
--- a/x11-wm/windowmaker/windowmaker-9999.ebuild
+++ b/x11-wm/windowmaker/windowmaker-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop eutils git-r3
+inherit autotools desktop git-r3
DESCRIPTION="The fast and light GNUstep window manager"
HOMEPAGE="https://www.windowmaker.org/"
@@ -24,15 +24,16 @@ DEPEND="media-libs/fontconfig
gif? ( >=media-libs/giflib-4.1.0-r3 )
imagemagick? ( >=media-gfx/imagemagick-7:0= )
jpeg? ( virtual/jpeg:0= )
+ nls? ( virtual/libintl )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0 )
webp? ( media-libs/libwebp )
xinerama? ( x11-libs/libXinerama )
xrandr? ( x11-libs/libXrandr )"
-RDEPEND="${DEPEND}
- nls? ( >=sys-devel/gettext-0.10.39 )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
-DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL INSTALL-WMAKER FAQ
+DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL-WMAKER FAQ
NEWS README README.definable-cursor README.i18n TODO )
src_unpack() {
@@ -49,38 +50,48 @@ src_prepare() {
sed -i -e "s|/usr/local/GNUstep/Applications/WPrefs.app|${EPREFIX}/usr/bin/|g;" "$file" || die
sed -i -e "s|/usr/local/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
sed -i -e "s|/opt/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
- fi;
- done;
+ fi
+ done
default
eautoreconf
}
src_configure() {
- local myconf
-
- # image format types
- myconf="$(use_enable imagemagick magick) $(use_enable jpeg) $(use_enable gif) $(use_enable png) $(use_enable tiff) $(use_enable webp) $(use_enable xpm)"
-
- # non required X capabilities
- myconf="${myconf} $(use_enable modelock) $(use_enable xrandr randr) $(use_enable xinerama)"
-
+ local -a myeconfargs=(
+ # image format types
+ $(use_enable gif)
+ $(use_enable imagemagick magick)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable tiff)
+ $(use_enable webp)
+ $(use_enable xpm)
+
+ # optional X capabilities
+ $(use_enable modelock)
+ $(use_enable xinerama)
+ $(use_enable xrandr randr)
+ )
+
+ # NLS depends on whether LINGUAS is empty
if use nls; then
- [[ -z $LINGUAS ]] && export LINGUAS="$(ls po/*.po | sed 's:po/\(.*\)\.po$:\1:' | xargs)"
+ myeconfargs+=( LINGUAS="${LINGUAS:-$(cd po; x=(*.po); echo ${x[*]%.po})}" )
else
- myconf="${myconf} --disable-locale"
+ myeconfargs+=( LINGUAS= )
fi
- # default settings with $myconf appended
econf \
+ --localedir="${EPREFIX}"/usr/share/locale \
--sysconfdir="${EPREFIX}"/etc/X11 \
- --with-x \
+ --disable-static \
--enable-usermenu \
+ --with-{incs,libs}-from= \
--with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
- --localedir="${EPREFIX}"/usr/share/locale \
- ${myconf}
+ --with-x \
+ "${myeconfargs[@]}"
- pushd ../WindowMaker-extra-0.1 || die
+ pushd ../WindowMaker-extra-0.1 &>/dev/null || die
econf
}
@@ -88,18 +99,15 @@ src_compile() {
emake
# WindowMaker Extra Package (themes and icons)
- pushd ../WindowMaker-extra-0.1 || die
- emake
+ emake -C ../WindowMaker-extra-0.1
}
src_install() {
default
# WindowMaker Extra
- pushd ../WindowMaker-extra-0.1 || die
- emake DESTDIR="${D}" install
-
- newdoc README README.extra
+ emake -C ../WindowMaker-extra-0.1 DESTDIR="${D}" install
+ newdoc ../WindowMaker-extra-0.1/README README.extra
# create wmaker session shell script
echo "#!/usr/bin/env bash" > wmaker
@@ -110,4 +118,6 @@ src_install() {
insinto /usr/share/xsessions
doins "${FILESDIR}"/wmaker.desktop
make_desktop_entry /usr/bin/wmaker
+
+ find "${ED}" -type f -name '*.la' -delete || die
}