summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-01-13 12:19:52 -0500
committerMike Frysinger <vapier@gentoo.org>2021-01-13 12:19:52 -0500
commit934210d45b546749377461a29fc73dddc600b93d (patch)
treeca4e6881b39d7139354aa5c9d9310e98d6a58dae
parentdev-vcs/repo: mark 2.8 stable (diff)
downloadgentoo-934210d45b546749377461a29fc73dddc600b93d.tar.gz
gentoo-934210d45b546749377461a29fc73dddc600b93d.tar.bz2
gentoo-934210d45b546749377461a29fc73dddc600b93d.zip
dev-vcs/repo: version bump to 2.11
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.11.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index e0d2e59c82e4..b3603feb71f3 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,2 +1,3 @@
+DIST repo-2.11 39791 BLAKE2B 535de238d934eb2717af7bddd960c158501a56dd400ae02f3665e30c34bd68a1973de4c84e2ea76f48aa027249dfd4270153f1a7d4c4a2d5d883b580f02664e9 SHA512 1889ee9c782a6dc90b782c8ca9c5411b97c4495e0d27add62b9661a5961a782096037e081e984c965e44d33459e8fe4428528b5ebfff9fe356ce401cb610480a
DIST repo-2.5 38761 BLAKE2B 26d002bb7e5a24dc958bb4e0653c2cc260b2766d81fd55edf9a0373542365ed89a224805293383e2c16d8fc331038b265d3b2aca3a9a637d893f4a9c8221ce76 SHA512 36e515241fd9705c63beaf662309dc2ab6406552ba845fe020c878ac82e7eb7e1cd73924a076cf5fe4800ea70919bb5ad5d2d43566d5b0a559f81a45f9a58fe8
DIST repo-2.8 39134 BLAKE2B af52a2c06e09de83100cb297d585f89bcbe85d6e9e5c358024a371ee4d47c59992745d1088b164fc670cdd9db7394a5f3521967e3eb80840c53993af8b0172b1 SHA512 6d577fce34eb298035a7b98c24fc21521c8c9efbdf02abc37af8a54552893ecf8cdce2db5efbc5398d7f99226408f6cc9ce2f81c2961d9d5dd21fb0264194431
diff --git a/dev-vcs/repo/repo-2.11.ebuild b/dev-vcs/repo/repo-2.11.ebuild
new file mode 100644
index 000000000000..71f6820e3670
--- /dev/null
+++ b/dev-vcs/repo/repo-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}