summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-05-19 17:50:02 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-05-19 17:50:02 +0000
commit91ba8d2e66871815a7c38d15c5bf59cc46705363 (patch)
tree32569ec22e97f30ce6f8516db149f32f362d5611
parent2021-05-19 17:35:15 UTC (diff)
parentdev-python/pyicu: remove old (diff)
downloadgentoo-91ba8d2e66871815a7c38d15c5bf59cc46705363.tar.gz
gentoo-91ba8d2e66871815a7c38d15c5bf59cc46705363.tar.bz2
gentoo-91ba8d2e66871815a7c38d15c5bf59cc46705363.zip
Merge updates from master
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild30
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild29
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild30
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2019-r2.ebuild30
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2020.ebuild28
-rw-r--r--dev-python/pyicu/Manifest2
-rw-r--r--dev-python/pyicu/pyicu-2.6.ebuild26
-rw-r--r--dev-python/pyicu/pyicu-2.7.2.ebuild28
-rw-r--r--net-libs/nodejs/Manifest2
-rw-r--r--net-libs/nodejs/nodejs-14.17.0.ebuild (renamed from net-libs/nodejs/nodejs-14.16.1-r1.ebuild)0
-rw-r--r--net-libs/nodejs/nodejs-16.2.0.ebuild234
-rw-r--r--sys-libs/db/db-4.5.20_p2-r6.ebuild2
-rw-r--r--sys-libs/db/db-4.6.21_p4-r5.ebuild2
-rw-r--r--sys-libs/db/db-4.7.25_p4-r5.ebuild2
-rw-r--r--sys-libs/db/db-4.8.30-r6.ebuild2
-rw-r--r--sys-libs/db/db-5.3.28-r8.ebuild2
16 files changed, 305 insertions, 144 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild
index eeeeaf2c0388..d9b01134a7c3 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -67,9 +67,18 @@ S="${WORKDIR}"/${MYP}
FSFGCC=gcc-${TOOLCHAIN_GCC_PV}
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -91,23 +100,10 @@ pkg_setup() {
GNATBIND="${path}/${GNATBIND}"
CXX="${path}/${CXX}"
fi
-}
-
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm ../${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
cd ..
sed -i \
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
index bff11256c1f6..bdbf1fafb6e7 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -51,9 +51,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -73,23 +82,11 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
index bb4782b8d4be..87b416731cdb 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,9 +50,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -72,23 +81,10 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2019-r2.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2019-r2.ebuild
index 397ec960074f..173c640d4b94 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2019-r2.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2019-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -52,9 +52,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -74,23 +83,10 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
index 1e59a7091c9f..10317ef96f88 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
@@ -52,9 +52,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -74,23 +83,10 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index a92a6ff011f6..0f4ae7490d3a 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1,3 +1 @@
-DIST PyICU-2.6.tar.gz 233826 BLAKE2B 318b87b878f8d49f47f48780567751671f5f88902c4cae9a243a81300b002ca6ea2336aee38bfc76a3037326f15f197fd71819173b678c68094d16f8db51864e SHA512 ab4c167cbeb80a23904476e51a3c16aa4721e26840b1d4c2f44b5a610e5467a6880c45f27636efb9e44e8e4302a095d437f4868409103270d79ecd56a3d90c9c
-DIST pyicu-v2.7.2.tar.bz2 238645 BLAKE2B cca24a2cda18e943ac00a50b9a28342845af156b66bffcae2ec915e8e5d97577e1c5975b6711051558223278ccd7ad33782d02e759427ace4ce609fcad1c7ba6 SHA512 ece8a7a7e5162de8a2ad7a1ae1310ca4f32c6d27695942580a9a4cd1755a94c4230fe9f9e1c9a6b5a7d4a712b2ad570660e89316f437a7af502521e91137960e
DIST pyicu-v2.7.3.tar.bz2 239703 BLAKE2B ce575c313d0e24838f87d270afce70e8b702753ec41d188bcdd60492f97ea276bca194c1bfd6224de17eaf84455509079e007b81e58c09ad0f48340b231e8671 SHA512 ff3bfdc5f24f259dc470f44c65707f7c29bff5c56dc85be7d4551269e5b6cc6e8f3a6953c5faae63aa9eb62e55f6ac75b32a1524f80ce2a7661de56ee1a5bf99
diff --git a/dev-python/pyicu/pyicu-2.6.ebuild b/dev-python/pyicu/pyicu-2.6.ebuild
deleted file mode 100644
index 8b50556d8dcd..000000000000
--- a/dev-python/pyicu/pyicu-2.6.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-MY_PN=PyICU
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Python bindings for dev-libs/icu"
-HOMEPAGE="https://github.com/ovalhub/pyicu"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-libs/icu:="
-DEPEND="${RDEPEND}"
-
-DOCS=( CHANGES CREDITS README.md )
-
-distutils_enable_tests pytest
diff --git a/dev-python/pyicu/pyicu-2.7.2.ebuild b/dev-python/pyicu/pyicu-2.7.2.ebuild
deleted file mode 100644
index 98aecea4d8c8..000000000000
--- a/dev-python/pyicu/pyicu-2.7.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-MY_P=${P/-/-v}
-DESCRIPTION="Python bindings for dev-libs/icu"
-HOMEPAGE="
- https://gitlab.pyicu.org/main/pyicu/
- https://pypi.org/project/PyICU/"
-SRC_URI="
- https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-libs/icu:="
-DEPEND="${RDEPEND}"
-
-DOCS=( CHANGES CREDITS README.md )
-
-distutils_enable_tests pytest
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index aec0f6fda875..e566846951cc 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -1,3 +1,5 @@
DIST node-v12.22.1.tar.xz 23650180 BLAKE2B 90b0a8ab3842483fea0c776e0245e63539a986c18f55abd8c7cd22ec399ccde22fa5b008d3e07c0f07713b5a45a1ee2a0bc370c04408800db2ee59cd92fcb5be SHA512 eaead633611bda04ab9be200aeddf3b4004b8104e9c6af246023b8008003dd3a7103e1508ea690443e59c6591521b04a2d71c7344343f2a20d1c935ef51c66a0
DIST node-v14.16.1.tar.xz 33297064 BLAKE2B 0927434c63cd248e90a4002b50c7a0fd68a5527a4cd7424b451840ddf0c403ba452979b195e598cc3b323e24233248a74a1274519ce8cd3a2f4e71dc7a8f3dcb SHA512 d4f5fbab69592ae555613b2186090b85a458d2211b6035989aee2617bfd0f6768ca767ec45ce12756a9c452d00af7237edee3b1ae526049e9fcd01f8f67680c0
+DIST node-v14.17.0.tar.xz 33484212 BLAKE2B 0ad045b7e0b96f564f42cef703338fece2167cb8bfe32840b765b137e01491a43a9c31ce290a3379ffa834ddfe4e2e1f42f95d4d0014240151b06313e0339383 SHA512 7a7683523904580462077c8bf3ee9640f1b674c7df55655049ca50ca3cfdb2973b13088f2b65e4eccf4df2641cd9c86c9716bcd160a5d5863a969cb1e88de093
DIST node-v16.1.0.tar.xz 33770472 BLAKE2B 2b7cf5f07dbf72eb25018cd046ce15cf6c5a444225e34d425614c19e69888b4f5c9488b079fed12e6fe52cb8dfdee20cf61c4df5a39f53e60b95c4da445f2091 SHA512 dc12078203940e7b280198ae15f51f68aaefcf8cab71a9f988952e67045e4b16dc48ec471abcc497bd15b0b426c06678e376b53762349d6568b48d52888cc2d5
+DIST node-v16.2.0.tar.xz 33786196 BLAKE2B be2784332cbbfa58cf24f830cd88117378c51b413167b6443ed90176bb0bd429005a99b5148f5d8315fd751dd34d83192c2a09753f84faf3d91080fa6e5eab44 SHA512 bf86427d29679f47d0596c532e84790ceea1784b4a06fc2a63969a1bdbf853b06d14f264c416f357c8ef097189566a44f962a678b5026bb4f781557f7b2bd363
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.17.0.ebuild
index 6f3e887f73d1..6f3e887f73d1 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.17.0.ebuild
diff --git a/net-libs/nodejs/nodejs-16.2.0.ebuild b/net-libs/nodejs/nodejs-16.2.0.ebuild
new file mode 100644
index 000000000000..95fb8c3f56fe
--- /dev/null
+++ b/net-libs/nodejs/nodejs-16.2.0.ebuild
@@ -0,0 +1,234 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nodejs/node"
+ SLOT="0"
+else
+ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+ SLOT="0/$(ver_cut 1)"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+ S="${WORKDIR}/node-v${PV}"
+fi
+
+IUSE="cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax_kernel +snapshot +ssl system-icu +system-ssl systemtap test"
+REQUIRED_USE="inspector? ( icu ssl )
+ npm? ( ssl )
+ system-icu? ( icu )
+ system-ssl? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-arch/brotli-1.0.9
+ >=dev-libs/libuv-1.40.0:=
+ >=net-dns/c-ares-1.17.0
+ >=net-libs/nghttp2-1.41.0
+ sys-libs/zlib
+ system-icu? ( >=dev-libs/icu-67:= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )"
+BDEPEND="${PYTHON_DEPS}
+ sys-apps/coreutils
+ virtual/pkgconfig
+ systemtap? ( dev-util/systemtap )
+ test? ( net-misc/curl )
+ pax_kernel? ( sys-apps/elfix )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch
+ "${FILESDIR}"/${PN}-12.22.1-uvwasi_shared_libuv.patch
+ "${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-16.1.0-ppc64-segfault.patch #785751, drop after it stops applying
+)
+
+pkg_pretend() {
+ (use x86 && ! use cpu_flags_x86_sse2) && \
+ die "Your CPU doesn't support the required SSE2 instruction."
+
+ if [[ ${MERGE_TYPE} != "binary" ]]; then
+ if use lto; then
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ tc-export AR CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ sed -i -e "/'-O3'/d" common.gypi node.gypi || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ # We need to disable mprotect on two files when it builds Bug 694100.
+ use pax_kernel && PATCHES+=( "${FILESDIR}"/${PN}-13.8.0-paxmarking.patch )
+
+ # All this test does is check if the npm CLI produces warnings of any sort,
+ # failing if it does. Overkill, much? Especially given one possible warning
+ # is that there is a newer version of npm available upstream (yes, it does
+ # use the network if available), thus making it a real possibility for this
+ # test to begin failing one day even though it was fine before.
+ rm -f test/parallel/test-release-npm.js
+
+ default
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ # LTO compiler flags are handled by configure.py itself
+ filter-flags '-flto*'
+
+ local myconf=(
+ --shared-brotli
+ --shared-cares
+ --shared-libuv
+ --shared-nghttp2
+ --shared-zlib
+ )
+ use debug && myconf+=( --debug )
+ use lto && myconf+=( --enable-lto )
+ if use system-icu; then
+ myconf+=( --with-intl=system-icu )
+ elif use icu; then
+ myconf+=( --with-intl=full-icu )
+ else
+ myconf+=( --with-intl=none )
+ fi
+ use inspector || myconf+=( --without-inspector )
+ use npm || myconf+=( --without-npm )
+ use snapshot || myconf+=( --without-node-snapshot )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
+
+ local myarch=""
+ case ${ABI} in
+ amd64) myarch="x64";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ ppc64) myarch="ppc64";;
+ x32) myarch="x32";;
+ x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${EPYTHON}" configure.py \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ $(use_with systemtap dtrace) \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ default
+
+ pax-mark -m "${ED}"/usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ docinto html
+ dodoc -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ keepdir /etc/npm
+
+ # Install bash completion for `npm`
+ local tmp_npm_completion_file="$(TMPDIR="${T}" mktemp -t npm.XXXXXXXXXX)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm -f "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile}
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man}
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+
+ mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
+}
+
+src_test() {
+ # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
+ if has usersandbox ${FEATURES}; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
+ out/${BUILDTYPE}/cctest || die
+ "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
+}
diff --git a/sys-libs/db/db-4.5.20_p2-r6.ebuild b/sys-libs/db/db-4.5.20_p2-r6.ebuild
index 5d76d20b0084..04445720d1c0 100644
--- a/sys-libs/db/db-4.5.20_p2-r6.ebuild
+++ b/sys-libs/db/db-4.5.20_p2-r6.ebuild
@@ -27,7 +27,7 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="tcl java doc cxx"
RESTRICT="!test? ( test )"
diff --git a/sys-libs/db/db-4.6.21_p4-r5.ebuild b/sys-libs/db/db-4.6.21_p4-r5.ebuild
index d69c3c32c2a1..6d51c0e1eb95 100644
--- a/sys-libs/db/db-4.6.21_p4-r5.ebuild
+++ b/sys-libs/db/db-4.6.21_p4-r5.ebuild
@@ -27,7 +27,7 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="tcl java doc cxx"
RESTRICT="!test? ( test )"
diff --git a/sys-libs/db/db-4.7.25_p4-r5.ebuild b/sys-libs/db/db-4.7.25_p4-r5.ebuild
index a4d8f87a8e48..d7c527220db6 100644
--- a/sys-libs/db/db-4.7.25_p4-r5.ebuild
+++ b/sys-libs/db/db-4.7.25_p4-r5.ebuild
@@ -29,7 +29,7 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="doc java cxx tcl test"
# the entire testsuite needs the TCL functionality
diff --git a/sys-libs/db/db-4.8.30-r6.ebuild b/sys-libs/db/db-4.8.30-r6.ebuild
index 80ec7706ca17..0b56bb919ef3 100644
--- a/sys-libs/db/db-4.8.30-r6.ebuild
+++ b/sys-libs/db/db-4.8.30-r6.ebuild
@@ -29,7 +29,7 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="doc java cxx tcl test"
REQUIRED_USE="test? ( tcl )"
diff --git a/sys-libs/db/db-5.3.28-r8.ebuild b/sys-libs/db/db-5.3.28-r8.ebuild
index 6a25488eddc3..7da5133f3c77 100644
--- a/sys-libs/db/db-5.3.28-r8.ebuild
+++ b/sys-libs/db/db-5.3.28-r8.ebuild
@@ -29,7 +29,7 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="doc java cxx tcl test"
REQUIRED_USE="test? ( tcl )"