summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-04 22:09:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-04 22:09:18 +0100
commit844c0b192a46048a01b7e9e17953e2534df0d229 (patch)
treeda4e943fdc1ff94465e36cb15a7d792c2cc5a684
parentdev-libs/nettle: Bump to version 3.7 (diff)
downloadgentoo-844c0b192a46048a01b7e9e17953e2534df0d229.tar.gz
gentoo-844c0b192a46048a01b7e9e17953e2534df0d229.tar.bz2
gentoo-844c0b192a46048a01b7e9e17953e2534df0d229.zip
dev-libs/nettle: Removed old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/nettle/Manifest2
-rw-r--r--dev-libs/nettle/files/nettle-3.4.1-build.patch53
-rw-r--r--dev-libs/nettle/nettle-3.4.1.ebuild67
-rw-r--r--dev-libs/nettle/nettle-3.5.1-r1.ebuild63
4 files changed, 0 insertions, 185 deletions
diff --git a/dev-libs/nettle/Manifest b/dev-libs/nettle/Manifest
index 0de3dc7f97c9..7b7ca7e26f9c 100644
--- a/dev-libs/nettle/Manifest
+++ b/dev-libs/nettle/Manifest
@@ -1,4 +1,2 @@
-DIST nettle-3.4.1.tar.gz 1947053 BLAKE2B 354318c46c28aeaaca611abe70298024ec12ff70aed53c741e43c1b5373361e5cffb03df7b8e86ef103a3b7770b2b4fe39fbca00b128f2b7ec810b3a4d9fd0fd SHA512 26aefbbe9927e90e28f271e56d2ba876611831222d0e1e1a58bdb75bbd50934fcd84418a4fe47b845f557e60a9786a72a4de2676c930447b104f2256aca7a54f
-DIST nettle-3.5.1.tar.gz 1989593 BLAKE2B 40e527a4cc541674acc39072f2ebbab4b6ed1b043687d88c776ce9c58374538b111d282e0eea5424059260b0876c5cf01f97470c850e082c167b05a57e6c591a SHA512 f738121b9091cbe79435fb5d46b45cf6f10912320c233829356908127bab1cac6946ca56e022a832380c44f2c10f21d2feef64cb0f4f41e3da4a681dc0131784
DIST nettle-3.6.tar.gz 2288173 BLAKE2B 45e08832e9c337f10d958956545c77f521b747b8abca56ce40c755adf352bdc2a79584b1e1c0e50f5ede0ac54794aabd6883601c53593b965aada744502789db SHA512 2471af875e51327af61af8bda53cd9c3adc27b6e32592a4b5b10b3ec60999ebf771ab9c54c747b0bade4b3b5a717e77fdbdb53699dd9e8a9ed4eee07f46aed51
DIST nettle-3.7.tar.gz 2375067 BLAKE2B 1e8a77db9b7e62dee9a01e3c3b476e206f36cc7235153b0a1a762276650c61d7c4c3be73b2ecae9313313e416e3c7a2bd999a3505c41b26e806f9b3eb486550f SHA512 be32eff0ea3c83abb8b6670d049a8ce21ea9c7cac3e1a5d41ae003d5160e2683572c7dd8930b869ac1db0b89f9423605e0a8ec0cff074c63e2a60c71996ef66c
diff --git a/dev-libs/nettle/files/nettle-3.4.1-build.patch b/dev-libs/nettle/files/nettle-3.4.1-build.patch
deleted file mode 100644
index 4351dfeb5bcb..000000000000
--- a/dev-libs/nettle/files/nettle-3.4.1-build.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From f5a3a224bf00bef5669366d2ae23c2b2b13b8016 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Niels=20M=C3=B6ller?= <nisse@lysator.liu.se>
-Date: Wed, 26 Dec 2018 11:04:31 +0100
-Subject: [PATCH] Fix accidental use of C99 for loop.
-
-* rsa-sign-tr.c (sec_equal): Fix accidental use of C99 for loop.
-Reported by Andreas Gustafsson.
-* testsuite/rsa-sec-decrypt-test.c (test_main): Likewise.
----
- ChangeLog | 6 ++++++
- rsa-sign-tr.c | 3 ++-
- testsuite/rsa-sec-decrypt-test.c | 3 ++-
- 3 files changed, 10 insertions(+), 2 deletions(-)
-
-diff --git a/rsa-sign-tr.c b/rsa-sign-tr.c
-index 59c9bd07..f824c4ca 100644
---- a/rsa-sign-tr.c
-+++ b/rsa-sign-tr.c
-@@ -239,8 +239,9 @@ static int
- sec_equal(const mp_limb_t *a, const mp_limb_t *b, size_t limbs)
- {
- volatile mp_limb_t z = 0;
-+ size_t i;
-
-- for (size_t i = 0; i < limbs; i++)
-+ for (i = 0; i < limbs; i++)
- {
- z |= (a[i] ^ b[i]);
- }
-diff --git a/testsuite/rsa-sec-decrypt-test.c b/testsuite/rsa-sec-decrypt-test.c
-index 64f0b13c..fb0ed3a1 100644
---- a/testsuite/rsa-sec-decrypt-test.c
-+++ b/testsuite/rsa-sec-decrypt-test.c
-@@ -68,6 +68,7 @@ test_main(void)
- unsigned n_size = 1024;
- mpz_t gibberish;
- mpz_t garbage;
-+ size_t size;
-
- rsa_private_key_init(&key);
- rsa_public_key_init(&pub);
-@@ -78,7 +79,7 @@ test_main(void)
-
- memset(verifybad, 'A', PAYLOAD_SIZE);
-
-- for (size_t size = 1; size < 51; size++)
-+ for (size = 1; size < 51; size++)
- {
- ASSERT (rsa_generate_keypair(&pub, &key, &random_ctx,
- (nettle_random_func *) knuth_lfib_random,
---
-2.18.1
-
diff --git a/dev-libs/nettle/nettle-3.4.1.ebuild b/dev-libs/nettle/nettle-3.4.1.ebuild
deleted file mode 100644
index bb7dcdf6c2ad..000000000000
--- a/dev-libs/nettle/nettle-3.4.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-build multilib-minimal multilib toolchain-funcs
-
-DESCRIPTION="Low-level cryptographic library"
-HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-3 LGPL-2.1 )"
-SLOT="0/6.2" # subslot = libnettle soname version, .2 as broke ABI bug#601512 then fixed
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes"
-RESTRICT="!test? ( test )"
-
-DEPEND="gmp? ( >=dev-libs/gmp-6.0:0=[static-libs?,${MULTILIB_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/nettle/nettle-stdint.h
- /usr/include/nettle/version.h
-)
-
-DOCS=()
-HTML_DOCS=()
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
-
-pkg_setup() {
- use doc && DOCS+=(
- nettle.pdf
- )
- use doc && HTML_DOCS+=(
- nettle.html
- )
-}
-
-src_prepare() {
- default
-
- sed -e '/CFLAGS=/s: -ggdb3::' \
- -e 's/solaris\*)/sunldsolaris*)/' \
- -i configure.ac || die
-
- # conditionally build tests and examples required by tests
- use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- # --disable-openssl bug #427526
- ECONF_SOURCE="${S}" econf \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-openssl \
- --disable-fat \
- $(use_enable gmp public-key) \
- $(use_enable static-libs static) \
- $(tc-is-static-only && echo --disable-shared) \
- $(use_enable doc documentation) \
- $(use_enable neon arm-neon) \
- $(use_enable cpu_flags_x86_aes x86-aesni)
-}
diff --git a/dev-libs/nettle/nettle-3.5.1-r1.ebuild b/dev-libs/nettle/nettle-3.5.1-r1.ebuild
deleted file mode 100644
index acb10fbbe9af..000000000000
--- a/dev-libs/nettle/nettle-3.5.1-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-build multilib-minimal multilib toolchain-funcs
-
-DESCRIPTION="Low-level cryptographic library"
-HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-3 LGPL-2.1 )"
-SLOT="0/7" # subslot = libnettle soname version
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+asm doc +gmp static-libs test cpu_flags_x86_aes cpu_flags_arm_neon cpu_flags_x86_sha"
-RESTRICT="!test? ( test )"
-
-DEPEND="gmp? ( >=dev-libs/gmp-6.0:0=[static-libs?,${MULTILIB_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/nettle/version.h
-)
-
-DOCS=()
-HTML_DOCS=()
-
-pkg_setup() {
- use doc && DOCS+=(
- nettle.pdf
- )
- use doc && HTML_DOCS+=(
- nettle.html
- )
-}
-
-src_prepare() {
- default
-
- # I do not see in config.sub reference to sunldsolaris.
- # if someone complains readd
- # -e 's/solaris\*)/sunldsolaris*)/' \
- sed -e '/CFLAGS=/s: -ggdb3::' \
- -i configure.ac || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- # --disable-openssl bug #427526
- ECONF_SOURCE="${S}" econf \
- $(tc-is-static-only && echo --disable-shared) \
- $(use_enable cpu_flags_x86_aes x86-aesni) \
- $(use_enable cpu_flags_x86_sha x86-sha-ni) \
- $(use_enable asm assembler) \
- $(use_enable doc documentation) \
- $(use_enable gmp public-key) \
- $(use_enable cpu_flags_arm_neon arm-neon) \
- $(use_enable static-libs static) \
- --disable-fat \
- --disable-openssl \
- --libdir="${EPREFIX}"/usr/$(get_libdir)
-}