summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-06-20 19:34:58 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-06-20 19:34:58 +0000
commit7bc9d06603fad2dde69156ac9ecb5d0d4f019a34 (patch)
tree19ff1078f2770e741190836291da0e97c3ecf944
parent2021-06-20 19:20:05 UTC (diff)
parentgui-libs/wpebackend-fdo: Version bump to 1.10.1 (diff)
downloadgentoo-7bc9d06603fad2dde69156ac9ecb5d0d4f019a34.tar.gz
gentoo-7bc9d06603fad2dde69156ac9ecb5d0d4f019a34.tar.bz2
gentoo-7bc9d06603fad2dde69156ac9ecb5d0d4f019a34.zip
Merge updates from master
-rw-r--r--gnome-extra/office-runner/Manifest1
-rw-r--r--gnome-extra/office-runner/office-runner-1.0.3.ebuild43
-rw-r--r--gui-libs/libwpe/Manifest1
-rw-r--r--gui-libs/libwpe/libwpe-1.10.1.ebuild31
-rw-r--r--gui-libs/wpebackend-fdo/Manifest1
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild35
6 files changed, 112 insertions, 0 deletions
diff --git a/gnome-extra/office-runner/Manifest b/gnome-extra/office-runner/Manifest
index 5c76ba80c964..e7a7468d567c 100644
--- a/gnome-extra/office-runner/Manifest
+++ b/gnome-extra/office-runner/Manifest
@@ -1 +1,2 @@
DIST office-runner-1.0.2.tar.xz 562660 BLAKE2B ad69a4340025b58d45f954524c9807831c98a4d81901276bfa3e8f76adb3a5bd1fcf0b50908e00c19888d82b6c48602228a42b84b008f2b7b95210868c8a90ed SHA512 a840af75f014147d30e950a4bc8628c97a79c8161eab3d0f658f5e4f5200df5baaa761d4ea27dc1bc70c6a467fc2536ac0aa473c338ffcbfc48689ba1ec13177
+DIST office-runner-1.0.3.tar.bz2 957912 BLAKE2B 064dac6f511d9c1019a2da073276509d6ccf9bce19ae1778335f5dde3fe1f236a76430dd3fb989f06e64d0214b5125769b0a3531cba44460ae15b0ad8b87f07d SHA512 475aac701cd4faec378e4f7673658489e9d4cebea499b24fb2baa6cc981ed1dab435769ce75ed82ffa9d28bf29e96d2911820a29abaa5aafed7d38af80636584
diff --git a/gnome-extra/office-runner/office-runner-1.0.3.ebuild b/gnome-extra/office-runner/office-runner-1.0.3.ebuild
new file mode 100644
index 000000000000..62c820e0058e
--- /dev/null
+++ b/gnome-extra/office-runner/office-runner-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME2_EAUTORECONF="yes"
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Lighthearted tool to temporarily inhibit GNOME's suspend on lid close behavior"
+HOMEPAGE="https://www.hadess.net/search/label/office-runner"
+SRC_URI="https://gitlab.gnome.org/GNOME/office-runner/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ >=gnome-base/gnome-settings-daemon-3.0
+ >=x11-libs/gtk+-3.8:3
+"
+# requires systemd's org.freedesktop.login1 dbus service
+RDEPEND="${DEPEND}
+ >=sys-apps/systemd-190
+"
+BDEPEND="
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOC_CONTENTS="${PN} inhibits suspend on lid close only for 10 minutes"
+
+src_install() {
+ gnome2_src_install
+ mv "${ED}"/usr/share/{appdata,metainfo}/ || die
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/gui-libs/libwpe/Manifest b/gui-libs/libwpe/Manifest
index 48f9dd52c48b..b6220a9b60d3 100644
--- a/gui-libs/libwpe/Manifest
+++ b/gui-libs/libwpe/Manifest
@@ -1 +1,2 @@
DIST libwpe-1.10.0.tar.xz 52004 BLAKE2B 3088cb103b99ab626a74c37910d91fe8abdb07d14d0846bd202716fa1a7d8087e4095e65977e25d9a6f2b97bdfcef664f3872abd8de447ffe3e841a613ebc116 SHA512 b5634dd71cca70eb960f3c045ad109346ab6ce6b01aa8c8bc8f326d232eb16ac1600757896a4b99720af3c77084351ea4f69e2e2c81b9c32cc8bc12a5c66ba3c
+DIST libwpe-1.10.1.tar.xz 51984 BLAKE2B 8afb81e85d134a525a9f7cf0156632ea72a72ab94fcb06c411a11d5304b510cb711a1f2f948cb448bf1ac54c4734cce7a2eaa1ca34c2207c6155d4ab5c350139 SHA512 be1f366ae0d23326ceaab0fe4cdbaea4b50ab822c0e9e7315120fa665113d5eea43f5a23c8e5068f041322d3139cd4de75cfb0f03613cb40586fece1467afbca
diff --git a/gui-libs/libwpe/libwpe-1.10.1.ebuild b/gui-libs/libwpe/libwpe-1.10.1.ebuild
new file mode 100644
index 000000000000..812b9f6d8d15
--- /dev/null
+++ b/gui-libs/libwpe/libwpe-1.10.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/mesa[egl]
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild-docs=false # hotdoc not packaged
+ )
+ meson_src_configure
+}
diff --git a/gui-libs/wpebackend-fdo/Manifest b/gui-libs/wpebackend-fdo/Manifest
index dcdce50c8c91..151cb2108048 100644
--- a/gui-libs/wpebackend-fdo/Manifest
+++ b/gui-libs/wpebackend-fdo/Manifest
@@ -1 +1,2 @@
+DIST wpebackend-fdo-1.10.0.tar.xz 38484 BLAKE2B 6b2cb4d4b1321245dee13d33ad58ee8d31aa4f5a25cfc2cde2bc2a67db15e9835de59f1b0550b7a205502b2e201398cf8032a0f235ae01f74e4568874cb47620 SHA512 50e65d1560b943ec85b80449c838b61d7ab3baf96844542cce06028bd934b1145319f3fa07a3dc629d2a7896b95ab388edbe853b7e377cf0ff02fb66291e1ce0
DIST wpebackend-fdo-1.8.4.tar.xz 43276 BLAKE2B 03973e94ea19db6f9a3e8e9855d970d6b2bdc546a5a69e5e80d07aec3c2aa48739653c596138c798f766816fbc4b1df4da0a5ed5bf42969812a87b4670db502e SHA512 a92fea7e16b48c89789ffa35427f716900071d4e65d7f06acc94d28f49688f3ff344623cc4801d4f5b7ebbd740a8349cce064467826c41a7983cc90811805a64
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild
new file mode 100644
index 000000000000..03c027d50901
--- /dev/null
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="WPE backend designed for Linux desktop systems"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libepoxy[egl]
+ dev-libs/glib:2
+ >=dev-libs/wayland-1.10
+ >=gui-libs/libwpe-1.6:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_docs=false # hotdoc not packaged
+ )
+
+ meson_src_configure
+}