summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2025-01-26 16:58:39 +0100
committerPacho Ramos <pacho@gentoo.org>2025-01-26 17:03:23 +0100
commit52f72068530b4e3161bee555538a30ef5db133a7 (patch)
treef20100b45b11937d3a23a8c2fc577ea7da49fbe3
parentgnome-base/gnome-control-center: drop 45.3-r1, 45.4-r1, 46.2-r1 (diff)
downloadgentoo-52f72068530b4e3161bee555538a30ef5db133a7.tar.gz
gentoo-52f72068530b4e3161bee555538a30ef5db133a7.tar.bz2
gentoo-52f72068530b4e3161bee555538a30ef5db133a7.zip
dev-libs/gjs: add 1.82.1
Closes: https://bugs.gentoo.org/947698 Closes: https://github.com/gentoo/gentoo/pull/39075 Closes: https://bugs.gentoo.org/908251 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.82.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 53d8c8121dd8..bc42bce3702b 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,2 +1,3 @@
DIST gjs-1.78.5.tar.xz 656168 BLAKE2B e1458d000998b66fda90e448ca487e591729e003c3e11a939dc474958b6de55783d41db8de5b243a329361f12acc15a8e84f4131650705becb046b68c54a24a2 SHA512 bb25e52dff53bfbde6d2329027d4ff68849740cf753da58f9bdf5a19ea7b029e2517d67978f461f16660dd1aa48b223798e9c0a24cde0ccb62060e4a0c83a02e
DIST gjs-1.80.2.tar.xz 663256 BLAKE2B d5c8dd85acc0ee1fa8da9450b1d9427da0f835b695d5c6877ea166d41751dcf4449bb00ee0068ac98abed245d6dc1d67504432db368b9fcd8d81e0f37e72e952 SHA512 cc9a9073f741ee60eff2d2ce808cca7f40e97798f9ffa9197ebc3780a8a5df6e174ba76293bf7547fc8fa7e82be6a828a633a5aa8ba27d551dec72d635b6c5bd
+DIST gjs-1.82.1.tar.xz 728920 BLAKE2B 47380451b8859494097700dd00adc03f08dd5c2d9a1734ffe32618a7a1c97e41fc9e24ea930a8077826ed017cffa0ffdd3dfcc0c471afeef58f76415aebf0f9e SHA512 2e4e1ceee784d252cb0f6a5df9c9dd9a486112af9973e184d785cb4bcb06a5844e16ce51b8a46021220f2b6ead24186eb98cc15b836492f71922e8a80669b16f
diff --git a/dev-libs/gjs/gjs-1.82.1.ebuild b/dev-libs/gjs/gjs-1.82.1.ebuild
new file mode 100644
index 000000000000..3a498338bfbb
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.82.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+IUSE="examples readline sysprof test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.71.1:=
+ dev-lang/spidermonkey:128
+ x11-libs/cairo[X,glib]
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}