summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas PARLANT <nicolas.parlant@parhuet.fr>2025-01-15 19:28:25 +0000
committerLouis Sautier <sbraz@gentoo.org>2025-01-30 14:06:27 +0100
commit4e54077cf4cdb64eb50cd3b9cb1814a61ba3d53c (patch)
treed980a6f093c5f4870d72c5f634fa0a4c50cb0ece
parentapp-admin/winbox: add 4.0_beta17, drop 4.0_beta16 (diff)
downloadgentoo-4e54077cf4cdb64eb50cd3b9cb1814a61ba3d53c.tar.gz
gentoo-4e54077cf4cdb64eb50cd3b9cb1814a61ba3d53c.tar.bz2
gentoo-4e54077cf4cdb64eb50cd3b9cb1814a61ba3d53c.zip
app-admin/supervisor: add 4.2.5_p20250125
post release as some bugs are fixed since 4.2.5 and : enable py3.13 setuptools is no longer a runtime-dep for ≥ py3.8: https://github.com/Supervisor/supervisor/commit/19c68f5 patch for setuptools QA warns exclude tests dir for install Signed-off-by: Nicolas PARLANT <nicolas.parlant@parhuet.fr> Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/files/supervisor-4.3.0-fix-qa-warnings.patch45
-rw-r--r--app-admin/supervisor/supervisor-4.2.5_p20250125.ebuild58
3 files changed, 104 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index d23b71bbe800..3112c3d47c12 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -1 +1,2 @@
DIST supervisor-4.2.5.tar.gz 466073 BLAKE2B 54b45c824a1ad2960b04ca4ca9e54337f8c4da1a13008b559103f9efb9043588e72b3ee97c41218eb9252606d717575ad2615d12136047734f83d843d0a63bfa SHA512 ea80c8c91356646deccf20735e065fd9b341f3be6d56838d333989297a912b0a59142338925b2eb08690e038f0617814e03447673701a19093aa483432ce6d41
+DIST supervisor-4.2.5_p20250125.gh.tar.gz 446525 BLAKE2B 33372d7424a8d5b500a8dcbcc25f9d2e678155f570936c9be337b443fee65243b2c632c0b429c4fd2b9133243a864cb7297f1640c5d843d6439bf1fb1c06a3c4 SHA512 53e2d798ef9663f471ed05b76dad23b96ed65c7f4b40d7ab837586dd58fda1dcb471f7cfbcdf014c6a830ddb2c7457aa6a5569a1ffe1cfa576e2f9c683149478
diff --git a/app-admin/supervisor/files/supervisor-4.3.0-fix-qa-warnings.patch b/app-admin/supervisor/files/supervisor-4.3.0-fix-qa-warnings.patch
new file mode 100644
index 000000000000..0b8769e02295
--- /dev/null
+++ b/app-admin/supervisor/files/supervisor-4.3.0-fix-qa-warnings.patch
@@ -0,0 +1,45 @@
+https://github.com/Supervisor/supervisor/issues/1560
+https://github.com/Supervisor/supervisor/pull/1675
+upstream will not merge soon as it's py3 only (find_namespace_packages)
+--- a/setup.py
++++ b/setup.py
+@@ -34,7 +34,7 @@
+ 'pytest-cov',
+ ]
+
+-from setuptools import setup, find_packages
++from setuptools import setup, find_namespace_packages
+ here = os.path.abspath(os.path.dirname(__file__))
+ try:
+ with open(os.path.join(here, 'README.rst'), 'r') as f:
+@@ -91,15 +91,19 @@
+ classifiers=CLASSIFIERS,
+ author="Chris McDonough",
+ author_email="chrism@plope.com",
+- packages=find_packages(),
++ packages=find_namespace_packages(exclude=["docs","supervisor.tests","supervisor.tests.*"]),
++ package_dir={"": "."},
++ package_data={
++ "supervisor": ["version.txt"],
++ "supervisor.ui": ["**/*"],
++ "supervisor.skel": ["*"]
++ },
+ install_requires=requires,
+ extras_require={
+ 'testing': testing_extras,
+ },
+- tests_require=tests_require,
+ include_package_data=True,
+ zip_safe=False,
+- test_suite="supervisor.tests",
+ entry_points={
+ 'console_scripts': [
+ 'supervisord = supervisor.supervisord:main',
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -2,4 +2,4 @@
+ zip_ok = false
+
+ [bdist_wheel]
+-universal = 1
++universal = 0
diff --git a/app-admin/supervisor/supervisor-4.2.5_p20250125.ebuild b/app-admin/supervisor/supervisor-4.2.5_p20250125.ebuild
new file mode 100644
index 000000000000..a2584961e9b9
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.2.5_p20250125.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+COMMIT="4bf1e57cbf292ce988dc128e0d2c8917f18da9be"
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="https://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="https://github.com/Supervisor/supervisor/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+PATCHES=(
+ # https://github.com/Supervisor/supervisor/issues/1560
+ "${FILESDIR}"/${PN}-4.3.0-fix-qa-warnings.patch
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}