summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-09-17 14:05:21 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-09-17 14:05:21 +0000
commit48c45597e063211db0e7ca9bd9265c72cd917157 (patch)
tree67621e699e9cf1d6fde93705f1e79addc9550527
parent2020-09-17 13:35:34 UTC (diff)
parentsys-auth/polkit: Bump to version 0.118 (diff)
downloadgentoo-48c45597e063211db0e7ca9bd9265c72cd917157.tar.gz
gentoo-48c45597e063211db0e7ca9bd9265c72cd917157.tar.bz2
gentoo-48c45597e063211db0e7ca9bd9265c72cd917157.zip
Merge updates from master
-rw-r--r--media-plugins/kodi-pvr-mythtv/Manifest1
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-7.1.1.ebuild36
-rw-r--r--media-plugins/kodi-vfs-sftp/Manifest1
-rw-r--r--media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild40
-rw-r--r--media-plugins/kodi-visualization-shadertoy/Manifest1
-rw-r--r--media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-2.3.0.ebuild43
-rw-r--r--sys-apps/ipmiutil/Manifest2
-rw-r--r--sys-apps/ipmiutil/files/ipmiutil-3.1.7-fix-configure.patch184
-rw-r--r--sys-apps/ipmiutil/files/ipmiutil-3.1.7-flags.patch20
-rw-r--r--sys-apps/ipmiutil/ipmiutil-3.1.7.ebuild (renamed from sys-apps/ipmiutil/ipmiutil-3.1.5-r1.ebuild)14
-rw-r--r--sys-auth/polkit/Manifest1
-rw-r--r--sys-auth/polkit/polkit-0.118.ebuild132
12 files changed, 470 insertions, 5 deletions
diff --git a/media-plugins/kodi-pvr-mythtv/Manifest b/media-plugins/kodi-pvr-mythtv/Manifest
index 4314211afa2f..901462c1bdce 100644
--- a/media-plugins/kodi-pvr-mythtv/Manifest
+++ b/media-plugins/kodi-pvr-mythtv/Manifest
@@ -3,3 +3,4 @@ DIST kodi-pvr-mythtv-5.10.16.tar.gz 702675 BLAKE2B cc2f229e53b9c91b1a09e954dda88
DIST kodi-pvr-mythtv-5.10.18.tar.gz 702659 BLAKE2B 90e1d655633a857e8068f4b1cb30c3f4cd802adc1139002399107989d3e8477ed38b83076f5a3a96bacd18e10c8a28399e752d43078cf4d9fafb73ef4d4328f9 SHA512 cc09de5086f69e1cee073719d306a44b41f2b0131bc70f74ee730eb681a72d4cecbd263d52ac7610574ce1a8d1b737cdc653adbf9642559e5e0fafa0e06aea25
DIST kodi-pvr-mythtv-5.10.19.tar.gz 702741 BLAKE2B 0baa0e7168ca33af0198205323b1ec8036b46ad33cde2c9a0ce928ae3335d4e0c2704094e3e5b77af41a53f07ded7a77e8709a3c29b389dc044969523982c08d SHA512 7b0ce0ccd74fa5743c774804f6f8d34d3d2085195da26a9da74a12948d611a25142a7ffb228e342120d286da140b234cbfc8a5ca97a77a5a2fc807d6d52d60ae
DIST kodi-pvr-mythtv-7.0.5.tar.gz 706430 BLAKE2B 569725596d66efd8076f39f7ff6fd6aba10057f77be395a94c03d58146e50072c055adf625a02ab9390dbe1cffeddb3b7775e03c689b1b32bef138bdd9af19a6 SHA512 ad94f44f0fa853776da62af7b23a54d884cb25b6fab3186b1bc02f9c4716e7cdeb371f5eb789d65221573117ed7afafcc2a7e1f53a004d42866b61d8deae1dac
+DIST kodi-pvr-mythtv-7.1.1.tar.gz 706444 BLAKE2B 130dc700cbc3d95e5d5332caf5718ef965442f0e42a6922c000753da63a6d679352560ddb5f6ced03f993f12fecbd1e4e8d42618cb5110d65b5bf425d32d79c5 SHA512 9154924e7c433a8d0aa6c82a8e6b638310707d1df0607a19da7cc97431e66a38f11ab2d5e1c95ec05caf37f4a32ddce54efa4e94f07d19d2264422d38c4e6bad
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-7.1.1.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-7.1.1.ebuild
new file mode 100644
index 000000000000..3e6fb192fd68
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-7.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ sys-libs/zlib
+ =media-tv/kodi-19*
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-vfs-sftp/Manifest b/media-plugins/kodi-vfs-sftp/Manifest
index 949109a07646..15eb1a1ee362 100644
--- a/media-plugins/kodi-vfs-sftp/Manifest
+++ b/media-plugins/kodi-vfs-sftp/Manifest
@@ -4,3 +4,4 @@ DIST kodi-vfs-sftp-1.0.4.tar.gz 28366 BLAKE2B fce63dcfffdaa03bcfae7ef4c4406ee209
DIST kodi-vfs-sftp-1.0.5.tar.gz 30777 BLAKE2B ff0fd5a56a5e68cafddd7267c9881079b7439ddc8f15638a1ea9f8d05be505646f08f1332b85e0e3fa8e0959194ee009b125222e86e78e02876f6b373b5e9b47 SHA512 999b7c136294b7691457ffea4fa929211dce8cdabcb3b1efcb37c2e062ca10b36f2f036cd1bbaa2e25a9c1647b983b48acd6a279df4ceb1741cb5131d379e381
DIST kodi-vfs-sftp-1.0.6.tar.gz 37162 BLAKE2B 7f2a4e9dbabd01b2fbd4efd6c19e8f5bcf1f6e6f55fe7a286c6bf616fa83303f3a0e26cf8c82cc6e4a69a7c981645f72bbfa06b4c0545047b5c1ae579cc22257 SHA512 e7e6d70e974179bb1d7b5a22b495490d75ad6988b8b519a03c167dd9731ed8c695a2ef3b72264107b9559ab9ce2756a4aa3247d6417de50d9a3652d2c890e618
DIST kodi-vfs-sftp-1.3.0.tar.gz 36956 BLAKE2B 213049a4a3b2e35040622f4c5cb5ab6a76a6c4a0f56cd8157248fa83fb7a8a7054623a11f919e73ed0ace5f64d2ead88db6e613ba12a978ee76e936dcb606bd4 SHA512 2edf833761da194d53d33e7a35ec440283eacd9a31adec3518408fe318c3131a1a2c59c7e61c4562af7029030d97adaad500eb83bbcc0e679aff1568ae6732e0
+DIST kodi-vfs-sftp-2.0.0.tar.gz 36146 BLAKE2B 50aadf1087b64791c6e284673c4072829592dd10e8772b739e34091257c3a410862225dae98c322b6616663e3dd0d6ebe8ae7e1518fe89cc9e8b2233dec95cf0 SHA512 223dc0f7ef53318963e77f4b4c5ddb9bc3afa9f3ea5d8ba202269d71a68f24600b99c6927ee856441fe216fbec9e821af8328c3911ef306dff61bb107a7cf0df
diff --git a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild
new file mode 100644
index 000000000000..4f57d2b4aa6c
--- /dev/null
+++ b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="SFTP VFS addon for Kodi"
+HOMEPAGE="https://github.com/xbmc/vfs.sftp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/vfs.sftp.git"
+ EGIT_BRANCH="Matrix"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/vfs.sftp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vfs.sftp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ net-libs/libssh[sftp]
+ =media-tv/kodi-19*
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}
diff --git a/media-plugins/kodi-visualization-shadertoy/Manifest b/media-plugins/kodi-visualization-shadertoy/Manifest
index fb1338a7ecb0..66c57fb9b745 100644
--- a/media-plugins/kodi-visualization-shadertoy/Manifest
+++ b/media-plugins/kodi-visualization-shadertoy/Manifest
@@ -8,3 +8,4 @@ DIST kodi-visualization-shadertoy-1.2.3.tar.gz 12495585 BLAKE2B 821b4bf4b380125c
DIST kodi-visualization-shadertoy-2.1.1.tar.gz 12481964 BLAKE2B 179e60218a86ab3294fab5a7c8d5c1f4892ad0f6ff9a3a799a05088551a61487542a0624201a4025aafeaeba097228b21ddf36310f930661f25b27fed4588ccf SHA512 e406ceec5f4efc6bdc7b22ec96cfb36a59177a836ea3bf6a3a5df6cdde0c2ee9f7e7c93b240d9b0e4c2f3f2c7c8fe6d88123c4cb104d547b5ce15f8223b20ea0
DIST kodi-visualization-shadertoy-2.2.0.tar.gz 12483112 BLAKE2B 6b8a841085b316eeddcda95e4d4d79949f2bc822605469a4fddf589180f6a93310b14a449201ed600d22422c47bce8bb53e92faded294a7c49dcce9e93bc7648 SHA512 0050f35614b17e48adbe16c8255c111e0927245b46067bbf8d547b460b556f3fa8cf12fb3c6cfd7320a06967d2b397da3d83aa5b58e9f997dfc2d318771d5302
DIST kodi-visualization-shadertoy-2.2.1.tar.gz 12483348 BLAKE2B 81cb4383b6067149a6ec4a66329a11d9482fb845f3c70c2a51644f3af0fc151adf7ace7c1f252bc911ed8095b2f52e54b2ba718de12a2256dec9ab135eb1256b SHA512 91b9feaa47b025dbce0a60723405ff2cbab926c37d167984be4409aba1f296de6d734667d728ce5c5730fb3a7cde815e37237aa641e3808d693dd94f8999650f
+DIST kodi-visualization-shadertoy-2.3.0.tar.gz 12483281 BLAKE2B a2140c52820a235d9c3d469fea0d3d1b20bc33d697915a6dd789fe0c25addb5296d80d643ee2d99613b3f3144b41c451b2a418798df7a5aa869f96e79187b3f4 SHA512 7693e67b3aaad0b6bc78c80b1bdfd92348de139acbb1292b56e9430dfd939b242f56e5c732625bece0088ef9e2a5627fe2f9a19aadbf076c54647c9e6929874a
diff --git a/media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-2.3.0.ebuild b/media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-2.3.0.ebuild
new file mode 100644
index 000000000000..ed5256b3ad5d
--- /dev/null
+++ b/media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Shadertoy visualizer for Kodi"
+HOMEPAGE="https://github.com/xbmc/visualization.shadertoy"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/visualization.shadertoy.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/visualization.shadertoy/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/visualization.shadertoy-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ >=media-libs/glm-0.9.9.8-r1
+ virtual/opengl
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}
diff --git a/sys-apps/ipmiutil/Manifest b/sys-apps/ipmiutil/Manifest
index 1f4bf92209bb..bc3c07233bb9 100644
--- a/sys-apps/ipmiutil/Manifest
+++ b/sys-apps/ipmiutil/Manifest
@@ -1,4 +1,4 @@
DIST ipmiutil-3.0.6.tar.gz 1692679 BLAKE2B dcc02dbb5467b824005dbc95c8f5231b2e2758e7600231c1c3fc31c1207cff0540400857dd1bfa83fc8b033fe0277ab23c6013f110744bff57fe4bc7b89174f9 SHA512 0c47246b7aa6a060091745d36e33aae07e7907dcad5fefb1759aac62adf48316915ce5818d2f9241e24b73be13e54fbb57046234a69c60ce56f41a933915580f
DIST ipmiutil-3.0.9.tar.gz 1697688 BLAKE2B 93ed8865cae1cea0ea4f7de4683f4698e3f75e9190cc7e0af1832ca44a08f52aa149393761f1ede3994827db78841061d54058bbe4178b5930accd3a4c225ba7 SHA512 c2c0a516216a46a52621159e665a77d96cf81f385fc9cf19877e72283be3e1a4dad5a4826454727b71576c22cc4de3c73ff428d26f35bf496c7dc1511305cda3
-DIST ipmiutil-3.1.5.tar.gz 1703583 BLAKE2B 5e96659387b3e11e5f7867156d0079e06f19676099e8ff2a212f7e28550f9dde2079a4d527439489e1a710d878e7eb79a68b0e11b531f92d986aa7687273d462 SHA512 a9bd4d99d5bcad8a9f64c3636d6774d09e1d4c20927a6803891777ba035ee3c114b06295185cf00fb0c5d4b4b9afd335fd19c06f64298130e42945dc5f6e8010
DIST ipmiutil-3.1.6.tar.gz 1693461 BLAKE2B efc2b283d7655b8afb9d3d8da2e5458deea1c1b939f3ccdf2be0cdf3792ea60229099cce1b8e32f087972385feb01d604f1c63bddbfd031210d5acf8a6b1b9d7 SHA512 9bccfa2e0bba7f30e422d67f93ee6cff50c08cc8bceab5ba5bfd1b0a91e1af8a4a98a2eaa81364e8a1f38e0bd1ce6b99717d86957c6f689aa7329e7013f5b0ef
+DIST ipmiutil-3.1.7.tar.gz 1726396 BLAKE2B 7fa31f8aca61462fc08dd4fe420e27eecce2ee9fa5fb2676eb944e2ae6c09598aec5f06d59e4ed02faab077003b14085f944b6cf0b63f90b10f2660f363e997b SHA512 7522808e4a94c8627de0a95dde0e3eb463ba05948159b5181129b573ce8f9feba3543ef603c14e7cdcafcbd58ca5319536cc5534ea8191cce0ef9d33cc548274
diff --git a/sys-apps/ipmiutil/files/ipmiutil-3.1.7-fix-configure.patch b/sys-apps/ipmiutil/files/ipmiutil-3.1.7-fix-configure.patch
new file mode 100644
index 000000000000..16435dacd6b7
--- /dev/null
+++ b/sys-apps/ipmiutil/files/ipmiutil-3.1.7-fix-configure.patch
@@ -0,0 +1,184 @@
+--- ipmiutil-3.1.7/configure.ac
++++ ipmiutil-3.1.7/configure.ac
+@@ -80,40 +80,46 @@
+ # fi]
+
+ drv_landesk=0
++LANDESK_CFLAGS=""
++LANDESK_LDADD=""
+ dnl configure for LANDESK libipmiapi or not
+ AC_ARG_ENABLE([landesk],
+- [ --enable-landesk adds landesk library support [[default=no]]],
+- [if test "x$enableval" = "xyes"; then
+- drv_landesk=1
+- LANDESK_CFLAGS="-DLINK_LANDESK"
+- LANDESK_LDADD="-lipmiapi -L../lib"
+- AC_SUBST(LANDESK_CFLAGS)
+- AC_SUBST(LANDESK_LDADD)
+- fi]
+- )
++ AS_HELP_STRING([--enable-landesk], [enable landesk support (default=no)]),
++ [],
++ [enable_landesk=no])
++
++AS_IF([test "x$enable_landesk" = "xyes"], [
++ drv_landesk=1
++ LANDESK_CFLAGS="-DLINK_LANDESK"
++ LANDESK_LDADD="-lipmiapi -L../lib"
++ AC_SUBST(LANDESK_CFLAGS)
++ AC_SUBST(LANDESK_LDADD)
++ ])
+
+ dnl Configure ipmiutil for lanplus (libipmi_lanplus.a) or not (default yes)
+ AC_ARG_ENABLE([lanplus],
+- [ --enable-lanplus enable lanplus support (default=yes)],[default=yes],
+-[if test "x$enableval" = "xno"; then
+- drv_lanplus=""
+- LANPLUS_CFLAGS=""
+- LANPLUS_LDADD=""
+- LANPLUS_LIB=""
+- LANPLUS_CRYPTO=""
+- LANPLUS_SAM="no"
+- LD_SAMX=""
+-else
++ AS_HELP_STRING([--disable-lanplus], [enable lanplus support (default=yes)]),
++ [],
++ [enable_lanplus=yes])
++
++drv_lanplus=""
++LANPLUS_CFLAGS=""
++LANPLUS_LDADD=""
++LANPLUS_LIB=""
++LANPLUS_CRYPTO=""
++LANPLUS_SAM="no"
++LD_SAMX=""
++AS_IF([test "x$enable_lanplus" = "xyes"], [
+ drv_lanplus="lanplus"
+ LANPLUS_CFLAGS="-DHAVE_LANPLUS"
+ # LANPLUS_CFLAGS="-DHAVE_LANPLUS -I${projdir}/lib/lanplus/inc"
+ # LANPLUS_LDADD="-L../lib -lintf_lanplus -L/usr/local/lib -lcrypto"
+ LANPLUS_LDADD="-L../lib -lipmi_lanplus -L/usr/local/lib -lcrypto"
+- LANPLUS_LIB="../lib/libipmi_lanplus.a"
++ LANPLUS_LIB="../lib/libipmi_lanplus.a"
+ LANPLUS_CRYPTO="-lcrypto"
+ LANPLUS_SAM="yes"
+ LD_SAMX="../lib/libipmi_lanplus.a -lcrypto"
+-fi ])
++])
+
+ dnl Configure libipmiutil.a for lanplus or not
+ dnl Only SOL requires lanplus, so usually build libipmiutil.a without lanplus
+@@ -128,21 +134,28 @@
+ #fi
+
+ # strings /lib/libssl.so* |grep EVP_sha256
+-dnl configure for SHA256, build lanplus with SHA256 support, uses later openssl.
++dnl configure for SHA256, build lanplus with SHA256 support
++dnl requires openssl-1.0.1 which was released in 2012/03
+ AC_ARG_ENABLE([sha256],
+- [ --enable-sha256 build with SHA256 support, requires later openssl.],
+- [if test "x$enableval" = "xyes"; then
+- LANPLUS_CFLAGS="$LANPLUS_CFLAGS -DHAVE_SHA256"
+- fi]
+- )
++ AS_HELP_STRING([--disable-sha256], [build with SHA256 support (default=yes)]),
++ dnl action if passed
++ [],
++ dnl action if not passed
++ [enable_sha256=yes]
++ )
++AS_IF([test "x$enable_sha256" = "xyes"], [
++ LANPLUS_CFLAGS="$LANPLUS_CFLAGS -DHAVE_SHA256"
++])
+
+ dnl configure for EKANALYZER, build with ekanalyzer function enabled
+ AC_ARG_ENABLE([ekanalyzer],
+- [ --enable-ekanalyzer build with ekanalyzer function enabled.],
+- [if test "x$enableval" = "xyes"; then
++ AS_HELP_STRING([--enable-ekanalyzer], [build with ekanalyzer function enabled.]),
++ [],
++ [enable_ekanalyzer=no]
++ )
++AS_IF([test "x$enable_ekanalyzer" = "xyes"], [
+ OS_CFLAGS="$OS_CFLAGS -DHAVE_EKANAL"
+- fi]
+- )
++ ])
+
+ GPL_CFLAGS=""
+ CROSS_LFLAGS=""
+@@ -152,17 +165,20 @@
+ SYSTEMD_DIR=/usr/share/ipmiutil
+
+ AC_ARG_ENABLE([useflags],
+- [ --enable-useflags include environment CFLAGS and LDFLAGS.],
+- [if test "x$enableval" = "xyes"; then
++ AS_HELP_STRING([--enable-useflags], [include environment CFLAGS and LDFLAGS.]),
++ [],
++ [enable_useflags=no])
++AS_IF([test "x$enable_useflags" = "xyes"], [
+ CROSS_CFLAGS="$CFLAGS"
+ CROSS_LFLAGS="$LDFLAGS"
+- fi]
+- )
++])
+
+ dnl configure for standalone, with no lanplus or GPL libs
+ AC_ARG_ENABLE([standalone],
+- [ --enable-standalone build standalone, with no GPL or LanPlus libs.],
+- [if test "x$enableval" = "xyes"; then
++ AS_HELP_STRING([--enable-standalone], [build standalone, with no GPL or LanPlus libs.]),
++ [],
++ [enable_standalone=no])
++AS_IF([test "x$enable_standalone" = "xyes"], [
+ GPL_CFLAGS=""
+ LANPLUS_CFLAGS=""
+ LANPLUS_LDADD=""
+@@ -176,10 +192,11 @@
+ # cross-compiling, so link with -static (e.g. Android ARM)
+ CROSS_LFLAGS="-static"
+ CROSS_CFLAGS="-DCROSS_COMPILE"
++ # TODO: how can this be effective? Configure only converts Makefile.in -> Makefile
++ # Configure does not convert Makefile.am->Makefile.in
+ sed -i -e 's/^# ipmiutil: $(METASOURCE:.c=.o)/ipmiutil:\t$(METASOURCE:.c=.o)\n\t$(CC) $(CFLAGS) $(LDFLAGS) -o ipmiutil $(METASOURCE:.c=.o) $(LDADD)/' util/Makefile.am
+ fi
+- fi]
+- )
++ ])
+
+ AC_ARG_ENABLE([doc],
+ [ --enable-doc build with documentation [[default=yes]]],
+@@ -192,20 +209,22 @@
+
+ dnl build libipmiutil with sensor modules
+ AC_ARG_ENABLE([libsensors],
+- [ --enable-libsensors build libipmiutil with sensor modules [[default=no]]],
+- [if test "x$enableval" = "xyes"; then
+- LIBSENSORS="isensor2.o ievents2.o"
+- SAM2OBJ=""
+- fi]
+- )
++ AS_HELP_STRING([--enable-libsensors], [build libipmiutil with sensor modules (default=no)]),
++ [],
++ [enable_libsensors=no])
++AS_IF([test "x$enable_libsensors" = "xyes"], [
++ LIBSENSORS="isensor2.o ievents2.o"
++ SAM2OBJ=""
++ ])
+
+ dnl configure for GPL build or not (GPL files: md2.h, ipmi_ioctl.h)
+ AC_ARG_ENABLE([gpl],
+- [ --enable-gpl build with some GPL code [[default=no]]],
+- [if test "x$enableval" = "xyes"; then
+- GPL_CFLAGS="-DALLOW_GPL"
+- fi]
+- )
++ AS_HELP_STRING([--enable-gpl], [build with some GPL code (default=no)]),
++ [],
++ [enable_gpl=no])
++AS_IF([test "x$enable_gpl" = "xyes"], [
++ GPL_CFLAGS="-DALLOW_GPL"
++ ])
+
+ dnl Does this Linux have systemd enabled? Otherwise use sysv init.
+ AC_ARG_ENABLE([systemd],
diff --git a/sys-apps/ipmiutil/files/ipmiutil-3.1.7-flags.patch b/sys-apps/ipmiutil/files/ipmiutil-3.1.7-flags.patch
new file mode 100644
index 000000000000..7ef804bc11d3
--- /dev/null
+++ b/sys-apps/ipmiutil/files/ipmiutil-3.1.7-flags.patch
@@ -0,0 +1,20 @@
+--- ipmiutil-3.1.7/configure.ac
++++ ipmiutil-3.1.7/configure.ac
+@@ -170,7 +170,7 @@
+ LANPLUS_CRYPTO=""
+ LANPLUS_SAM="no"
+ LD_SAMX=""
+- CFLAGS="-O2"
++ #CFLAGS="-O2"
+ SUBDIR_S="scripts util"
+ if test "x$cross_compiling" = "xyes"; then
+ # cross-compiling, so link with -static (e.g. Android ARM)
+@@ -363,7 +363,7 @@
+ fi
+ rm -f $tmpc $tmpo >/dev/null 2>&1
+ echo $ECHO_N "checking compile fortify flags ... $ECHO_C"
+- cfhard="-fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
++ #cfhard="-fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
+ echo "int main() { alloca(100); return(1); }" >$tmpc
+ $CC -o $tmpo $cfhard $tmpc >/dev/null 2>&1
+ if test $? -ne 0 ; then
diff --git a/sys-apps/ipmiutil/ipmiutil-3.1.5-r1.ebuild b/sys-apps/ipmiutil/ipmiutil-3.1.7.ebuild
index e6ec34c06cd9..5bf9b0440aa6 100644
--- a/sys-apps/ipmiutil/ipmiutil-3.1.5-r1.ebuild
+++ b/sys-apps/ipmiutil/ipmiutil-3.1.7.ebuild
@@ -18,9 +18,9 @@ DEPEND="${RDEPEND}
virtual/os-headers"
PATCHES=(
- "${FILESDIR}"/${PN}-2.9.8-flags.patch
+ "${FILESDIR}"/${PN}-3.1.7-flags.patch
"${FILESDIR}"/${PN}-2.9.9-lib_symlink.patch
- "${FILESDIR}"/${PN}-3.1.5-fix-configure.patch
+ "${FILESDIR}"/${PN}-3.1.7-fix-configure.patch
)
src_prepare() {
@@ -30,13 +30,18 @@ src_prepare() {
sed -i -e 's|which rpm |which we_are_gentoo_rpm_is_a_guest |' configure.ac || die
# Don't compress man pages
- sed '/gzip -f/d' -i doc/Makefile.am || die
+ sed '/gzip -nf/d' -i doc/Makefile.am || die
eautoreconf
}
src_configure() {
- econf --disable-systemd --enable-sha256 --enable-lanplus
+ local myeconfargs=(
+ --disable-systemd
+ --enable-sha256
+ --enable-lanplus
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {
@@ -58,6 +63,7 @@ src_install() {
# Init scripts are only for Fedora
rm -r "${ED}"/etc/init.d || die 'remove initscripts failed'
+ # --disable-static has no effect
if ! use static-libs ; then
find "${ED}" -type f -name '*.a' -delete || die
fi
diff --git a/sys-auth/polkit/Manifest b/sys-auth/polkit/Manifest
index 7bd122a1005f..22da4a92e245 100644
--- a/sys-auth/polkit/Manifest
+++ b/sys-auth/polkit/Manifest
@@ -1,3 +1,4 @@
DIST polkit-0.115.tar.gz 1550932 BLAKE2B 3185ebed46209f88a9ffccbbcaf1bf180d1ae6d5ec53cf3c66d867ad43910b47a1123a3db190991ebb382a0d28fc5a119ea4bab942db324e9af5663056cf6ee1 SHA512 1153011fa93145b2c184e6b3446d3ca21b38918641aeccd8fac3985ac3e30ec6bc75be6973985fde90f2a24236592f1595be259155061c2d33358dd17c4ee4fc
DIST polkit-0.116.tar.gz 1548311 BLAKE2B e9761a2934136d453a47b81dd1f132f9fc96c45b731d5fceb2aa7706f5325b6499f6acbb68032befc1b21878b1b54754685607c916ca8e02a8accca3ca014b31 SHA512 b66b01cc2bb4349de70147f41f161f0f6f41e7230b581dfb054058b48969ec57041ab05b51787c749ccfc36aa5f317952d7e7ba337b4f6f6c0a923ed5866c2d5
DIST polkit-0.117.tar.gz 1554536 BLAKE2B 1cf7e0ff9db19a29be626f4bea96c9e2ef8b1eab4b8287a5f1f4d2a818b86d58c1c4c4a41849d95e31559dba1b18853a31e934ebbadd8e07f94dfd58b45240e0 SHA512 c10ea984f2386fe436e58a2866e5323afc80d24f744f0ee61d966941259aa491bd96b07d911434aa731b300c3cca25b647804b396501175ab5b3c53384e94c70
+DIST polkit-0.118.tar.gz 1556765 BLAKE2B d048b37b1ff8ad59a2d8a333a3b459d1592b61f7a6d9a9569f8b2984de913d71abfc9748e242c7453f0bce4f322bd44672e35309f181afd22488794ca0e47119 SHA512 3d412f40c903cfaf68530f9c0cb616106f8edf43bec6805de129f8bb9cb4e64c98da6bf02caa3ef5619974f3e2df7a70564f08b92901662453477e9005752b4e
diff --git a/sys-auth/polkit/polkit-0.118.ebuild b/sys-auth/polkit/polkit-0.118.ebuild
new file mode 100644
index 000000000000..a3123451cf84
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.118.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools pam pax-utils systemd xdg-utils
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/polkit https://gitlab.freedesktop.org/polkit/polkit"
+SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc64 ~s390 ~x86"
+IUSE="consolekit elogind examples gtk +introspection jit kde nls pam selinux systemd test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="^^ ( consolekit elogind systemd )"
+
+BDEPEND="
+ acct-user/polkitd
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/gobject-introspection-common
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="
+ dev-lang/spidermonkey:78[-debug]
+ dev-libs/glib:2
+ dev-libs/expat
+ elogind? ( sys-auth/elogind )
+ pam? (
+ sys-auth/pambase
+ sys-libs/pam
+ )
+ systemd? ( sys-apps/systemd:0=[policykit] )
+"
+RDEPEND="${DEPEND}
+ acct-user/polkitd
+ selinux? ( sec-policy/selinux-policykit )
+"
+PDEPEND="
+ consolekit? ( sys-auth/consolekit[policykit] )
+ gtk? ( || (
+ >=gnome-extra/polkit-gnome-0.105
+ >=lxde-base/lxsession-0.5.2
+ ) )
+ kde? ( kde-plasma/polkit-kde-agent )
+"
+
+DOCS=( docs/TODO HACKING NEWS README )
+
+PATCHES=(
+ # bug 660880
+ "${FILESDIR}"/polkit-0.115-elogind.patch
+)
+
+QA_MULTILIB_PATHS="
+ usr/lib/polkit-1/polkit-agent-helper-1
+ usr/lib/polkit-1/polkitd"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|unix-group:wheel|unix-user:0|' src/polkitbackend/*-default.rules || die #401513
+
+ # Workaround upstream hack around standard gtk-doc behavior, bug #552170
+ sed -i -e 's/@ENABLE_GTK_DOC_TRUE@\(TARGET_DIR\)/\1/' \
+ -e '/install-data-local:/,/uninstall-local:/ s/@ENABLE_GTK_DOC_TRUE@//' \
+ -e 's/@ENABLE_GTK_DOC_FALSE@install-data-local://' \
+ docs/polkit/Makefile.in || die
+
+ # disable broken test - bug #624022
+ sed -i -e "/^SUBDIRS/s/polkitbackend//" test/Makefile.am || die
+
+ # Fix cross-building, bug #590764, elogind patch, bug #598615
+ eautoreconf
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --disable-static
+ --enable-man-pages
+ --disable-gtk-doc
+ --disable-examples
+ $(use_enable elogind libelogind)
+ $(use_enable introspection)
+ $(use_enable nls)
+ $(usex pam "--with-pam-module-dir=$(getpam_mod_dir)" '')
+ --with-authfw=$(usex pam pam shadow)
+ $(use_enable systemd libsystemd-login)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable test)
+ --with-os-type=gentoo
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ # Required for polkitd on hardened/PaX due to spidermonkey's JIT
+ pax-mark mr src/polkitbackend/.libs/polkitd test/polkitbackend/.libs/polkitbackendjsauthoritytest
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc src/examples/{*.c,*.policy*}
+ fi
+
+ diropts -m 0700 -o polkitd
+ keepdir /usr/share/polkit-1/rules.d
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ chmod 0700 "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
+ chown polkitd "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
+}