summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-29 01:19:05 +0000
committerSam James <sam@gentoo.org>2023-10-29 01:19:05 +0000
commit38e920453eec3ab5dfa4dd57728a86dcc5e8a04a (patch)
tree289643d8029ff2860b359da91a1276f577056e8c
parentdev-perl/Log-Report: add 1.360.0 (diff)
downloadgentoo-38e920453eec3ab5dfa4dd57728a86dcc5e8a04a.tar.gz
gentoo-38e920453eec3ab5dfa4dd57728a86dcc5e8a04a.tar.bz2
gentoo-38e920453eec3ab5dfa4dd57728a86dcc5e8a04a.zip
dev-perl/UUID: add 0.290.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/UUID/Manifest1
-rw-r--r--dev-perl/UUID/UUID-0.290.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/UUID/Manifest b/dev-perl/UUID/Manifest
index 74cafce1303c..bbf67a12d9bd 100644
--- a/dev-perl/UUID/Manifest
+++ b/dev-perl/UUID/Manifest
@@ -1 +1,2 @@
DIST UUID-0.28.tar.gz 15828 BLAKE2B 670f25e2e3e414e36ee5dd7d129cefd1f9a50e1e9594c7adf5625f9d193755a2ac08d8b9acd8fcef0b2e1b1e26bf2c2f6d2a2f338dbb43c3eeac7a305a052624 SHA512 f6203e024f83c8156d4dae093513f5a6817a67874d77f01c7cb1f83d1cfa811c815ad3324983b655332e994f85c536eb65682e598168f9d1d6b76bf0bde9817e
+DIST UUID-0.29.tar.gz 15955 BLAKE2B e2dbbb16b36fcc1244c44bfe520e0391d6fae02a47b2299ce9b5dc5bc8a42c16bbe6ab91da5c5e0228a263441d3922c5214e9da64ed6489adc355fe973c5ab53 SHA512 37b8a1013532772e5265ef093d7ba0dc5e52ad31e7a4ac2181515c0b3121b355dda697c27c60d44f9ad5e767c3739b0e67df32f450d3445707648f542ea3f7cf
diff --git a/dev-perl/UUID/UUID-0.290.0.ebuild b/dev-perl/UUID/UUID-0.290.0.ebuild
new file mode 100644
index 000000000000..32c15003fd49
--- /dev/null
+++ b/dev-perl/UUID/UUID-0.290.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=JRM
+DIST_VERSION=0.29
+inherit perl-module
+
+DESCRIPTION="Perl extension for using UUID interfaces as defined in e2fsprogs"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+# Note: UUID appears to link against a bunch of different UUID
+# implementations depending on availability and platform.
+# Presently uses uuid.h/libuuid.so from util-linux which is fine for Linux
+# platforms, but may need special attention on *bsd, *osx and win*
+RDEPEND="sys-apps/util-linux"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Devel-CheckLib-1.140.0
+"
+DEPEND="${RDEPEND}"