summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-12-17 01:05:04 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-12-17 01:05:04 +0000
commit340bd3bd9070d6510b3d9f9e6ac3713535eec62c (patch)
treeed8013ed97aba8554ec9d3a20793712cc099884a
parent2020-12-17 00:35:12 UTC (diff)
parentsys-libs/uid_wrapper: Stabilize 1.2.8 amd64, #737486 (diff)
downloadgentoo-340bd3bd9070d6510b3d9f9e6ac3713535eec62c.tar.gz
gentoo-340bd3bd9070d6510b3d9f9e6ac3713535eec62c.tar.bz2
gentoo-340bd3bd9070d6510b3d9f9e6ac3713535eec62c.zip
Merge updates from master
-rw-r--r--app-admin/gentoo-perl-helpers/gentoo-perl-helpers-0.4.0.ebuild2
-rw-r--r--dev-python/PyQt5/Manifest1
-rw-r--r--dev-python/PyQt5/PyQt5-5.15.2.ebuild190
-rw-r--r--dev-python/PyQtWebEngine/Manifest1
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.15.2.ebuild75
-rw-r--r--games-simulation/openrct2/Manifest3
-rw-r--r--games-simulation/openrct2/openrct2-0.3.0-r1.ebuild166
-rw-r--r--games-simulation/openrct2/openrct2-0.3.2-r1.ebuild2
-rw-r--r--media-gfx/krita/krita-4.4.1.ebuild2
-rw-r--r--net-fs/samba/samba-4.12.9-r1.ebuild2
-rw-r--r--sci-calculators/galculator/galculator-2.1.4-r1.ebuild2
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.2.8-r1.ebuild2
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild2
-rw-r--r--sys-libs/ldb/ldb-2.1.4-r1.ebuild2
-rw-r--r--sys-libs/liburing/liburing-0.7-r1.ebuild2
-rw-r--r--sys-libs/uid_wrapper/uid_wrapper-1.2.8.ebuild2
-rw-r--r--x11-libs/gl2ps/gl2ps-1.4.2.ebuild2
-rw-r--r--x11-plugins/purple-facebook/purple-facebook-20190113.ebuild4
-rw-r--r--x11-wm/icewm/icewm-1.9.2.ebuild2
19 files changed, 281 insertions, 183 deletions
diff --git a/app-admin/gentoo-perl-helpers/gentoo-perl-helpers-0.4.0.ebuild b/app-admin/gentoo-perl-helpers/gentoo-perl-helpers-0.4.0.ebuild
index 4304f8dd6662..230e202e58f7 100644
--- a/app-admin/gentoo-perl-helpers/gentoo-perl-helpers-0.4.0.ebuild
+++ b/app-admin/gentoo-perl-helpers/gentoo-perl-helpers-0.4.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="
"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE=""
# Assumed System:
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
index 954521b840fa..fe53d1c65bc1 100644
--- a/dev-python/PyQt5/Manifest
+++ b/dev-python/PyQt5/Manifest
@@ -1 +1,2 @@
DIST PyQt5-5.15.1.tar.gz 3264559 BLAKE2B 20060297c52aa5d07ba28b50440bd3623b8648eef8502693f8175af9ba4edf9238b9be71c696ea2589556ad70e70e868dc9c286466af22867ab51d5c66e613db SHA512 a7378dd53337c58f5ba7e9f7510b57fe4affe578b68975ce1dd7ba5c2a1c77d08d51d11078ce782aab09509df934eb3e4d0588de87391f74ad99f9624644cc4e
+DIST PyQt5-5.15.2.tar.gz 3265445 BLAKE2B 7712d68aa54cf9e6836863d7aa645151254d79621e115ed314ba63c371d5e24577a0392311b31a73e45af45baa29eca1d7e9a03874beac1fbf043fa703af69f9 SHA512 6d48d2ed907b436131d46b0513d82e1069c76e873d395e4a6c0832ae3a20621b92d3abece046c5fcd14cb818d50ffb369153fca1ce9341f0db1b8c479b94e621
diff --git a/dev-python/PyQt5/PyQt5-5.15.2.ebuild b/dev-python/PyQt5/PyQt5-5.15.2.ebuild
new file mode 100644
index 000000000000..c98841322746
--- /dev/null
+++ b/dev-python/PyQt5/PyQt5-5.15.2.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit multibuild python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+# TODO: QtNfc, QtQuick3D, QtRemoteObjects, QtTextToSpeech
+IUSE="bluetooth dbus debug declarative designer examples gles2-only gui help location
+ multimedia network networkauth opengl positioning printsupport sensors serialport
+ sql +ssl svg testlib webchannel webkit websockets widgets x11extras xmlpatterns"
+
+# The requirements below were extracted from configure.py
+# and from the output of 'grep -r "%Import " "${S}"/sip'
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ bluetooth? ( gui )
+ declarative? ( gui network )
+ designer? ( widgets )
+ help? ( gui widgets )
+ location? ( positioning )
+ multimedia? ( gui network )
+ networkauth? ( network )
+ opengl? ( gui widgets )
+ positioning? ( gui )
+ printsupport? ( gui widgets )
+ sensors? ( gui )
+ serialport? ( gui )
+ sql? ( widgets )
+ svg? ( gui widgets )
+ testlib? ( widgets )
+ webchannel? ( network )
+ webkit? ( gui network printsupport widgets )
+ websockets? ( network )
+ widgets? ( gui )
+ xmlpatterns? ( network )
+"
+
+# Minimal supported version of Qt.
+QT_PV="5.15:5"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/PyQt5-sip-4.19.23:=[${PYTHON_USEDEP}]
+ >=dev-qt/qtcore-${QT_PV}
+ >=dev-qt/qtxml-${QT_PV}
+ bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
+ dbus? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-qt/qtdbus-${QT_PV}
+ )
+ declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
+ designer? ( >=dev-qt/designer-${QT_PV} )
+ gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only=] )
+ help? ( >=dev-qt/qthelp-${QT_PV} )
+ location? ( >=dev-qt/qtlocation-${QT_PV} )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
+ network? ( >=dev-qt/qtnetwork-${QT_PV}[ssl=] )
+ networkauth? ( >=dev-qt/qtnetworkauth-${QT_PV} )
+ opengl? ( >=dev-qt/qtopengl-${QT_PV} )
+ positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
+ printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
+ sensors? ( >=dev-qt/qtsensors-${QT_PV} )
+ serialport? ( >=dev-qt/qtserialport-${QT_PV} )
+ sql? ( >=dev-qt/qtsql-${QT_PV} )
+ svg? ( >=dev-qt/qtsvg-${QT_PV} )
+ testlib? ( >=dev-qt/qttest-${QT_PV} )
+ webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
+ webkit? ( dev-qt/qtwebkit:5[printsupport] )
+ websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
+ widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
+ x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
+ xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.23[${PYTHON_USEDEP}]
+ dbus? ( virtual/pkgconfig )
+"
+
+S=${WORKDIR}/${MY_P}
+
+pyqt_use_enable() {
+ use "$1" || return
+
+ if [[ $# -eq 1 ]]; then
+ echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
+ else
+ shift
+ echo ${@/#/--enable=}
+ fi
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ $(usex debug '--debug --qml-debug --trace' '')
+ --verbose
+ --confirm-license
+ --qmake="$(qt5_get_bindir)"/qmake
+ --bindir="${EPREFIX}/usr/bin"
+ --qsci-api
+ --enable=QtCore
+ --enable=QtXml
+ $(pyqt_use_enable bluetooth)
+ $(pyqt_use_enable dbus QtDBus)
+ $(usex dbus '' --no-python-dbus)
+ $(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
+ $(usex declarative '' --no-qml-plugin)
+ $(pyqt_use_enable designer)
+ $(usex designer '' --no-designer-plugin)
+ $(usex gles2-only '--disable-feature=PyQt_Desktop_OpenGL' '')
+ $(pyqt_use_enable gui)
+ $(pyqt_use_enable gui $(use gles2-only && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
+ $(pyqt_use_enable help)
+ $(pyqt_use_enable location)
+ $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
+ $(pyqt_use_enable network)
+ $(pyqt_use_enable networkauth QtNetworkAuth)
+ $(pyqt_use_enable opengl QtOpenGL)
+ $(pyqt_use_enable positioning)
+ $(pyqt_use_enable printsupport QtPrintSupport)
+ $(pyqt_use_enable sensors)
+ $(pyqt_use_enable serialport QtSerialPort)
+ $(pyqt_use_enable sql)
+ $(usex ssl '' '--disable-feature=PyQt_SSL')
+ $(pyqt_use_enable svg)
+ $(pyqt_use_enable testlib QtTest)
+ $(pyqt_use_enable webchannel QtWebChannel)
+ $(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
+ $(pyqt_use_enable websockets QtWebSockets)
+ $(pyqt_use_enable widgets)
+ $(pyqt_use_enable x11extras QtX11Extras)
+ $(pyqt_use_enable xmlpatterns QtXmlPatterns)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ local tmp_root=${D}/${PN}_tmp_root
+ # parallel install fails because mk_distinfo.py runs too early
+ emake -j1 INSTALL_ROOT="${tmp_root}" install
+
+ local bin_dir=${tmp_root}${EPREFIX}/usr/bin
+ local exe
+ for exe in pylupdate5 pyrcc5 pyuic5; do
+ python_doexe "${bin_dir}/${exe}"
+ rm "${bin_dir}/${exe}" || die
+ done
+
+ local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
+ rm -r "${uic_dir}"/port_v2 || die
+
+ multibuild_merge_root "${tmp_root}" "${D}"
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
index 300b3bc08a7f..3e54fe3f290e 100644
--- a/dev-python/PyQtWebEngine/Manifest
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -1 +1,2 @@
DIST PyQtWebEngine-5.15.1.tar.gz 48520 BLAKE2B d4e4fcfb1066fcc274f4b3c8ccd7380435b9391586e3396fb5aa95ad7443c168ea9be3b85ec93e2dc28285aca18718afeb1487cb2c4ad5ed1a4f4d03010107ec SHA512 1efbea43bfd4a6de1c7aa2ab2ca124c4278b6b7ea0d6073c64a7ad83df676759d0747421cae5214017e3c61d8edddf9766f93660e13eee5d407a24fd11d8c21f
+DIST PyQtWebEngine-5.15.2.tar.gz 48608 BLAKE2B a03f77b0cde0d1031e8f1c4c6b5d13a342c28cf814ebaaf4a2cdb4608ce40cdd8163783932abc76cda583c0fed7191653b537598a9ab65f6509ef88008538e31 SHA512 7e6d95833b1a9e5bb5275eff01e1923419da35d13862fc4cbb231cbf950ed45e628bc7e161b0b6b66c718ee439a1a8e66dd754cee9adcdf69ab1b8ffab58901e
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.2.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.2.ebuild
new file mode 100644
index 000000000000..94183f43f9bb
--- /dev/null
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QtWebEngine"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.14[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-sip-4.19.22:=[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtwebengine:5[widgets]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.22[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --qmake="$(qt5_get_bindir)"/qmake
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
+ ${PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+}
diff --git a/games-simulation/openrct2/Manifest b/games-simulation/openrct2/Manifest
index 06407f1c28c3..0847d88d7808 100644
--- a/games-simulation/openrct2/Manifest
+++ b/games-simulation/openrct2/Manifest
@@ -1,7 +1,4 @@
-DIST openrct2-0.3.0.tar.gz 11754657 BLAKE2B 66d956fd85829bc6b4825a59db9f3a3eebbb1e4565a4c8afdb8c05d9d7b3f339f75ff1d9fbc0a0f48d3c0673ac3fc335fb6bec5fe458513de2a0611ccfa3d48d SHA512 585bcd7a077114dc5332b95cb44f7c689e47fcbd7cff7c2ab32a24253a4fd87f50e79f40f9428c79ea6bc6d8cd88019b4edfce88509c03bc2d43854926d21317
DIST openrct2-0.3.2.tar.gz 12749225 BLAKE2B de79fefdb860dae1bf2962f9359d1ea46ab073c80206b6687ef40386725c84d1d048eafbd3f3aeb3fcae3136528568943e4cb88ae0f78b4f6c04d127726254e8 SHA512 e9986ce1fb7e57b4ac80b1de6c99f6b9d26a7a37b4e7fe081528f4faac41833871f9bcf8df864302b8d902271561fc44e606acf8d9adfaf789f69fbc4ae379a7
-DIST openrct2-objects-1.0.16.zip 3056214 BLAKE2B 7d8d938ba20ce612f7845dce1038134ec60d7e17e0f7d78a67480ae1ae2e6f8dd043f266742acd2dbd8539390349a2dcd7b8c73859a3caef3b5cd8565a4ec1c7 SHA512 2a8696467320f7894330d0fbb4894dd6effb2d6844fcf643e1f8e15a7b0b45411a7c205b75a9e9d7ea0627bc70b7a7e1e2213e0f7db1c7b489ae8b485670dba5
DIST openrct2-objects-1.0.18.zip 3117675 BLAKE2B faccbd11ff7995977b45cc81df07fde8eeecd781141cab813026bc551fb0d867edd078627cc83a6317fddccd025ed3019e14596bf107f48d287110d69c6f73bd SHA512 12deb118740e83a1dcd64b5196371f0fd4f57a3593ab58cb71867ccd35e7a9b0641bb797ab15266ec932c96f1fc208daa7b0e8683ac7e7ef48342733d8b58aa4
-DIST openrct2-replays-0.0.17.zip 1825315 BLAKE2B 9c22b52302c37abe5e802662eb4b6805fa3e229a71ab9f901b57eee30641ae4b86de9b1315476d158a3feb57c6be2a26c1ccca7c94328fe35bf57b46e2364c32 SHA512 103a8ba5b5b2dd76c18b642720d262553bb15ad26d59892f895327bf5e87b73e476b255af6556286faacb668aae49aa1ee29a14bcca2bb75d855383d12e60f4a
DIST openrct2-replays-0.0.19.zip 1825303 BLAKE2B d7ddbe090fe041f5bdeab435d223a40f5e8a231850393aa0274813c1b5db0abc2086dcf5b0e807232edf9ceaa05ce98efca14869a01742820366460353c29320 SHA512 09615b9687da0de1fd690765305a413b8e57b1de48d42a8707a9e4167ac20566b39b2abb6112b200ac0caab45001b7cd2896df71205d64df0c61e7742e082de5
DIST openrct2-title-sequences-0.1.2c.zip 2980030 BLAKE2B f91168bea0a4f88a801c95ea45759e0d1c887a89c18dbbded5887d2914db7119dd65c231aa422e4f8a964a81d832eae05bffaa8b7908fac39a63792d082b53a0 SHA512 0e544d236d5f6ac7f68d75ba1f56f043c76c77676cbb92e6fdbf68a6ae2dc6c41dbdad6083ceec36b2f774bcdd99f64f28de73b208d6a39a8218a9e95502d46e
diff --git a/games-simulation/openrct2/openrct2-0.3.0-r1.ebuild b/games-simulation/openrct2/openrct2-0.3.0-r1.ebuild
deleted file mode 100644
index 5a111a1f34fd..000000000000
--- a/games-simulation/openrct2/openrct2-0.3.0-r1.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake readme.gentoo-r1 xdg-utils
-
-MY_PN="OpenRCT2"
-MY_PN_OBJ="objects"
-MY_PN_RPL="replays"
-MY_PN_TS="title-sequences"
-MY_PV_OBJ="1.0.16"
-MY_PV_RPL="0.0.17"
-MY_PV_TS="0.1.2c"
-
-DESCRIPTION="An open source re-implementation of Chris Sawyer's RollerCoaster Tycoon 2"
-HOMEPAGE="https://openrct2.org/"
-SRC_URI="
- https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/${MY_PN}/${MY_PN_OBJ}/releases/download/v${MY_PV_OBJ}/${MY_PN_OBJ}.zip -> ${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}.zip
- https://github.com/${MY_PN}/${MY_PN_TS}/releases/download/v${MY_PV_TS}/${MY_PN_TS}.zip -> ${PN}-${MY_PN_TS}-${MY_PV_TS}.zip
- test? ( https://github.com/${MY_PN}/${MY_PN_RPL}/releases/download/v${MY_PV_RPL}/${MY_PN_RPL}.zip -> ${PN}-${MY_PN_RPL}-${MY_PV_RPL}.zip )
-"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="dedicated libressl +lightfx +opengl scripting test +truetype"
-
-COMMON_DEPEND="
- dev-libs/icu:=
- dev-libs/jansson
- dev-libs/libzip:=
- media-libs/libpng:0=
- net-misc/curl[ssl]
- sys-libs/zlib
- !dedicated? (
- media-libs/libsdl2
- media-libs/speexdsp
- opengl? ( virtual/opengl )
- )
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- scripting? ( dev-lang/duktape:= )
- truetype? (
- media-libs/fontconfig:1.0
- media-libs/freetype:2
- )
-"
-
-RDEPEND="
- ${COMMON_DEPEND}
- dedicated? (
- acct-group/openrct2
- acct-user/openrct2
- )
-"
-
-DEPEND="
- ${COMMON_DEPEND}
- test? ( dev-cpp/gtest )
-"
-
-BDEPEND="
- app-arch/unzip
- virtual/pkgconfig
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.2.4-include-additional-paths.patch"
- "${FILESDIR}/${PN}-0.2.6-gtest-1.10.patch"
-)
-
-src_unpack() {
- unpack "${P}".tar.gz
-
- mkdir -p "${S}"/data/sequence || die
- cd "${S}"/data/sequence || die
- unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip
-
- mkdir -p "${S}"/data/object || die
- cd "${S}"/data/object || die
- unpack "${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}".zip
-
- if use test; then
- mkdir -p "${S}"/testdata/replays || die
- cd "${S}"/testdata/replays || die
- unpack "${PN}-${MY_PN_RPL}-${MY_PV_RPL}".zip
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Don't treat warnings as errors.
- sed -e 's/-Werror//' -i CMakeLists.txt || die
-}
-
-src_configure() {
- # Note: There is currently no support for Disord-RPC and Google Benchmark,
- # as both packages do not exist in Gentoo, so support for them has been disabled.
- local mycmakeargs=(
- -DDISABLE_DISCORD_RPC=ON
- -DDISABLE_GOOGLE_BENCHMARK=ON
- -DDISABLE_GUI=$(usex dedicated)
- -DDISABLE_HTTP=OFF
- -DDISABLE_NETWORK=OFF
- $(usex !dedicated "-DDISABLE_OPENGL=$(usex !opengl)" "")
- -DDISABLE_TTF=$(usex !truetype)
- -DDOWNLOAD_OBJECTS=OFF
- -DDOWNLOAD_REPLAYS=OFF
- -DDOWNLOAD_TITLE_SEQUENCES=OFF
- -DENABLE_LIGHTFX=$(usex lightfx)
- -DENABLE_SCRIPTING=$(usex scripting)
- -DOPENRCT2_USE_CCACHE=OFF
- -DPORTABLE=OFF
- -DSTATIC=OFF
- $(usex test "-DSYSTEM_GTEST=ON" "")
- -DWITH_TESTS=$(usex test)
- -DUSE_MMAP=ON
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # Since the tests need the OpenRCT2 data,
- # we need to symlink them into the build directory,
- # otherwise some tests will fail, as they don't find the OpenRCT2 data.
- # It is currently not possible to override that path.
- # See: https://github.com/OpenRCT2/OpenRCT2/issues/6473
- ln -s "${S}"/data "${BUILD_DIR}" || die
-
- cmake_src_test
-}
-
-src_install() {
- use scripting && DOCS+=( "distribution/scripting.md" "distribution/openrct2.d.ts" )
-
- cmake_src_install
-
- if use dedicated; then
- newinitd "${FILESDIR}"/openrct2.initd openrct2
- newconfd "${FILESDIR}"/openrct2.confd openrct2
- fi
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
diff --git a/games-simulation/openrct2/openrct2-0.3.2-r1.ebuild b/games-simulation/openrct2/openrct2-0.3.2-r1.ebuild
index 5a1847da7c74..ab825ca0f215 100644
--- a/games-simulation/openrct2/openrct2-0.3.2-r1.ebuild
+++ b/games-simulation/openrct2/openrct2-0.3.2-r1.ebuild
@@ -24,7 +24,7 @@ SRC_URI="
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="dedicated libressl +lightfx +opengl scripting test +truetype"
COMMON_DEPEND="
diff --git a/media-gfx/krita/krita-4.4.1.ebuild b/media-gfx/krita/krita-4.4.1.ebuild
index 1b8485696af3..c33ac85cc1b7 100644
--- a/media-gfx/krita/krita-4.4.1.ebuild
+++ b/media-gfx/krita/krita-4.4.1.ebuild
@@ -13,7 +13,7 @@ inherit ecm kde.org python-single-r1
if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz
https://dev.gentoo.org/~asturm/distfiles/${PN}-4.2.9-patchset.tar.xz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~ppc64 ~x86"
fi
DESCRIPTION="Free digital painting application. Digital Painting, Creative Freedom!"
diff --git a/net-fs/samba/samba-4.12.9-r1.ebuild b/net-fs/samba/samba-4.12.9-r1.ebuild
index d71989170169..b68e9a0c85b6 100644
--- a/net-fs/samba/samba-4.12.9-r1.ebuild
+++ b/net-fs/samba/samba-4.12.9-r1.ebuild
@@ -15,7 +15,7 @@ SRC_PATH="stable"
SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
[[ ${PV} = *_rc* ]] || \
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ~ppc64 sparc x86"
DESCRIPTION="Samba Suite Version 4"
HOMEPAGE="https://www.samba.org/"
diff --git a/sci-calculators/galculator/galculator-2.1.4-r1.ebuild b/sci-calculators/galculator/galculator-2.1.4-r1.ebuild
index fc934979bf70..25e7913ad37d 100644
--- a/sci-calculators/galculator/galculator-2.1.4-r1.ebuild
+++ b/sci-calculators/galculator/galculator-2.1.4-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://galculator.mnim.org/downloads/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="
dev-libs/glib:2
diff --git a/sci-visualization/gnuplot/gnuplot-5.2.8-r1.ebuild b/sci-visualization/gnuplot/gnuplot-5.2.8-r1.ebuild
index 13e88a456a1d..83433aa7f6a1 100644
--- a/sci-visualization/gnuplot/gnuplot-5.2.8-r1.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.2.8-r1.ebuild
@@ -17,7 +17,7 @@ if [[ -z ${PV%%*9999} ]]; then
else
MY_P="${P/_/.}"
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="gnuplot"
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
index 52aaa1653ef6..170f9004ac00 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
@@ -19,7 +19,7 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/boot/syslinux/${SRC_URI_DIR}/${P
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~amd64 x86"
+KEYWORDS="-* amd64 x86"
IUSE="custom-cflags"
RDEPEND="sys-fs/mtools
diff --git a/sys-libs/ldb/ldb-2.1.4-r1.ebuild b/sys-libs/ldb/ldb-2.1.4-r1.ebuild
index 837fb552f8cb..5710d4163f57 100644
--- a/sys-libs/ldb/ldb-2.1.4-r1.ebuild
+++ b/sys-libs/ldb/ldb-2.1.4-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 sparc x86"
IUSE="doc +ldap +lmdb python test"
RESTRICT="!test? ( test )"
diff --git a/sys-libs/liburing/liburing-0.7-r1.ebuild b/sys-libs/liburing/liburing-0.7-r1.ebuild
index 284efb838d67..dc6b60760777 100644
--- a/sys-libs/liburing/liburing-0.7-r1.ebuild
+++ b/sys-libs/liburing/liburing-0.7-r1.ebuild
@@ -12,7 +12,7 @@ if [[ "${PV}" == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/axboe/liburing.git"
else
SRC_URI="https://git.kernel.dk/cgit/${PN}/snapshot/${P}.tar.bz2"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 sparc x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
fi
LICENSE="MIT"
SLOT="0/1.0.7" # liburing.so version
diff --git a/sys-libs/uid_wrapper/uid_wrapper-1.2.8.ebuild b/sys-libs/uid_wrapper/uid_wrapper-1.2.8.ebuild
index 65c553494e10..00c61d6d09c3 100644
--- a/sys-libs/uid_wrapper/uid_wrapper-1.2.8.ebuild
+++ b/sys-libs/uid_wrapper/uid_wrapper-1.2.8.ebuild
@@ -13,4 +13,4 @@ SRC_URI="https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
diff --git a/x11-libs/gl2ps/gl2ps-1.4.2.ebuild b/x11-libs/gl2ps/gl2ps-1.4.2.ebuild
index 757c951a3064..a327e3eb6720 100644
--- a/x11-libs/gl2ps/gl2ps-1.4.2.ebuild
+++ b/x11-libs/gl2ps/gl2ps-1.4.2.ebuild
@@ -10,7 +10,7 @@ SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 arm arm64 ~hppa ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc png zlib"
RDEPEND="
diff --git a/x11-plugins/purple-facebook/purple-facebook-20190113.ebuild b/x11-plugins/purple-facebook/purple-facebook-20190113.ebuild
index 5954a74a3264..d9c29b05113a 100644
--- a/x11-plugins/purple-facebook/purple-facebook-20190113.ebuild
+++ b/x11-plugins/purple-facebook/purple-facebook-20190113.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/dequis/${PN}/releases/download/v${MY_PV}/${PN}-${MY_
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE=""
RDEPEND="dev-libs/json-glib
diff --git a/x11-wm/icewm/icewm-1.9.2.ebuild b/x11-wm/icewm/icewm-1.9.2.ebuild
index 2397deb3594c..1c8dd43ca855 100644
--- a/x11-wm/icewm/icewm-1.9.2.ebuild
+++ b/x11-wm/icewm/icewm-1.9.2.ebuild
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
SLOT="0"
-KEYWORDS="~amd64 ppc sparc x86"
+KEYWORDS="amd64 ppc sparc x86"
IUSE="+alsa ao bidi debug +gdk-pixbuf nls truetype uclibc xinerama"
# Tests broken in all versions, patches welcome, bug #323907, #389533