summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-06-20 18:49:56 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-06-20 18:49:56 +0000
commit30c14f4e7207cb9414cb0e5bdb708628b7cd187f (patch)
tree2bbe2022be1e09e5eff205715fcfc7928c8940ae
parent2021-06-20 17:50:08 UTC (diff)
parentmedia-video/vlc: add 3.0.16 (diff)
downloadgentoo-30c14f4e7207cb9414cb0e5bdb708628b7cd187f.tar.gz
gentoo-30c14f4e7207cb9414cb0e5bdb708628b7cd187f.tar.bz2
gentoo-30c14f4e7207cb9414cb0e5bdb708628b7cd187f.zip
Merge updates from master
-rw-r--r--dev-libs/libconfig/Manifest1
-rw-r--r--dev-libs/libconfig/libconfig-1.7.3.ebuild51
-rw-r--r--dev-python/pytables/files/pytables-3.6.1-py310.patch49
-rw-r--r--dev-python/pytables/pytables-3.6.1.ebuild5
-rw-r--r--media-video/vlc/Manifest1
-rw-r--r--media-video/vlc/vlc-3.0.16.ebuild514
6 files changed, 619 insertions, 2 deletions
diff --git a/dev-libs/libconfig/Manifest b/dev-libs/libconfig/Manifest
index 87da50b902fc..7edd5b65cf05 100644
--- a/dev-libs/libconfig/Manifest
+++ b/dev-libs/libconfig/Manifest
@@ -1 +1,2 @@
DIST libconfig-1.7.2.tar.gz 3017891 BLAKE2B 1b8bc54857feff506d5cd62312a35f0f8a123380567881bdb8241f2232c5281399e4283687a3254b8f43a92b8f7d5ff3f72ec4fd875bf1b9d5d6c7703014cc3c SHA512 9df57355c2d08381b4a0a6366f0db3633fbe8f73c2bb8c370c040b0bae96ce89ee4ac6c17a5a247fed855d890fa383e5b70cb5573fc9cfc62194d5b94e161cee
+DIST libconfig-1.7.3.tar.gz 3026416 BLAKE2B 94301be4d6e472fc9daeac7a04074855737ddda94bb5748cd0087fafe192cf674ea1c020808ebf855372188b6b27a57ed185323fa26988bb1fccde0566617cba SHA512 3749bf9eb29bab0f6b14f4fc759f0c419ed27a843842aaabed1ec1fbe0faa8c93322ff875ca1291d69cb28a39ece86d512aec42c2140d566c38c56dc616734f4
diff --git a/dev-libs/libconfig/libconfig-1.7.3.ebuild b/dev-libs/libconfig/libconfig-1.7.3.ebuild
new file mode 100644
index 000000000000..a8f84e82f152
--- /dev/null
+++ b/dev-libs/libconfig/libconfig-1.7.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Libconfig is a simple library for manipulating structured configuration files"
+HOMEPAGE="
+ http://www.hyperrealm.com/libconfig/libconfig.html
+ https://github.com/hyperrealm/libconfig
+"
+SRC_URI="https://github.com/hyperrealm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/11"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+cxx static-libs"
+
+DEPEND="
+ sys-apps/texinfo
+ sys-devel/bison
+ sys-devel/libtool
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/sleep 3/d' \
+ configure.ac || die
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable cxx) \
+ $(use_enable static-libs static) \
+ --disable-examples
+}
+
+multilib_src_test() {
+ # It responds to check but that does not work as intended
+ emake test
+}
+
+multilib_src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-python/pytables/files/pytables-3.6.1-py310.patch b/dev-python/pytables/files/pytables-3.6.1-py310.patch
new file mode 100644
index 000000000000..600516d16396
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.6.1-py310.patch
@@ -0,0 +1,49 @@
+From 2431150d691f5ccdb3da204a46e346c156ea2523 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Mon, 16 Nov 2020 10:53:05 +0100
+Subject: [PATCH] doctest: adjust __init__ TypeError formatting
+
+Python3.10 includes the class name in the TypeError string for
+__init__(), so the literal match does not work anymore.
+---
+ tables/atom.py | 4 ++--
+ tables/filters.py | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tables/atom.py b/tables/atom.py
+index 81d37c54..9cfd8609 100644
+--- a/tables/atom.py
++++ b/tables/atom.py
+@@ -569,10 +569,10 @@ class Atom(metaclass=MetaAtom):
+ >>> atom3 = atom1.copy(shape=(2, 2))
+ >>> print(atom3)
+ Int32Atom(shape=(2, 2), dflt=0)
+- >>> atom1.copy(foobar=42)
++ >>> atom1.copy(foobar=42) #doctest: +ELLIPSIS
+ Traceback (most recent call last):
+ ...
+- TypeError: __init__() got an unexpected keyword argument 'foobar'
++ TypeError: ...__init__() got an unexpected keyword argument 'foobar'
+
+ """
+ newargs = self._get_init_args()
+diff --git a/tables/filters.py b/tables/filters.py
+index f809ce77..7cb9b02d 100644
+--- a/tables/filters.py
++++ b/tables/filters.py
+@@ -432,10 +432,10 @@ class Filters:
+ Filters(complevel=0, shuffle=False, bitshuffle=False, fletcher32=False, least_significant_digit=None)
+ >>> print(filters3)
+ Filters(complevel=1, complib='zlib', shuffle=False, bitshuffle=False, fletcher32=False, least_significant_digit=None)
+- >>> filters1.copy(foobar=42)
++ >>> filters1.copy(foobar=42) #doctest: +ELLIPSIS
+ Traceback (most recent call last):
+ ...
+- TypeError: __init__() got an unexpected keyword argument 'foobar'
++ TypeError: ...__init__() got an unexpected keyword argument 'foobar'
+
+ """
+
+--
+2.32.0
+
diff --git a/dev-python/pytables/pytables-3.6.1.ebuild b/dev-python/pytables/pytables-3.6.1.ebuild
index b504eaf8f32f..67448098a5b3 100644
--- a/dev-python/pytables/pytables-3.6.1.ebuild
+++ b/dev-python/pytables/pytables-3.6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
MY_PN=tables
@@ -46,6 +46,7 @@ DOCS=( RELEASE_NOTES.txt THANKS )
PATCHES=(
"${FILESDIR}"/${P}-numpy-float.patch
+ "${FILESDIR}"/${P}-py310.patch
)
python_prepare_all() {
@@ -64,7 +65,7 @@ python_compile() {
python_test() {
cd "${BUILD_DIR}"/lib* || die
- ${EPYTHON} tables/tests/test_all.py || die
+ "${EPYTHON}" tables/tests/test_all.py -v || die
}
python_install_all() {
diff --git a/media-video/vlc/Manifest b/media-video/vlc/Manifest
index 833e337cecd8..4b4d273cc4a6 100644
--- a/media-video/vlc/Manifest
+++ b/media-video/vlc/Manifest
@@ -2,3 +2,4 @@ DIST vlc-3.0-3.0.12.1.tar.gz 34233801 BLAKE2B 0bc571d8f3f8aa40eee93fe8ab13bd1f37
DIST vlc-3.0-3.0.13.tar.gz 34356102 BLAKE2B 93490278f47ab389c927a44bc84727b8067a9792e5621b3a9caa90c23a25ecb11244ebd62aa2dfb6d03df692c1ce3ae2aaec20aff001bb805f3965357298b4c9 SHA512 58439ef605ddc43aaf3fbd41715d3e341565590db3d73256ea3a977544f287d8f5001eb334a70674b707ccdc584125a24a3f320b3b4d166c01450d53741a4f85
DIST vlc-3.0-3.0.14.tar.gz 34355555 BLAKE2B e8182229da1fe4f73b640fad8005ec3fc49da70f289bd32c33fcec51bf81d393b067a795626bad57c87499e8de181ac3ce159e572431e794586753c4a7c32597 SHA512 6d366c0f17a8bda7f588ab1818d985bccd076dd821bc83dd7d06827d463931e56cb06ca934622ee2cda4a76b0fbe265a66e4566e9307abc768b76174020f0150
DIST vlc-3.0.15.tar.xz 26436344 BLAKE2B 42e20e8bbd2af79a63d261c3b376ff974a38e8d5376a3998e4759584f4e791a1d0c2827268055ec36a792980c74cf39a749770b2d1a31e15d3cff721a855851c SHA512 4645d7e9cc894ddf4c1776fe15124b1c123c3860f6dceec7bc0087a37a6e98f62e35856cdb59f8759b8f4aeea766b25c9a7767b65f1be8bb9ee23c71376cd914
+DIST vlc-3.0.16.tar.xz 26439328 BLAKE2B 1971b88f3faf6d3b019c3fcb83108242bb218f1472dc3c1763a8eaa996befcb36a685a75beb8c2513e3365e77a9df6623d194ef511b5271e3114f2f46588e1ff SHA512 35cdf191071224d0cf1b5a83c00773ff87b9e5bfcf0f5523f7edd53f75b23eda6b27bb49ffa97d69a1d176b8fe4786d959aeeb00d4380beab71c9f7e6b7c7298
diff --git a/media-video/vlc/vlc-3.0.16.ebuild b/media-video/vlc/vlc-3.0.16.ebuild
new file mode 100644
index 000000000000..8d7b04a4384d
--- /dev/null
+++ b/media-video/vlc/vlc-3.0.16.ebuild
@@ -0,0 +1,514 @@
+# Copyright 2000-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..2} )
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/-beta/-test}"
+MY_P="${PN}-${MY_PV}"
+if [[ ${PV} = *9999 ]] ; then
+ if [[ ${PV%.9999} != ${PV} ]] ; then
+ EGIT_REPO_URI="https://git.videolan.org/git/vlc/vlc-${PV%.9999}.git"
+ else
+ EGIT_REPO_URI="https://git.videolan.org/git/vlc.git"
+ fi
+ inherit git-r3
+else
+ SRC_URI="https://get.videolan.org/vlc/${PV}/${P}.tar.xz"
+ #S="${WORKDIR}/${PN}-$(ver_cut 1-2)-${PV}"
+ #SRC_URI="https://code.videolan.org/videolan/vlc-$(ver_cut 1-2)/-/archive/${PV}/vlc-$(ver_cut 1-2)-${PV}.tar.gz"
+ #if [[ ${MY_P} = ${P} ]] ; then
+ # SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
+ #else
+ # SRC_URI="https://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.xz"
+ #fi
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -sparc ~x86"
+fi
+
+inherit autotools flag-o-matic lua-single toolchain-funcs virtualx xdg
+
+DESCRIPTION="Media player and framework with support for most multimedia files and streaming"
+HOMEPAGE="https://www.videolan.org/vlc/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0/5-9" # vlc - vlccore
+
+IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast
+ dav1d dbus dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac
+ fluidsynth fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate
+ libass libcaca libnotify +libsamplerate libtar libtiger linsys lirc
+ live lua macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
+ nfs ogg omxil optimisememory opus png projectm pulseaudio +qt5 rdp
+ run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl svg taglib
+ theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vpx wayland +X
+ x264 x265 xml zeroconf zvbi cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_mmx
+ cpu_flags_x86_sse
+"
+REQUIRED_USE="
+ chromecast? ( encode )
+ directx? ( ffmpeg )
+ fontconfig? ( truetype )
+ libcaca? ( X )
+ libtar? ( skins )
+ libtiger? ( kate )
+ lua? ( ${LUA_REQUIRED_USE} )
+ skins? ( qt5 truetype X xml )
+ ssl? ( gcrypt )
+ vaapi? ( ffmpeg X )
+ vdpau? ( ffmpeg X )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ lua? ( ${LUA_DEPS} )
+ amd64? ( dev-lang/yasm )
+ x86? ( dev-lang/yasm )
+"
+RDEPEND="
+ media-libs/libvorbis
+ net-dns/libidn:=
+ sys-libs/zlib[minizip]
+ virtual/libintl
+ virtual/opengl
+ a52? ( media-libs/a52dec )
+ alsa? ( media-libs/alsa-lib )
+ aom? ( media-libs/libaom:= )
+ archive? ( app-arch/libarchive:= )
+ aribsub? ( media-libs/aribb24 )
+ bidi? (
+ dev-libs/fribidi
+ media-libs/freetype:2[harfbuzz]
+ media-libs/harfbuzz
+ virtual/ttf-fonts
+ )
+ bluray? ( >=media-libs/libbluray-1.3.0:= )
+ cddb? ( media-libs/libcddb )
+ chromaprint? ( media-libs/chromaprint:= )
+ chromecast? (
+ >=dev-libs/protobuf-2.5.0:=
+ >=net-libs/libmicrodns-0.1.2:=
+ )
+ dav1d? ( media-libs/dav1d:= )
+ dbus? ( sys-apps/dbus )
+ dc1394? (
+ media-libs/libdc1394:2
+ sys-libs/libraw1394
+ )
+ dts? ( media-libs/libdca )
+ dvbpsi? ( >=media-libs/libdvbpsi-1.2.0:= )
+ dvd? (
+ >=media-libs/libdvdnav-6.1.1:0=
+ >=media-libs/libdvdread-6.1.2:0=
+ )
+ faad? ( media-libs/faad2 )
+ fdk? ( media-libs/fdk-aac:= )
+ ffmpeg? ( >=media-video/ffmpeg-3.1.3:0=[postproc,vaapi?,vdpau?] )
+ flac? (
+ media-libs/flac
+ media-libs/libogg
+ )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ fontconfig? ( media-libs/fontconfig:1.0 )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gme? ( media-libs/game-music-emu )
+ gnome-keyring? ( app-crypt/libsecret )
+ gstreamer? ( >=media-libs/gst-plugins-base-1.4.5:1.0 )
+ ieee1394? (
+ sys-libs/libavc1394
+ sys-libs/libraw1394
+ )
+ jack? ( virtual/jack )
+ jpeg? ( virtual/jpeg:0 )
+ kate? ( media-libs/libkate )
+ libass? (
+ media-libs/fontconfig:1.0
+ media-libs/libass:=
+ )
+ libcaca? ( media-libs/libcaca )
+ libnotify? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ )
+ libsamplerate? ( media-libs/libsamplerate )
+ libtar? ( dev-libs/libtar )
+ libtiger? ( media-libs/libtiger )
+ linsys? ( media-libs/zvbi )
+ lirc? ( app-misc/lirc )
+ live? ( media-plugins/live:= )
+ lua? ( ${LUA_DEPS} )
+ mad? ( media-libs/libmad )
+ matroska? (
+ >=dev-libs/libebml-1.4.2:=
+ media-libs/libmatroska:=
+ )
+ modplug? ( >=media-libs/libmodplug-0.8.9.0 )
+ mp3? ( media-sound/mpg123 )
+ mpeg? ( media-libs/libmpeg2 )
+ mtp? ( media-libs/libmtp:= )
+ musepack? ( media-sound/musepack-tools )
+ ncurses? ( sys-libs/ncurses:0=[unicode] )
+ nfs? ( >=net-fs/libnfs-0.10.0:= )
+ ogg? ( media-libs/libogg )
+ opus? ( >=media-libs/opus-1.0.3 )
+ png? ( media-libs/libpng:0= )
+ projectm? (
+ media-fonts/dejavu
+ media-libs/libprojectm:0=
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )
+ )
+ rdp? ( >=net-misc/freerdp-2.0.0_rc0:=[client(+)] )
+ samba? ( >=net-fs/samba-4.0.0:0[client,-debug(-)] )
+ sdl-image? ( media-libs/sdl-image )
+ sftp? ( net-libs/libssh2 )
+ shout? ( media-libs/libshout )
+ sid? ( media-libs/libsidplay:2 )
+ skins? (
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXpm
+ )
+ soxr? ( >=media-libs/soxr-0.1.2 )
+ speex? (
+ >=media-libs/speex-1.2.0
+ media-libs/speexdsp
+ )
+ srt? ( >=net-libs/srt-1.4.2 )
+ ssl? ( net-libs/gnutls:= )
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )
+ taglib? ( >=media-libs/taglib-1.9 )
+ theora? ( media-libs/libtheora )
+ tremor? ( media-libs/tremor )
+ truetype? (
+ media-libs/freetype:2
+ virtual/ttf-fonts
+ !fontconfig? ( media-fonts/dejavu )
+ )
+ twolame? ( media-sound/twolame )
+ udev? ( virtual/udev )
+ upnp? ( net-libs/libupnp:=[ipv6] )
+ v4l? ( media-libs/libv4l:= )
+ vaapi? ( x11-libs/libva:=[drm,wayland?,X?] )
+ vdpau? ( x11-libs/libvdpau )
+ vnc? ( net-libs/libvncserver )
+ vpx? ( media-libs/libvpx:= )
+ wayland? (
+ >=dev-libs/wayland-1.15
+ dev-libs/wayland-protocols
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-keysyms
+ )
+ x264? ( >=media-libs/x264-0.0.20190214:= )
+ x265? ( media-libs/x265:= )
+ xml? ( dev-libs/libxml2:2 )
+ zeroconf? ( net-dns/avahi[dbus] )
+ zvbi? ( media-libs/zvbi )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-fix-libtremor-libs.patch # build system
+ "${FILESDIR}"/${PN}-2.2.8-freerdp-2.patch # bug 590164
+ "${FILESDIR}"/${PN}-3.0.6-fdk-aac-2.0.0.patch # bug 672290
+ "${FILESDIR}"/${PN}-3.0.11.1-configure_lua_version.patch
+ "${FILESDIR}"/${PN}-3.0.11.1-srt-1.4.2.patch # bug 758062
+ "${FILESDIR}"/${PN}-3.0.13-srt-1.3.0.patch
+)
+
+DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
+
+pkg_setup() {
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ xdg_src_prepare # bug 608256
+
+ has_version 'net-libs/libupnp:1.8' && \
+ eapply "${FILESDIR}"/${PN}-2.2.8-libupnp-slot-1.8.patch
+
+ # Bootstrap when we are on a git checkout.
+ if [[ ${PV} = *9999 ]] ; then
+ ./bootstrap
+ fi
+
+ # Make it build with libtool 1.5
+ #rm m4/lt* m4/libtool.m4 || die
+
+ # We are not in a real git checkout due to the absence of a .git directory.
+ touch src/revision.txt || die
+
+ # Don't use --started-from-file when not using dbus.
+ if ! use dbus ; then
+ sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
+ fi
+
+ # Disable running of vlc-cache-gen, we do that in pkg_postinst
+ sed -e "/test.*build.*host/s/\$(host)/nothanks/" \
+ -i Makefile.am -i bin/Makefile.am || die "Failed to disable vlc-cache-gen"
+
+ # Fix gettext version mismatch errors.
+ sed -i -e s/GETTEXT_VERSION/GETTEXT_REQUIRE_VERSION/ configure.ac || die
+
+ eautoreconf
+
+ # Disable automatic running of tests.
+ find . -name 'Makefile.in' -exec sed -i 's/\(..*\)check-TESTS/\1/' {} \; || die
+}
+
+src_configure() {
+ local -x BUILDCC=$(tc-getBUILD_CC)
+
+ local myeconfargs=(
+ --disable-aa
+ --disable-optimizations
+ --disable-rpath
+ --disable-update-check
+ --enable-fast-install
+ --enable-screen
+ --enable-vcd
+ --enable-vlc
+ --enable-vorbis
+ $(use_enable a52)
+ $(use_enable alsa)
+ $(use_enable aom)
+ $(use_enable archive)
+ $(use_enable aribsub)
+ $(use_enable bidi fribidi)
+ $(use_enable bidi harfbuzz)
+ $(use_enable bluray)
+ $(use_enable cddb libcddb)
+ $(use_enable chromaprint)
+ $(use_enable chromecast)
+ $(use_enable chromecast microdns)
+ $(use_enable cpu_flags_arm_neon neon)
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable dav1d)
+ $(use_enable dbus)
+ $(use_enable dbus kwallet)
+ $(use_enable dc1394)
+ $(use_enable debug)
+ $(use_enable directx)
+ $(use_enable directx d3d11va)
+ $(use_enable directx dxva2)
+ $(use_enable dts dca)
+ $(use_enable dvbpsi)
+ $(use_enable dvd dvdnav)
+ $(use_enable dvd dvdread)
+ $(use_enable encode sout)
+ $(use_enable encode vlm)
+ $(use_enable faad)
+ $(use_enable fdk fdkaac)
+ $(use_enable ffmpeg avcodec)
+ $(use_enable ffmpeg avformat)
+ $(use_enable ffmpeg postproc)
+ $(use_enable ffmpeg swscale)
+ $(use_enable flac)
+ $(use_enable fluidsynth)
+ $(use_enable fontconfig)
+ $(use_enable gcrypt libgcrypt)
+ $(use_enable gme)
+ $(use_enable gnome-keyring secret)
+ $(use_enable gstreamer gst-decode)
+ $(use_enable ieee1394 dv1394)
+ $(use_enable jack)
+ $(use_enable jpeg)
+ $(use_enable kate)
+ $(use_enable libass)
+ $(use_enable libcaca caca)
+ $(use_enable libnotify notify)
+ $(use_enable libsamplerate samplerate)
+ $(use_enable libtar)
+ $(use_enable libtiger tiger)
+ $(use_enable linsys)
+ $(use_enable lirc)
+ $(use_enable live live555)
+ $(use_enable lua)
+ $(use_enable macosx-notifications osx-notifications)
+ $(use_enable mad)
+ $(use_enable matroska)
+ $(use_enable modplug mod)
+ $(use_enable mp3 mpg123)
+ $(use_enable mpeg libmpeg2)
+ $(use_enable mtp)
+ $(use_enable musepack mpc)
+ $(use_enable ncurses)
+ $(use_enable nfs)
+ $(use_enable ogg)
+ $(use_enable omxil)
+ $(use_enable omxil omxil-vout)
+ $(use_enable optimisememory optimize-memory)
+ $(use_enable opus)
+ $(use_enable png)
+ $(use_enable projectm)
+ $(use_enable pulseaudio pulse)
+ $(use_enable qt5 qt)
+ $(use_enable rdp freerdp)
+ $(use_enable run-as-root)
+ $(use_enable samba smbclient)
+ $(use_enable sdl-image)
+ $(use_enable sftp)
+ $(use_enable shout)
+ $(use_enable sid)
+ $(use_enable skins skins2)
+ $(use_enable soxr)
+ $(use_enable speex)
+ $(use_enable srt)
+ $(use_enable ssl gnutls)
+ $(use_enable svg)
+ $(use_enable svg svgdec)
+ $(use_enable taglib)
+ $(use_enable theora)
+ $(use_enable tremor)
+ $(use_enable twolame)
+ $(use_enable udev)
+ $(use_enable upnp)
+ $(use_enable v4l v4l2)
+ $(use_enable vaapi libva)
+ $(use_enable vdpau)
+ $(use_enable vnc)
+ $(use_enable vpx)
+ $(use_enable wayland)
+ $(use_with X x)
+ $(use_enable X xcb)
+ $(use_enable X xvideo)
+ $(use_enable x264)
+ $(use_enable x264 x26410b)
+ $(use_enable x265)
+ $(use_enable xml libxml2)
+ $(use_enable zeroconf avahi)
+ $(use_enable zvbi)
+ $(use_enable !zvbi telx)
+ --with-kde-solid="${EPREFIX}"/usr/share/solid/actions
+ --disable-asdcp
+ --disable-coverage
+ --disable-cprof
+ --disable-crystalhd
+ --disable-decklink
+ --disable-gles2
+ --disable-goom
+ --disable-kai
+ --disable-kva
+ --disable-libplacebo
+ --disable-maintainer-mode
+ --disable-merge-ffmpeg
+ --disable-mfx
+ --disable-mmal
+ --disable-opencv
+ --disable-opensles
+ --disable-oss
+ --disable-rpi-omxil
+ --disable-schroedinger
+ --disable-shine
+ --disable-sndio
+ --disable-spatialaudio
+ --disable-vsxu
+ --disable-wasapi
+ --disable-wma-fixed
+ )
+ # ^ We don't have these disabled libraries in the Portage tree yet.
+
+ # Compatibility fix for Samba 4.
+ use samba && append-cppflags "-I/usr/include/samba-4.0"
+
+ if use x86; then
+ # We need to disable -fstack-check if use >=gcc 4.8.0. bug #499996
+ append-cflags $(test-flags-CC -fno-stack-check)
+ # Bug 569774
+ replace-flags -Os -O2
+ fi
+
+ # VLC now requires C++11 after commit 4b1c9dcdda0bbff801e47505ff9dfd3f274eb0d8
+ append-cxxflags -std=c++11
+
+ if use omxil; then
+ # bug #723006
+ # https://trac.videolan.org/vlc/ticket/24617
+ append-cflags -fcommon
+ fi
+
+ # FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
+ append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
+
+ if use truetype || use bidi; then
+ myeconfargs+=( --enable-freetype )
+ else
+ myeconfargs+=( --disable-freetype )
+ fi
+
+ if use truetype || use projectm; then
+ local dejavu="${EPREFIX}/usr/share/fonts/dejavu/"
+ myeconfargs+=(
+ --with-default-font=${dejavu}/DejaVuSans.ttf
+ --with-default-font-family=Sans
+ --with-default-monospace-font=${dejavu}/DejaVuSansMono.ttf
+ --with-default-monospace-font-family=Monospace
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+
+ # _FORTIFY_SOURCE is set to 2 in config.h, which is also the default value on Gentoo.
+ # Other values may break the build (bug 523144), so definition should not be removed.
+ # To prevent redefinition warnings, we undefine _FORTIFY_SOURCE at the start of config.h
+ sed -i '1i#undef _FORTIFY_SOURCE' config.h || die
+}
+
+src_test() {
+ virtx emake check-TESTS
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EROOT}/usr/$(get_libdir)/vlc/vlc-cache-gen" ]] ; then
+ einfo "Running ${EROOT}/usr/$(get_libdir)/vlc/vlc-cache-gen on ${EROOT}/usr/$(get_libdir)/vlc/plugins/"
+ "${EROOT}/usr/$(get_libdir)/vlc/vlc-cache-gen" "${EROOT}/usr/$(get_libdir)/vlc/plugins/"
+ else
+ ewarn "We cannot run vlc-cache-gen (most likely ROOT != /)"
+ ewarn "Please run ${EROOT}/usr/$(get_libdir)/vlc/vlc-cache-gen manually"
+ ewarn "If you do not do it, vlc will take a long time to load."
+ fi
+
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ if [[ -e "${EROOT}"/usr/$(get_libdir)/vlc/plugins/plugins.dat ]]; then
+ rm "${EROOT}"/usr/$(get_libdir)/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ fi
+
+ xdg_pkg_postrm
+}