summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-10 18:07:22 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-10 19:11:50 +0200
commit1f86949a3e0354acef3bcd5d903b6be2ea27d80a (patch)
treeda323a93734af0f6d3e36e211a520a2facb81cc5
parentdev-python/readme_renderer: add 31.0 (diff)
downloadgentoo-1f86949a3e0354acef3bcd5d903b6be2ea27d80a.tar.gz
gentoo-1f86949a3e0354acef3bcd5d903b6be2ea27d80a.tar.bz2
gentoo-1f86949a3e0354acef3bcd5d903b6be2ea27d80a.zip
dev-python/pytest-forked: add 1.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytest-forked/Manifest1
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index a2424b371d55..a0ca355af796 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1 +1,2 @@
DIST pytest-forked-1.3.0.tar.gz 9850 BLAKE2B cbe44d87052c5a3bc58934ac17153401810004aaa38b53ff3100384535cb2ea0fa99dada706113f324fa0a135ddbd9b97488319b4a9554d912388c341b62943c SHA512 25d639aa43380155d7744f1d05a95e0144f5fe7dea42ff3c2bba3803a07d73b5eb008525469330c5dda14800fe4b611241691be197132f31f88f66930c3ecac0
+DIST pytest-forked-1.4.0.tar.gz 10197 BLAKE2B 7a6ec42f7ad1323eea243739a9186fb87eac3016afef844ec39a6e3fd55f7d40b1410fcc27074624f8468e6dabddffcc22ea0597bbbd898fab71c82c06e25b46 SHA512 ba402aec6dbec7a94815913192a49390b637a123d3557f48d809ae2e871e9e0cff8f9d0feb99e2bd06fe9486520b5e539f397d39475a720f8283b1bd21c751c7
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
new file mode 100644
index 000000000000..c65d14f14759
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
+RDEPEND="dev-python/py[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ epytest -p no:flaky
+}