summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-09-27 11:55:11 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-27 11:55:11 +0200
commit1053a057f3af62989c9f20d67f100f3d83b7679c (patch)
tree5b285b7064a6865dc0a4b244d33aaad6f91a0aa7
parentsci-geosciences/gpxsee: remove old version (diff)
downloadgentoo-1053a057f3af62989c9f20d67f100f3d83b7679c.tar.gz
gentoo-1053a057f3af62989c9f20d67f100f3d83b7679c.tar.bz2
gentoo-1053a057f3af62989c9f20d67f100f3d83b7679c.zip
net-vpn/vpnc: add 0.5.3_p20220927
Closes: https://bugs.gentoo.org/870727 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-vpn/vpnc/Manifest2
-rw-r--r--net-vpn/vpnc/vpnc-0.5.3_p20220927.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/net-vpn/vpnc/Manifest b/net-vpn/vpnc/Manifest
index 8048d237274f..b7de56d3af33 100644
--- a/net-vpn/vpnc/Manifest
+++ b/net-vpn/vpnc/Manifest
@@ -1 +1,3 @@
+DIST vpnc-0.5.3-docs.tar.xz 4816 BLAKE2B fe972fb71e74dea481593ce42225a2969608dd4d29a2f34ca1f7b5b82a71a62bfbd94d5fcd2e8db830768be1e858682904e655b8629cb164961644bc5de291e1 SHA512 e3e9f3e3651906f41a4a6b0f4247b903fb555155cbda210823f36a5613d8390b6aad7615ff88fd627ece4037b0e0f04753ac924c9cd9c1335480ca8186d476b8
+DIST vpnc-0.5.3_p20220927.tar.gz 119773 BLAKE2B 0dabadac8b5a8116c07597140b6fa31e8f7daed9448e1bf653491809453ec114c0e96d38a8103d90a8b68dd2cefa0540ed676ced3fb9d57eaf16d8be5e3f0fa1 SHA512 e8c2254042c67283749331349467b2aed29ececc26de0bc3227c9c4a14f06d9d518599b28ca979df0cbe997c8997dda8afa508a0858c80ec270922096d8f906f
DIST vpnc-0.5.3_p550-r2.tar.gz 133339 BLAKE2B d4f09a62edbe3b4014c4903d908eecf27ee09705017f715aadc869592fb80d7f4482f08e4681dd9e9c22ae16ae185404e09572800de8cb76419c20f5bf8e17d1 SHA512 3adaf4c73c14c328ca9702c1e3d3c333b0a589f99b52990febf7b22ac87f666f1fc0a1d62e9831ec645567ca01425ea476a7bb62fee214012c97651e0e99b732
diff --git a/net-vpn/vpnc/vpnc-0.5.3_p20220927.ebuild b/net-vpn/vpnc/vpnc-0.5.3_p20220927.ebuild
new file mode 100644
index 000000000000..d62312b59c91
--- /dev/null
+++ b/net-vpn/vpnc/vpnc-0.5.3_p20220927.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="https://www.unix-ag.uni-kl.de/~massar/vpnc/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/streambinder/vpnc.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="
+ https://api.github.com/repos/streambinder/vpnc/tarball/fdd0de7 -> ${P}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${PN}-0.5.3-docs.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="resolvconf +gnutls selinux"
+RESTRICT="!gnutls? ( bindist )"
+
+DEPEND="
+ dev-libs/libgcrypt:=
+ sys-apps/iproute2[-minimal]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}
+ >=net-vpn/vpnc-scripts-20210402-r1
+ resolvconf? ( virtual/resolvconf )
+ selinux? ( sec-policy/selinux-vpn )"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~TUN"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ else
+ vcs-snapshot_src_unpack
+ mv vpnc-0.5.3-docs/src/doc/*.md "${S}"/src/doc/ || die
+ fi
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+ export OPENSSL_GPL_VIOLATION=$(usex !gnutls)
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DOCDIR='$(PREFIX)'/share/doc/${PF} DESTDIR="${D}" install
+
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}"/vpnc-3.init vpnc
+ newconfd "${FILESDIR}"/vpnc.confd vpnc
+
+ dotmpfiles "${FILESDIR}"/vpnc-tmpfiles.conf
+ systemd_newunit "${FILESDIR}"/vpnc.service vpnc@.service
+
+ # LICENSE file resides here, should not be installed
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ tmpfiles_process vpnc-tmpfiles.conf
+
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is available at https://wiki.gentoo.org/wiki/Vpnc"
+
+ if use gnutls; then
+ elog "Will build with GnuTLS (default) instead of OpenSSL so you may even redistribute binaries."
+ elog "See the Makefile itself and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ else
+ ewarn "Building SSL support with OpenSSL instead of GnuTLS. This means that"
+ ewarn "you are not allowed to re-distibute the binaries due to conflicts between BSD license and GPL,"
+ ewarn "see the vpnc Makefile and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ fi
+}