summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-09-17 16:05:21 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-09-17 16:05:21 +0000
commit068f3bf7e16c94246aaa1ece5005ceb4af1de811 (patch)
treef8095a05ea5ca73438b5163c5f76bb17066264c9
parent2020-09-17 15:35:38 UTC (diff)
parentsys-libs/libixp: Port to EAPI 7 (diff)
downloadgentoo-068f3bf7e16c94246aaa1ece5005ceb4af1de811.tar.gz
gentoo-068f3bf7e16c94246aaa1ece5005ceb4af1de811.tar.bz2
gentoo-068f3bf7e16c94246aaa1ece5005ceb4af1de811.zip
Merge updates from master
-rw-r--r--sys-libs/libixp/files/libixp-0.5_p20110208-gentoo.patch40
-rw-r--r--sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild37
-rw-r--r--www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild35
-rw-r--r--www-apps/blazeblogger/files/blazeblogger-1.2.0-makefile.patch11
4 files changed, 87 insertions, 36 deletions
diff --git a/sys-libs/libixp/files/libixp-0.5_p20110208-gentoo.patch b/sys-libs/libixp/files/libixp-0.5_p20110208-gentoo.patch
new file mode 100644
index 000000000000..dbe101acef89
--- /dev/null
+++ b/sys-libs/libixp/files/libixp-0.5_p20110208-gentoo.patch
@@ -0,0 +1,40 @@
+--- a/cmd/ixpc.c
++++ b/cmd/ixpc.c
+@@ -10,6 +10,8 @@
+ #include <unistd.h>
+ #include <ixp_local.h>
+
++char *argv0;
++
+ /* Temporary */
+ #define fatal(...) ixp_eprint("ixpc: fatal: " __VA_ARGS__); \
+
+--- a/include/ixp.h
++++ b/include/ixp.h
+@@ -66,13 +66,13 @@
+
+ typedef unsigned char uchar;
+ typedef uint16_t ushort;
+-typedef uint32_t ulong;
++typedef unsigned long ulong;
+ typedef uint64_t uvlong;
+
+ typedef int64_t vlong;
+
+ # define respond ixp_respond
+-# define serve_9pcon ixp_serve9pconn
++# define serve_9pcon ixp_serve9conn
+ #endif
+
+ #undef uint
+--- a/include/ixp_local.h
++++ b/include/ixp_local.h
+@@ -12,7 +12,7 @@
+ typedef char* va_list;
+ #endif
+
+-char *argv0;
++extern char *argv0;
+ #define ARGBEGIN \
+ int _argtmp=0, _inargv=0; char *_argv=nil; \
+ if(!argv0) {argv0=*argv; argv++, argc--;} \
diff --git a/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild b/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild
index 8c7dc645c040..bd8a54c6e054 100644
--- a/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild
+++ b/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# hg clone https://hg.suckless.org/libixp
+EAPI=7
-EAPI=4
-inherit multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A stand-alone client/server 9P library including ixpc client"
HOMEPAGE="https://libs.suckless.org/deprecated/libixp"
@@ -13,29 +12,25 @@ SRC_URI="mirror://gentoo/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="app-arch/xz-utils"
+PATCHES=(
+ # https://code.google.com/p/libixp/issues/detail?id=2
+ # https://code.google.com/p/wmii/issues/detail?id=247
+ # https://bugs.gentoo.org/393299
+ "${FILESDIR}"/${P}-gentoo.patch
+)
-pkg_setup() {
+src_configure() {
myixpconf=(
- PREFIX="/usr"
- LIBDIR="/usr/$(get_libdir)"
+ PREFIX="${EPREFIX}"/usr
+ LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ LIBS=
CC="$(tc-getCC) -c"
LD="$(tc-getCC) ${LDFLAGS}"
AR="$(tc-getAR) crs"
- MAKESO="1"
+ MAKESO=1
SOLDFLAGS="-shared"
- )
-}
-
-src_prepare() {
- # https://code.google.com/p/libixp/issues/detail?id=2
- sed -i -e 's:ixp_serve9pconn:ixp_serve9conn:' include/ixp.h || die
-
- # https://bugs.gentoo.org/393299 https://code.google.com/p/wmii/issues/detail?id=247
- sed -i -e '69s:uint32_t:unsigned long:' include/ixp.h || die
+ )
}
src_compile() {
@@ -45,5 +40,5 @@ src_compile() {
src_install() {
emake "${myixpconf[@]}" DESTDIR="${D}" install
dolib.so lib/libixp{,_pthread}.so
- dodoc NEWS
+ einstalldocs
}
diff --git a/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild b/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
index 798b095bb8bc..0c268da869c0 100644
--- a/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
+++ b/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils
+inherit bash-completion-r1
DESCRIPTION="Simple, capable content management system for producing static content"
HOMEPAGE="http://blaze.blackened.cz/"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz
+SRC_URI="
+ https://${PN}.googlecode.com/files/${P}.tar.gz
doc? ( https://${PN}.googlecode.com/files/${PN}-doc-${PV}.tar.gz ) "
LICENSE="FDL-1.3 GPL-3"
@@ -18,17 +19,21 @@ IUSE="doc"
RDEPEND="dev-lang/perl"
DEPEND="${RDEPEND}"
-src_prepare() {
- sed -e '/-m 644 COPYING/d' \
- -e '/-m 644 INSTALL/d' \
- -i Makefile || die
-
- epatch "${FILESDIR}"/${P}-bash-completion.patch #bug 417953
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-bash-completion.patch #bug 417953
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_install() {
- emake prefix="${D}/usr" config="${D}/etc" \
- compdir="${D}/usr/share/bash-completion" install
-
- use doc && dohtml -r "${WORKDIR}"/${PN}-doc-${PV}/*
+ emake \
+ prefix="${ED}"/usr \
+ config="${ED}"/etc \
+ compdir="${D}"/$(get_bashcompdir) \
+ docsdir="${ED}"/usr/share/doc/${PF} \
+ install
+
+ if use doc; then
+ docinto html
+ dodoc -r "${WORKDIR}"/${PN}-doc-${PV}/.
+ fi
}
diff --git a/www-apps/blazeblogger/files/blazeblogger-1.2.0-makefile.patch b/www-apps/blazeblogger/files/blazeblogger-1.2.0-makefile.patch
new file mode 100644
index 000000000000..6fde1018c2d2
--- /dev/null
+++ b/www-apps/blazeblogger/files/blazeblogger-1.2.0-makefile.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -84,8 +84,6 @@
+ $(INSTALL) -m 644 TODO $(docsdir)
+ $(INSTALL) -m 644 README $(docsdir)
+ $(INSTALL) -m 644 AUTHORS $(docsdir)
+- $(INSTALL) -m 644 COPYING $(docsdir)
+- $(INSTALL) -m 644 INSTALL $(docsdir)
+ -$(INSTALL) -m 644 ChangeLog $(docsdir)
+
+ install_man: $(MAN1)