From 38554798288b66be3a6307200f9403c8031e2330 Mon Sep 17 00:00:00 2001
From: Carter Wobbe <it.a.me.oss@gmail.com>
Date: Thu, 26 Sep 2024 18:09:58 -0700
Subject: dev-lang/odin: add 2024.09

Signed-off-by: Carter Wobbe <it.a.me.oss@gmail.com>
---
 dev-lang/odin/Manifest            |  1 +
 dev-lang/odin/odin-2024.09.ebuild | 51 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 52 insertions(+)
 create mode 100644 dev-lang/odin/odin-2024.09.ebuild

(limited to 'dev-lang')

diff --git a/dev-lang/odin/Manifest b/dev-lang/odin/Manifest
index 1556ad6fa..6af5a385b 100644
--- a/dev-lang/odin/Manifest
+++ b/dev-lang/odin/Manifest
@@ -1 +1,2 @@
 DIST dev-2024-08.tar.gz 131294520 BLAKE2B f36029cb284d171fdf9b89591dabcc4f9ac0f9b7864fa8f66bc28ba733ade78e016c665f96be65568bd7be360f82af6a52344922caf9a9ecc27cbf10908b24ab SHA512 b151dec0dd0f863c93e6c49f9cae45769c0386733b91e962163c55c4d6cc6e794b772c6c47f91b78f84cddb6572e91c37cac31a47df6a86bf39fdb901b657930
+DIST dev-2024-09.tar.gz 135412805 BLAKE2B 04bcefb3ca7a38fe1f30722a83f42751617c038d0d224147b5b91cb54473d0a8ab3d726c6693f2f686455423ec9f29501271aec681e31588f3e9c9f7cc96e5c1 SHA512 47421178fdf48a70eac585b3dc165046d2c0f21d1208f47acead37e93b97b94ff4ba716c907a5958d5c3b992b04df5f7b4a29dc03adba08020da6a0620cd0c87
diff --git a/dev-lang/odin/odin-2024.09.ebuild b/dev-lang/odin/odin-2024.09.ebuild
new file mode 100644
index 000000000..7f1fc8e7c
--- /dev/null
+++ b/dev-lang/odin/odin-2024.09.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=(14 17 18)
+inherit llvm-r1
+
+DESCRIPTION="The Data-Oriented Language for Sane Software Development."
+
+HOMEPAGE="https://odin-lang.org/"
+
+MY_PV="${PV/./-}"
+SRC_URI="https://github.com/odin-lang/Odin/archive/refs/tags/dev-${MY_PV}.tar.gz"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+S="${WORKDIR}/Odin-dev-${MY_PV}"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND="
+$(llvm_gen_dep "
+sys-devel/clang:${LLVM_SLOT}=
+sys-devel/llvm:${LLVM_SLOT}=
+")
+"
+
+DEPEND="${RDEPEND}"
+
+# build_odin.sh sets its own flags. Some gcc flags cause build failures
+CPPFLAGS=""
+CXXFLAGS=""
+src_compile() {
+	./build_odin.sh release || die "failed to build odin"
+}
+
+src_install() {
+	insinto usr/lib/odin
+	exeinto usr/lib/odin
+
+	doexe odin
+	doins -r base core vendor
+	dosym -r /usr/lib/odin/odin /usr/bin/odin
+}
-- 
cgit v1.2.3-65-gdbad