aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/pipectl/pipectl-0.5.0.ebuild')
-rw-r--r--sys-process/pipectl/pipectl-0.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/pipectl/pipectl-0.5.0.ebuild b/sys-process/pipectl/pipectl-0.5.0.ebuild
new file mode 100644
index 000000000..330ad1f94
--- /dev/null
+++ b/sys-process/pipectl/pipectl-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="a simple named pipe management utility"
+HOMEPAGE="https://github.com/Ferdi265/pipectl"
+SRC_URI="https://github.com/Ferdi265/pipectl/releases/download/v${PV}/pipectl-${PV}.tar.gz"
+
+LICENSE="GPL-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="man"
+
+DEPEND="
+ man? (
+ app-text/scdoc
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex man)
+ -DINSTALL_DOCUMENTATION=$(usex man)
+ )
+
+ cmake_src_configure
+}
+