aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-05-03 22:02:31 -0500
committerZen <z@pyl.onl>2024-05-03 22:02:31 -0500
commit6bd7769cbdbc0d04ad19d719187a021a2f28c9d9 (patch)
treea194ae01cdb854e5c90de27c22ab081fca56a5bc /sys-kernel
parentnet-im/vesktop-bin: Update dependencies to resolve unresolved SONAME dependen... (diff)
downloadguru-6bd7769cbdbc0d04ad19d719187a021a2f28c9d9.tar.gz
guru-6bd7769cbdbc0d04ad19d719187a021a2f28c9d9.tar.bz2
guru-6bd7769cbdbc0d04ad19d719187a021a2f28c9d9.zip
sys-kernel/ugrd: Add 1.2.2
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.2.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index 803c2156f..cbac70313 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -7,3 +7,4 @@ DIST ugrd-0.22.0.tar.gz 44444 BLAKE2B 01c4cc36ea778c12478b3b2f6db76180f9b7ef8d21
DIST ugrd-1.0.0.tar.gz 46125 BLAKE2B 8f941f8cadcbfb92ad4be02ca5763779bcd57bdd3545a5526b642d288591ea76e6ffcd4e0962c9ac36ff31f177b4fd2ee7b5b3351147e9f1e0a1dc478da399e0 SHA512 f7629acdffb952f8b8c79969043574420cff821523c38627c4234d4ca0f93a38349f8acdf3a473bd5fd3f4854fd0b82bb4367e57b999674b8a550609a76330d3
DIST ugrd-1.1.5.tar.gz 47005 BLAKE2B 278831157c3f8b5d731f3acbdf41c19b1c6485b46acf7d2b75df40a9d9f542365514e814d1972a03bd4b53dad2d39a27098e4cfc97d526afdf4d45ccf5778691 SHA512 c198c592af40d2f126a333a03c74c638260ea8125f4a4da6f97d3489d2ddcf7edb5dce785eb236d309853dac6a3e7993186e4c6b775c4eccc121e95d308641dc
DIST ugrd-1.2.0.tar.gz 48323 BLAKE2B 8df44c91dd56da6d27eaf2c769b40ad7a008a71a87f2f33d1ab91d96e16cf680bb046af27d0b50ae79d48ad8d5b046d899e246ca44c18e62dae8f54fff9cace6 SHA512 a3ddd95abd30441013c9a11074052629dfdbcd2cfffd6a754c6d9c3b719b1861abcd613228fa613b6f566ca1cdca5fa881c9a302391c594b53096428d35e37bf
+DIST ugrd-1.2.2.tar.gz 49312 BLAKE2B 819457ae44cb278b93ef24af5e0aa2e23bf2d31d07fccec86e597f658a5cb13aad7838b08df644090417719402673b63087d27b6edbdb46dea04b98b48d26fb0 SHA512 6348458708406408973534ac5f15f8f9f6d9427bbac48443f7ff362bb97627be6288ba2d138355f92fc1c79a4eb5e51081485adb051cadf523a58f1ef618667e
diff --git a/sys-kernel/ugrd/ugrd-1.2.2.ebuild b/sys-kernel/ugrd/ugrd-1.2.2.ebuild
new file mode 100644
index 000000000..a474bbc7a
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-misc/pax-utils
+>=dev-python/zenlib-2.0.4[${PYTHON_USEDEP}]
+>=dev-python/pycpio-1.0.0[${PYTHON_USEDEP}]
+sys-apps/pciutils"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ keepdir /etc/kernel/preinst.d
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/51-ugrd.install
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+}