aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-02-16 21:43:32 -0500
committerDale Showers <gentoo@fictx.com>2024-02-16 21:44:39 -0500
commit1626d08afc391835d5027686855e2e002d203d77 (patch)
tree7a203037edd45f2384853fc38498d251bd85d046 /net-voip/baresip/baresip-3.7.0.ebuild
parentmpv-plugin/mpv_sponsorblock_minimal: update snapshot (diff)
downloadguru-1626d08afc391835d5027686855e2e002d203d77.tar.gz
guru-1626d08afc391835d5027686855e2e002d203d77.tar.bz2
guru-1626d08afc391835d5027686855e2e002d203d77.zip
net-voip/*: add baresip & re
Signed-off-by: Dale Showers <gentoo@fictx.com>
Diffstat (limited to 'net-voip/baresip/baresip-3.7.0.ebuild')
-rw-r--r--net-voip/baresip/baresip-3.7.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-voip/baresip/baresip-3.7.0.ebuild b/net-voip/baresip/baresip-3.7.0.ebuild
new file mode 100644
index 000000000..d1e006f92
--- /dev/null
+++ b/net-voip/baresip/baresip-3.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Baresip is a portable and modular SIP User-Agent"
+HOMEPAGE="https://github.com/baresip/baresip"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+
+IUSE="aac alsa amr aptx aom codec2 ffmpeg gst gtk3 jack mqtt mpa opus ssl png portaudio pulseaudio pipewire sdl sndfile spandsp vpx X"
+
+DEPEND="
+ ~net-voip/re-${PV}
+ aac? ( media-libs/fdk-aac )
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ aptx? ( media-libs/libopenaptx )
+ aom? ( media-libs/libaom )
+ codec2? ( media-libs/codec2 )
+ ffmpeg? ( media-video/ffmpeg )
+ gst? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ gtk3? ( x11-libs/gtk+:3 )
+ jack? ( virtual/jack )
+ mqtt? ( app-misc/mosquitto )
+ mpa? (
+ media-sound/twolame
+ media-sound/mpg123
+ media-libs/speexdsp
+ )
+ ssl? ( dev-libs/openssl:0= )
+ opus? ( media-libs/opus )
+ png? ( media-libs/libpng )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-libs/libpulse )
+ pipewire? ( media-video/pipewire )
+ sdl? ( media-libs/libsdl2 )
+ sndfile? ( media-libs/libsndfile )
+ spandsp? ( media-libs/spandsp )
+ vpx? ( media-libs/libvpx )
+ X? ( x11-libs/libX11 )
+ "
+
+RDEPEND="${DEPEND}"