aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-04 12:05:25 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-05 00:11:00 +0500
commitd6e707f480ed53054c959f189ed15f9f2a162d4d (patch)
tree63f85a9cc8f009d24bc0802bc5f5e3b5a8fd4722 /gui-wm
parentx11-wm/phoc: add 0.36.0, drop 0.33.0 (diff)
downloadguru-d6e707f480ed53054c959f189ed15f9f2a162d4d.tar.gz
guru-d6e707f480ed53054c959f189ed15f9f2a162d4d.tar.bz2
guru-d6e707f480ed53054c959f189ed15f9f2a162d4d.zip
gui-wm/phoc: rename x11-wm/phoc
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/phoc/Manifest2
-rw-r--r--gui-wm/phoc/metadata.xml12
-rw-r--r--gui-wm/phoc/phoc-0.35.0.ebuild85
-rw-r--r--gui-wm/phoc/phoc-0.36.0.ebuild85
-rw-r--r--gui-wm/phosh/metadata.xml7
-rw-r--r--gui-wm/phosh/phosh-0.17.0.ebuild2
6 files changed, 189 insertions, 4 deletions
diff --git a/gui-wm/phoc/Manifest b/gui-wm/phoc/Manifest
new file mode 100644
index 000000000..7d1927efb
--- /dev/null
+++ b/gui-wm/phoc/Manifest
@@ -0,0 +1,2 @@
+DIST phoc-0.35.0.tar.xz 677432 BLAKE2B 722a3669b1d76015612b5f4020d0e21c47faa8f6fb19887b2b79d4f6b79e30f45e0332ae2e2771fb9169214002508bdcff61ee0e7f874930e03a7cf952c44e7c SHA512 ec4b382ef11b257afe3b13ebf1e588353c785279afde4b1a8ee80790cb6a299fd94098a5170b30a2114061d86bdf388bb1c99f8ce1bd5173deb886d11015681e
+DIST phoc-0.36.0.tar.xz 681384 BLAKE2B 6c27c785dd01f9e44cb0940c5a4f73d5ce75cad85808d0b6c801360401ff001cca839abd27bc8442702c5241bac043c6d7015e6f1c5a5ec30cfcb6779adf973b SHA512 a47851a3e222958ad55c05ed86a068b30f6e00ed5d7e957aab99e7f4103b95fee4db6b177f2de8d0c9ce11306c68ef74d78e38ea0bdb6c47e66f9ef9bf0e9f66
diff --git a/gui-wm/phoc/metadata.xml b/gui-wm/phoc/metadata.xml
new file mode 100644
index 000000000..104ee5fe1
--- /dev/null
+++ b/gui-wm/phoc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gjdijkman@gjdwebserver.nl</email>
+ <name>Gerben Jan Dijkman</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://source.puri.sm/Librem5/phoc/-/issues</bugs-to>
+ <remote-id type="gnome-gitlab">World/Phosh/phoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-wm/phoc/phoc-0.35.0.ebuild b/gui-wm/phoc/phoc-0.35.0.ebuild
new file mode 100644
index 000000000..6b3b29f93
--- /dev/null
+++ b/gui-wm/phoc/phoc-0.35.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Wayland compositor for mobile phones"
+HOMEPAGE="https://gitlab.gnome.org/World/Phosh/phoc"
+SRC_URI="https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3+ MIT ) GPL-3+ LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+X gtk-doc man test"
+REQUIRED_USE="test? ( X )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2
+ dev-libs/json-glib
+ dev-libs/libinput:=
+ dev-libs/wayland
+ >=gnome-base/gnome-desktop-3.26:3
+ gnome-base/gsettings-desktop-schemas
+ >=gui-libs/wlroots-0.17.1:=[X?]
+ <gui-libs/wlroots-0.18.0
+ media-libs/libglvnd
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon[X?,wayland]
+ test? (
+ gui-libs/wlroots[x11-backend]
+ x11-wm/mutter
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/glib:2
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ sys-devel/gettext
+ gtk-doc? ( dev-util/gi-docgen )
+ man? ( dev-python/docutils )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature X xwayland)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use man)
+ $(meson_use test tests)
+ -Dembed-wlroots=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ local -x LC_ALL="C.UTF-8"
+ local -x WLR_RENDERER="pixman"
+
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}-${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+
+ newbin helpers/auto-maximize phoc-auto-maximize
+ newbin helpers/scale-to-fit phoc-scale-to-fit
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gui-wm/phoc/phoc-0.36.0.ebuild b/gui-wm/phoc/phoc-0.36.0.ebuild
new file mode 100644
index 000000000..6b3b29f93
--- /dev/null
+++ b/gui-wm/phoc/phoc-0.36.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Wayland compositor for mobile phones"
+HOMEPAGE="https://gitlab.gnome.org/World/Phosh/phoc"
+SRC_URI="https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3+ MIT ) GPL-3+ LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+X gtk-doc man test"
+REQUIRED_USE="test? ( X )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2
+ dev-libs/json-glib
+ dev-libs/libinput:=
+ dev-libs/wayland
+ >=gnome-base/gnome-desktop-3.26:3
+ gnome-base/gsettings-desktop-schemas
+ >=gui-libs/wlroots-0.17.1:=[X?]
+ <gui-libs/wlroots-0.18.0
+ media-libs/libglvnd
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon[X?,wayland]
+ test? (
+ gui-libs/wlroots[x11-backend]
+ x11-wm/mutter
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/glib:2
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ sys-devel/gettext
+ gtk-doc? ( dev-util/gi-docgen )
+ man? ( dev-python/docutils )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature X xwayland)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use man)
+ $(meson_use test tests)
+ -Dembed-wlroots=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ local -x LC_ALL="C.UTF-8"
+ local -x WLR_RENDERER="pixman"
+
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}-${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+
+ newbin helpers/auto-maximize phoc-auto-maximize
+ newbin helpers/scale-to-fit phoc-scale-to-fit
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gui-wm/phosh/metadata.xml b/gui-wm/phosh/metadata.xml
index ec76e1db3..dbc793aa3 100644
--- a/gui-wm/phosh/metadata.xml
+++ b/gui-wm/phosh/metadata.xml
@@ -6,11 +6,12 @@
<name>Gerben Jan Dijkman</name>
</maintainer>
<longdescription lang="en">
- A pure Wayland shell prototype for GNOME on mobile devices. For a matching compositor see x11-wm/phoc but others implementing wlr-layer-shell should work as well.
+ A pure Wayland shell for GNOME on mobile devices. For a matching
+ compositor see gui-wm/phoc but others implementing wlr-layer-shell
+ should work as well.
</longdescription>
<upstream>
- <doc>https://source.puri.sm/Librem5/phosh</doc>
- <bugs-to>https://source.puri.sm/Librem5/phosh/-/issues</bugs-to>
+ <bugs-to>https://gitlab.gnome.org/World/Phosh/phosh/-/issues</bugs-to>
<remote-id type="gnome-gitlab">World/Phosh/phosh</remote-id>
</upstream>
</pkgmetadata>
diff --git a/gui-wm/phosh/phosh-0.17.0.ebuild b/gui-wm/phosh/phosh-0.17.0.ebuild
index 7c03bce85..d2af27daf 100644
--- a/gui-wm/phosh/phosh-0.17.0.ebuild
+++ b/gui-wm/phosh/phosh-0.17.0.ebuild
@@ -35,7 +35,7 @@ DEPEND="
x11-themes/gnome-backgrounds
gnome-base/gnome-keyring
gnome-base/gnome-shell
- x11-wm/phoc
+ gui-wm/phoc
systemd? ( sys-apps/systemd )
sys-power/upower
app-misc/geoclue